7.7 Удаление записи периодического реквизита

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем djyarilo, 2 май 2012.

  1. TopicStarter Overlay
    djyarilo
    Offline

    djyarilo Опытный в 1С

    Регистрация:
    18 апр 2011
    Сообщения:
    435
    Симпатии:
    0
    Баллы:
    26
    Пытаюсь удалить значения пер реквизита(перечисление)
    Код:
    _Дата = НачДата;
    спр = СоздатьОбъект("Справочник.Номенклатура");
    Период =СоздатьОбъект("Периодический");
    спр.ВыбратьЭлементы(0);
    Пока спр.ПолучитьЭлемент()>0 Цикл
    Период.ИспользоватьОбъект(спр.КатегорияПродоваймости,спр);
    Период.ВыбратьЗначения();
    пока Период.ПолучитьЗначение() = 1 Цикл
    если Период.Значение=Перечисление.КатегорииПродаваймостиТовара.В Тогда
    Период.Удалить();
    КонецЕсли;
    
    
    КонецЦикла;
    
    
    КонецЦикла;
    постоянно выдает ошибку якобы нужно ИСПОЛЬЗВОВАТЬ ОБЪЕКТ. именно когда удаляю. Если заменить на сообщить(период.значение). ТО там все нормально. Уже все форумы облазил не могу понять что ему надо то
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    ИспользоватьОбъект(<ИмяРеквизита>,<Объект>)
    вот тут у вас не так....
    ИмяРеквизита - строка с именем реквизита.
    Т.е. д.б. так
    Код:
    ИспользоватьОбъект("ТутИмяРеквизита",Спр.ТекущийЭлемент())
    Для примера смотрим эту обработку
    http://www.1c-pro.ru/topic3050.html/page__view__findpost__p__89765
Похожие темы
  1. W@rt
    Ответов:
    1
    Просмотров:
    552
  2. Jivchic
    Ответов:
    4
    Просмотров:
    3.094
  3. o_O
    Ответов:
    21
    Просмотров:
    2.858
  4. consol
    Ответов:
    1
    Просмотров:
    615
  5. sashadeo
    Ответов:
    3
    Просмотров:
    407
Загрузка...

Поделиться этой страницей