8.х Удаление строки таблицы значений

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Pilgrim, 19 дек 2006.

  1. TopicStarter Overlay
    Pilgrim
    Offline

    Pilgrim Опытный в 1С

    Регистрация:
    13 сен 2006
    Сообщения:
    242
    Симпатии:
    0
    Баллы:
    26
    Народ, просто интересно. Столкнулся с такой вещью, если сделать цикл
    Для Каждого СтрТаблицы Из ТабОстатков Цикл
    Если СтрТаблицы.Количество = 0 Тогда
    ТабОстатков.Удалить(СтрТаблицы);
    КонецЕсли;
    КонецЦикла;

    то не все строки удаляет, так как я думаю, что метод Удалить ставится на следующую неудаленную строку, а Для каждого соответственно идет дальше и одна строка терятся.

    я сделал
    й = 0;
    Пока й < ТабОстатков.Количество() Цикл
    СтрТаблицы = ТабОстатков.Получить(й);
    Если СтрТаблицы.Количество = 0) Тогда
    ТабОстатков.Удалить(СтрТаблицы);
    й = й - 1;
    КонецЕсли;
    й = й + 1;
    КонецЦикла;

    и все нормально, но как-то некрасиво получается другого способа нет никакого?

Поделиться этой страницей