7.7 Удаление повторяющихся строк

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем NemeL, 27 фев 2012.

  1. TopicStarter Overlay
    NemeL
    Offline

    NemeL Опытный в 1С

    Регистрация:
    11 фев 2011
    Сообщения:
    73
    Симпатии:
    0
    Баллы:
    26
    добрый день, подскажите как можно удалить одинаковые строки из ТЧ, приведу пример: щас вот так все(Наименование в 1 и во 2 строке одинаковые)
    Код:
    №|наим|кол-во|цена
    1 |Телефон|2 |2000
    2|Телефон|3|2000
    
    а хотелось бы вот так
    Код:
    №|наим|кол-во|цена
    1 |Телефон|5|2000
    
    попробывал вот так сделать

    Код:
    Процедура УдалениеПовторов()
    Если КоличествоСтрок() > 0 Тогда
    ПолучитьСтрокуПоНомеру(1);
    Предыдущий=Наим;
    Иначе
    Сообщить("Документ не заполнен");
    Возврат;
    КонецЕсли;
    итогКол=0;
    ВыбратьСтроки();
    Пока ПолучитьСтроку()=1 Цикл
    Если СокрЛП(Наим) <> СокрЛП(Предыдущий) Тогда
    количество=ИтогКол+Количество;
    Удалитьстроку();
    Предыдущий = Сравнение;
    ИтогКол=0;
    КонецЕсли;	
    КонецЦикла;
    КонецПроцедуры
    
    в чем ошибка подскажите?
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Выгрузите табличную часть в таблицу значений и сверните....
    Код:
    ТЗ=СоздатьОбъект("ТаблицаЗначений");
    ВыгрузитьТабличнуюЧасть(ТЗ);
    ТЗ.Свернуть("ТМЦ","Количество");//укажите правильно имена колонок
    ЗагрузитьТабличнуюЧасть(ТЗ);
  3. Requin
    Offline

    Requin Опытный в 1С

    Регистрация:
    10 май 2010
    Сообщения:
    1.911
    Симпатии:
    2
    Баллы:
    29
    Цена пропадет. Надо в группировочные колонки ее тоже добавить:
    Код:
    ТЗ.Свернуть("ТМЦ,Цена","Количество");
  4. TopicStarter Overlay
    NemeL
    Offline

    NemeL Опытный в 1С

    Регистрация:
    11 фев 2011
    Сообщения:
    73
    Симпатии:
    0
    Баллы:
    26
    Requin -ага так я и сделал, Бухгалтерский угодник - спасибо, как всегда все просто. Извените за тупой вопрос.
  5. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    NemeL для "спасибо" есть кнопка


    Requin точно.. не обратил внимание

Поделиться этой страницей