7.7 Удаление истории периодических реквизитов

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Steel Rain, 5 июн 2007.

  1. TopicStarter Overlay
    Steel Rain
    Offline

    Steel Rain Опытный в 1С

    Регистрация:
    29 сен 2006
    Сообщения:
    408
    Симпатии:
    2
    Баллы:
    29
    Всем привет.
    (платформа 7.7, конфига ТиС 8.7 переписанная)
    В чем суть проблемы: Нужно в справочнике Цены (соответственно для всех элементов справочника Номенклатура) очистить историю периодических реквизитов (Валюта, Единица, Цена) за выбранный период (скажем так, с начала времен по 01.01.2007).
    Может у кого обработочка завалялась?
  2. TopicStarter Overlay
    Steel Rain
    Offline

    Steel Rain Опытный в 1С

    Регистрация:
    29 сен 2006
    Сообщения:
    408
    Симпатии:
    2
    Баллы:
    29
    Всем заинтересовавшимся, вот что получилось:
    ...может кому сгодиться...


    Код:
    //*******************************************
    Процедура Сформировать()
    
    Товар=СоздатьОбъект("Справочник.Номенклатура");
    Цена=СоздатьОбъект("Справочник.Цены");
    Период=СоздатьОбъект("Периодический");
    Товар.ВыбратьЭлементы();
    Пока Товар.ПолучитьЭлемент()=1 Цикл
    Если Товар.ЭтоГруппа()=0 Тогда
    Цена.ИспользоватьВладельца(Товар.ТекущийЭлемент());
    Цена.ВыбратьЭлементы();
    Пока Цена.ПолучитьЭлемент()=1 Цикл
    МетСправочник = Метаданные.Справочник("Цены");
    Для Номер = 1 по МетСправочник.Реквизит() Цикл
    Если МетСправочник.Реквизит(Номер).Периодический=1 Тогда
    Период.ИспользоватьОбъект(МетСправочник.Реквизит(Номер).Идентификатор,Цена.ТекущийЭлемент());
    Период.ВыбратьЗначения();   
    Пока Период.ПолучитьЗначение()=1 Цикл
    
    Если Период.ДатаЗнач<'01.01.2007' Тогда
    
    Период.Удалить();
    КонецЕсли;   
    КонецЦикла;   
    КонецЕсли;
    КонецЦикла;   
    КонецЦикла;
    КонецЕсли;   
    КонецЦикла;
    КонецПроцедуры
    
    
    
Похожие темы
  1. Olga_programmer
    Ответов:
    6
    Просмотров:
    1.515
  2. Mirvel
    Ответов:
    9
    Просмотров:
    1.385
  3. sergey484
    Ответов:
    2
    Просмотров:
    1.600
  4. phcode
    Ответов:
    14
    Просмотров:
    2.208
  5. badhaker
    Ответов:
    16
    Просмотров:
    2.148
Загрузка...

Поделиться этой страницей