8.х ЗУП Учёт начислений

Тема в разделе ""1С:Зарплата и управление персоналом ЗУП"", создана пользователем dlis, 2 июл 2013.

  1. TopicStarter Overlay
    dlis
    Offline

    dlis Опытный в 1С

    Регистрация:
    29 июл 2011
    Сообщения:
    266
    Симпатии:
    0
    Баллы:
    26
    табель будет набиваться в ручную, по данным табеля буду формировать вытеснения основного начисления ,то есть если была явка в количестве часов равном часам по графику - то целодневный невывод, если явки меньше, то внутрисменный невывод и так по каждому числу наряда. а всём сотрудникам у которых есть сделка буду назначать плановое начисление "Сделка" вид учета времени - "Дополнительное начисление за уже оплаченное время" способ расчета - "Сдельный заработок"

    как вы думаете, сработает это??
  2. svet
    Offline

    svet Профессионал в 1С Команда форума

    Регистрация:
    9 ноя 2007
    Сообщения:
    1.971
    Симпатии:
    59
    Баллы:
    54
    Как-то все у вас навернуто получается, совсем уже нестандартно... Сработать-то оно может быть и сработает, но, боюсь, вам и дальше придется программу перепахивать.

    А насколько вам важно выделять доплаты отдельными видами расчета? Может быть все-таки проще заполнять стандартный наряд и записывать туда общую сумму? Можно же использовать ваш самописный документ для подготовки данных: рассчитывать все доплаты и суммы по каждому наряду, а в конце месяца обработкой собрать данные по самописным документам и сводно записать в стандартный наряд.
  3. TopicStarter Overlay
    dlis
    Offline

    dlis Опытный в 1С

    Регистрация:
    29 июл 2011
    Сообщения:
    266
    Симпатии:
    0
    Баллы:
    26
    ну во-первых расчет сделки на нашем предприятии слишком уж замудрёный отличается от типового, а во-вторых - начисления должны отражаться в расчетнике, то есть если человек работал в месяц на двух объектах и на повременке то расчетник примет вид:

    оклад
    премии на оклад
    ......
    сделка 1
    премии на сделку 1
    .....
    сделка 2
    премии на сделку 2
    .....
  4. TopicStarter Overlay
    dlis
    Offline

    dlis Опытный в 1С

    Регистрация:
    29 июл 2011
    Сообщения:
    266
    Симпатии:
    0
    Баллы:
    26
    что то я смотрю что не получиться проводить отражение основных начислений по одному работнику за месяц по разным счетам
  5. svet
    Offline

    svet Профессионал в 1С Команда форума

    Регистрация:
    9 ноя 2007
    Сообщения:
    1.971
    Симпатии:
    59
    Баллы:
    54
    Должно получиться.
    В стандартном варианте это решается вводом распределения основной зарплаты по сотруднику.
    В нестандартном мы уже 4-й год переделываем стандартные сформированные документы "Отражение зарплаты" внешними обработками: берем ТЧ Основные и Дополнительные начисления, переписываем их обработками так, как нам надо, а потом на закладке "Проводки" жмем "Сформировать проводки". Все прокатывает.
  6. TopicStarter Overlay
    dlis
    Offline

    dlis Опытный в 1С

    Регистрация:
    29 июл 2011
    Сообщения:
    266
    Симпатии:
    0
    Баллы:
    26
    Посмотреть вложение 15376

    вот проведение по отражению основных начислений, период регистрации - месяц, а если у человека данное начисление в месяце несколько раз по разным счетам должно проводиться (новый наряд - новое отражение, причем и в пределах дня), не "перекроются" ли записи регистра?? или надо период регистрации ставить на время наряда?

    Вложения:

    • 17.PNG
      17.PNG
      Размер файла:
      34,3 КБ
      Просмотров:
      2
  7. svet
    Offline

    svet Профессионал в 1С Команда форума

    Регистрация:
    9 ноя 2007
    Сообщения:
    1.971
    Симпатии:
    59
    Баллы:
    54
    Насколько я помню, стандартное отражение сворачивает по аналитике, поэтому в регистрах не перекрывается.
  8. TopicStarter Overlay
    dlis
    Offline

    dlis Опытный в 1С

    Регистрация:
    29 июл 2011
    Сообщения:
    266
    Симпатии:
    0
    Баллы:
    26
    а то что период регистрации один, ничего страшного?
  9. svet
    Offline

    svet Профессионал в 1С Команда форума

    Регистрация:
    9 ноя 2007
    Сообщения:
    1.971
    Симпатии:
    59
    Баллы:
    54
    Да проходит, насколько я помню, нормально, если другие реквизиты различаются.
  10. TopicStarter Overlay
    dlis
    Offline

    dlis Опытный в 1С

    Регистрация:
    29 июл 2011
    Сообщения:
    266
    Симпатии:
    0
    Баллы:
    26
    ок, а как быть с периодом действия, ведь может быть такая ситуация: сотрудник работает по сдельному наряду на объекту 1 с 3 по 6 число месяца и с 18 по 21,
    по другому сдельному на другом объекте работает с 15 по 17, все остальные дни - повременка.

    придется наверное отражать на каждый день, то есть период действия будет 1 день и сумма пропорционально разбиваться
  11. svet
    Offline

    svet Профессионал в 1С Команда форума

    Регистрация:
    9 ноя 2007
    Сообщения:
    1.971
    Симпатии:
    59
    Баллы:
    54
    Там главное различать в какой регистр пишешь:

    в регистры отражение основных и дополнительных есть период действия записи, его надо будет заполнять (с 3 по 6 - отдельной строкой, с 18 по 21 - второй и т.д.) . Этот регистр стандартно заполняется из ТЧ Основные и дополнительные начисления документа "Отражение зарплаты".

    в регистр по проводкам - там идет регистр бухгалтерии и проблем возникнуть не должно. Единственное - проводки туда обычно сворачиваются по аналитике.
  12. TopicStarter Overlay
    dlis
    Offline

    dlis Опытный в 1С

    Регистрация:
    29 июл 2011
    Сообщения:
    266
    Симпатии:
    0
    Баллы:
    26
    то есть в регистр бухгалтерии писать "сводно" за наряд, не разбивать на периоды?
  13. svet
    Offline

    svet Профессионал в 1С Команда форума

    Регистрация:
    9 ноя 2007
    Сообщения:
    1.971
    Симпатии:
    59
    Баллы:
    54
    Ну да. В стандартном наряде в регистр бухгалтерии попадает столько строк, сколько введено технологических операций.
  14. TopicStarter Overlay
    dlis
    Offline

    dlis Опытный в 1С

    Регистрация:
    29 июл 2011
    Сообщения:
    266
    Симпатии:
    0
    Баллы:
    26
    как я понял, то дополнительные начисления (все повышения на выработку) тоже писать по дням ка и основные в отражение
  15. TopicStarter Overlay
    dlis
    Offline

    dlis Опытный в 1С

    Регистрация:
    29 июл 2011
    Сообщения:
    266
    Симпатии:
    0
    Баллы:
    26

    Вложения:

    • 18.png
      18.png
      Размер файла:
      214,9 КБ
      Просмотров:
      4
  16. svet
    Offline

    svet Профессионал в 1С Команда форума

    Регистрация:
    9 ноя 2007
    Сообщения:
    1.971
    Симпатии:
    59
    Баллы:
    54
    :) Так надо просто поробовать и станет видно - прокатит или не прокатит.
  17. TopicStarter Overlay
    dlis
    Offline

    dlis Опытный в 1С

    Регистрация:
    29 июл 2011
    Сообщения:
    266
    Симпатии:
    0
    Баллы:
    26
    Сделал движения по РР "БУДополнительныеНачисления", но они в документе отражение начислений на вкладке доп. начисления разносятся не по тем счетам!??

    Посмотреть вложение 15484 Посмотреть вложение 15483

    Код:
    Функция ДобавитьСтрокуВДвиженияПоБУДопНачислений(ДатаНачала, ДатаОкончания, ВидРасчета, Сотрудник, Результат, СтрокаТЗ)
    
    СчетУчетаРасчетовСРаботниками = ПланыСчетов.Хозрасчетный.РасчетыСПерсоналомПоОплатеТруда;
    СчетУчетаРасчетовСРаботникамиНУ = ПланыСчетов.Налоговый.РасчетыСПерсоналомПоОплатеТруда;
    
    СтрокаНабора = Движения.БУДополнительныеНачисления.Добавить();
    
    // свойства
    СтрокаНабора.ПериодРегистрации   = ПериодРегистрации;
    
    СтрокаНабора.ПериодДействияНачало  = ДатаНачала;
    СтрокаНабора.ПериодДействияКонец  = ДатаОкончания;
    
    СтрокаНабора.ВидРасчета	 = ВидРасчета;
    
    // Измерения
    СтрокаНабора.Сотрудник	 = Сотрудник;
    СтрокаНабора.Физлицо	 = СтрокаНабора.Сотрудник.Физлицо;
    СтрокаНабора.Организация	= Организация;
    
    // ресурсы
    СтрокаНабора.Результат	 = Результат;
    
    // реквизиты
    // СтрокаНабора.ГрафикРаботы	= ПолучитьГрафикСотрудникаНаДату(Сотрудник, ДатаНачала);
    // СтрокаНабора.ВидУчетаВремени   = Перечисления.ВидыУчетаВремени.ПоЧасам;
    СтрокаНабора.ОбособленноеПодразделение = Организация;
    //СтрокаНабора.ДокументОснование   = ВыборкаПоШапкеДокумента.Ссылка;
    
    // данные бухучета
    СтрокаНабора.СчетДт	  = СтрокаТЗ.СчетЗатрат;
    СтрокаНабора.СчетКт	  = СчетУчетаРасчетовСРаботниками;
    
    // субконто
    Для СчСк = 1 По 3 Цикл
    
    ВидыСубконтоСк = СтрокаТЗ["ВидСубконто" + СчСк];
    
    Если ВидыСубконтоСк = NULL Тогда
    
    ИначеЕсли ВидыСубконтоСк = ПланыВидовХарактеристик.ВидыСубконтоХозрасчетные.Номенклатура Тогда
    СтрокаНабора["СубконтоДт" + СчСк] = СтрокаТЗ.Продукция;
    ИначеЕсли ВидыСубконтоСк = ПланыВидовХарактеристик.ВидыСубконтоХозрасчетные.СтатьиЗатрат Тогда
    СтрокаНабора["СубконтоДт" + СчСк] = СтрокаТЗ.СтатьяЗатрат;
    ИначеЕсли ВидыСубконтоСк = ПланыВидовХарактеристик.ВидыСубконтоХозрасчетные.НоменклатурныеГруппы Тогда
    СтрокаНабора["СубконтоДт" + СчСк] = СтрокаТЗ.НоменклатурнаяГруппа;
    ИначеЕсли ВидыСубконтоСк = ПланыВидовХарактеристик.ВидыСубконтоХозрасчетные.Подразделения Тогда
    СтрокаНабора["СубконтоДт" + СчСк] = СтрокаТЗ.ПодразделениеОрганизации;
    ИначеЕсли ВидыСубконтоСк = ПланыВидовХарактеристик.ВидыСубконтоХозрасчетные.ОбъектыСтроительства Тогда
    СтрокаНабора["СубконтоДт" + СчСк] = СтрокаТЗ.ОбъектСтроительства;
    СтрокаНабора["СубконтоДт" + (СчСк + 1)] = Перечисления.СпособыСтроительства.Хозспособ;
    КонецЕсли;
    
    КонецЦикла;
    
    СтрокаНабора.СубконтоКт1 = СтрокаНабора.Сотрудник.Физлицо;
    
    
    СтрокаНабора.СчетДтНУ = СтрокаТЗ.СчетЗатратНУ;
    СтрокаНабора.СчетКтНУ = СчетУчетаРасчетовСРаботникамиНУ;
    
    // субконто
    Для СчСк = 1 По 3 Цикл
    
    ВидыСубконтоСк = СтрокаТЗ["ВидСубконтоНУ" + СчСк];
    
    Если ВидыСубконтоСк = NULL Тогда
    
    ИначеЕсли ВидыСубконтоСк = ПланыВидовХарактеристик.ВидыСубконтоХозрасчетные.Номенклатура Тогда
    СтрокаНабора["СубконтоДтНУ" + СчСк] = СтрокаТЗ.Продукция;
    ИначеЕсли ВидыСубконтоСк = ПланыВидовХарактеристик.ВидыСубконтоХозрасчетные.СтатьиЗатрат Тогда
    СтрокаНабора["СубконтоДтНУ" + СчСк] = СтрокаТЗ.СтатьяЗатрат;
    ИначеЕсли ВидыСубконтоСк = ПланыВидовХарактеристик.ВидыСубконтоХозрасчетные.НоменклатурныеГруппы Тогда
    СтрокаНабора["СубконтоДтНУ" + СчСк] = СтрокаТЗ.НоменклатурнаяГруппа;
    ИначеЕсли ВидыСубконтоСк = ПланыВидовХарактеристик.ВидыСубконтоХозрасчетные.Подразделения Тогда
    СтрокаНабора["СубконтоДтНУ" + СчСк] = СтрокаТЗ.ПодразделениеОрганизации;
    ИначеЕсли ВидыСубконтоСк = ПланыВидовХарактеристик.ВидыСубконтоХозрасчетные.ОбъектыСтроительства Тогда
    СтрокаНабора["СубконтоДтНУ" + СчСк] = СтрокаТЗ.ОбъектСтроительства;
    СтрокаНабора["СубконтоДтНУ" + (СчСк + 1)] = Перечисления.СпособыСтроительства.Хозспособ;
    КонецЕсли;
    
    КонецЦикла;
    
    СтрокаНабора.СубконтоКтНУ1 = СтрокаНабора.Сотрудник.Физлицо;
    //СтрокаНабора.СубконтоКтНУ2 = ВыборкаПоРаботники.ВидНачисленияНУ;
    
    КонецФункции
    

    Вложения:

    • 20.png
      20.png
      Размер файла:
      175,7 КБ
      Просмотров:
      3
    • 19.png
      19.png
      Размер файла:
      36,9 КБ
      Просмотров:
      3
  18. TopicStarter Overlay
    dlis
    Offline

    dlis Опытный в 1С

    Регистрация:
    29 июл 2011
    Сообщения:
    266
    Симпатии:
    0
    Баллы:
    26
    смотрел запрос на получение начислений - надоело проматывать колесом мышки, уж очень здоровенный, собирается из разных кусков, нереально разобраться((
    может кто знает как должны "собираться" данные об отражении начислений в этом документе???
  19. TopicStarter Overlay
    dlis
    Offline

    dlis Опытный в 1С

    Регистрация:
    29 июл 2011
    Сообщения:
    266
    Симпатии:
    0
    Баллы:
    26
    что нужно сделать, чтобы указать что на заданную дату дополнительное начисление по работнику отражалось по заданным счетам???
  20. TopicStarter Overlay
    dlis
    Offline

    dlis Опытный в 1С

    Регистрация:
    29 июл 2011
    Сообщения:
    266
    Симпатии:
    0
    Баллы:
    26
    Подскажите, быть может что-то делаю не так?
    вот мои действия:
    1. Планово назначаю "свое" начисление "Сделка" - вид времени - доп. начисл. за отр. время. способ расчета - выработка.
    2. В "своем" док. "Сдельный наряд" рассчитываю сдельную ЗП, там же рассчитываю доплаты за переработку и доп. начисления, база которых тоже хитро рассчитывается (не выработка).
    3. Делаю движения по выработке, по дням с суммами пропорционально отработанному времени.
    4. Делаю движения по основным начислениям "Доплата за работу выходной и праздничный день" (сверхурочно), по дням переработок, с суммами пропорционально отработанному времени.
    5. Делаю движения по дополнительным начислениям с суммами рассчитанных доплат.
    6. Делаю движения "хитрые" по основным начислениям, в зависимости от того, отработал ли работник целую смену (часов как по графику), то провожу целосменную неявку, иначе внутрисменную неявку. Это всё необходимо для вытеснения основного начисления.
    7. Делаю движения по РР "БУОсновныеНачисления" с данными: вид расчета - "Сделка" (п.1) для каждого сотрудника по датам и суммами пропорционально отраб. времени и способом отражения, указанным в техоперации. Здесь же делаются движения для видов расчета переработок.
    8. Делаю тоже самое что и в п. 7, но по РР "БУДополнительныеНачисления".

    В итоге получаю всё как надо, кроме того, что в док. отражение ЗП доп. начисления отражаются способом указанным по-умолчанию, а не из РР "БУДополнительныеНачисления".
    Основные начисления вроде верно "ложаться".
Похожие темы
  1. tana
    Ответов:
    3
    Просмотров:
    571
  2. Юджин
    Ответов:
    8
    Просмотров:
    3.633
  3. rom_strizh
    Ответов:
    0
    Просмотров:
    715
  4. nomad_irk
    Ответов:
    9
    Просмотров:
    422
  5. Dmitriy_76
    Ответов:
    5
    Просмотров:
    337
Загрузка...

Поделиться этой страницей