7.7 Учет покупателей

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем SerzhM, 9 июл 2014.

  1. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Перем ПровестиИЗакрыть;

    Процедура ВводНового()
    //вынести в начало
    ПровестиИЗакрыть=0;
    Если глПользователь.ОператорККМ = 0 Тогда
    ВрмСумма= 0;
    Параметр = СоздатьОбъект("СписокЗначений");
    Параметр.ДобавитьЗначение(ВрмСумма , "ВрмСумма");
    Параметр.ДобавитьЗначение(Сумма , "Получено");
    ОткрытьФормуМодально("Обработка.ВводПолучено", Параметр);

    Если Параметр.Получить("СтатусВозврата") = 0 Тогда
    СтатусВозврата(0);
    Возврат;
    КонецЕсли;

    ПровестиИЗакрыть=1;
    Сумма = Параметр.Получить("Получено");
    ФизЛицо = Константа.ДляОператораККМ;
    КодОперации= глКО.ВозвратПодотчетныхСумм;
    УправлениеВидимостью();
    УправлениеДоступностью();
    РасчетТекущегоДолга();
    ПринятоОт= глПользователь.Наименование;
    КонецЕсли;

    //тут типовой код с учетом вышеизложенного
    КонецПроцедуры


    Процедура ПриОткрытии()
    Если ПровестиИЗакрыть=1 Тогда
    Записать();
    Провести();
    //выбьем внесение или выдачу
    ПоКнопкеПечать(1,1);
    СтатусВозврата(0);
    Возврат;
    КонецЕсли;

    //далее типовой код

    // Заполним таблицу для выбора печатной формы
    НомерТекущейФормы = глУстановкаКнопкиПечать(Контекст, "Документ." + Вид(),ТаблицаПечФорм);

    .....
    SerzhM нравится это.
  2. TopicStarter Overlay
    SerzhM
    Offline

    SerzhM Опытный в 1С

    Регистрация:
    26 окт 2009
    Сообщения:
    511
    Симпатии:
    3
    Баллы:
    29
    Спасибо, заработало.
  3. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    не за что. обращайтесь
Похожие темы
  1. giraf
    Ответов:
    1
    Просмотров:
    1.392
  2. Юджин
    Ответов:
    8
    Просмотров:
    3.633
  3. rom_strizh
    Ответов:
    0
    Просмотров:
    715
  4. Andy45
    Ответов:
    7
    Просмотров:
    2.578
  5. nomad_irk
    Ответов:
    9
    Просмотров:
    423
Загрузка...

Поделиться этой страницей