7.7 Учебная часть с нуля...

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем ДимонУ, 1 дек 2011.

  1. TopicStarter Overlay
    ДимонУ
    Offline

    ДимонУ

    Регистрация:
    1 дек 2011
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    Нужна подсказка! Дано: два справочника 1-й-Преподаватели, имеет реквизит
    Наименование, в который записывается ФИО преподавателя; 2-й-Дисциплины, реквизиты Наименование и Преподаватель. Нужно чтоб выбранный в форме документа преподаватель мог выбрать только ту дисциплину которую он ведет... Планируется после выбора преподавателя выбирать дисциплину из справочника Дисциплины и преподаватель может выбрать только "свою" дисциплину...
    Код:
    Процедура ПослеВыбораПреподавателя()
    ТекПрепод=Преподаватель;
    Дисциплина="";
    Сообщить(ТекПрепод);
    Дисц=СоздатьОбъект("Справочник.Дисциплины");
    Дисц.ВыбратьЭлементы();
    Пока Дисц.ПолучитьЭлемент()=1 Цикл
    Если Дисц.Преподаватель=ТекПрепод Тогда
    Сообщить(Дисц.Наименование);
    КонецЕсли;                      
    КонецЦикла;
    КонецПроцедуры
    
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    А сели 2 преподавателя и нужно найти по одной дисциплине????
    Лучше так. Создаем еще один справочник ТекущиеУроки (имеет реквизит - справочник дисциплины) и делаем его подчиненным справочника преподаватели. Так думаю будет правильно.
  3. TopicStarter Overlay
    ДимонУ
    Offline

    ДимонУ

    Регистрация:
    1 дек 2011
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    То есть в конфигурации создать еще один справочник?
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Да. Я бы сделал таким образом.
    + Еще ВОЗМОЖНО еще один периодический реквизит (действует-не действует). Нужно же помнить ИСТОРИЮ.

Поделиться этой страницей