ЛВС Ubuntu 14.04 + PostgreSQL 9.2 = DATABASE непригоден для использования

Тема в разделе "Локальные сети (ЛВС), Hardware ("Железо"), Windows", создана пользователем Galich, 6 июн 2014.

  1. TopicStarter Overlay
    Galich
    Offline

    Galich Опытный в 1С

    Регистрация:
    6 июн 2014
    Сообщения:
    276
    Симпатии:
    9
    Баллы:
    29
    Качал PostgreSQL с Etersoft-а сборку для Убунты. Сам сервер постги ставится и ошибок нет, сервер предприятия то же. Но при создании базы как из консоли, так и из 1С ошибка - DATABASE непригоден для использования.....башку сломал уже. В логах PostgreSQL ни чего не пишется по этому поводу. Инет перекопал, но решения пока не нашел. Пробовал ставить от 1С, там ещё все хуже. Может кто сталкивался.
  2. LordMaverick
    Offline

    LordMaverick Профессионал в 1С

    Регистрация:
    17 мар 2014
    Сообщения:
    3.431
    Симпатии:
    372
    Баллы:
    104
    постгри только от 1С нужен, он патченный под 1С
    если что было при установке - вычищать нафиг полностью
    если правильно помню базу надо из 1С создавать
    --- Объединение сообщений, 6 июн 2014 ---
    а релиз платформы какой?

    Изменен формат кластера, создаваемого PostgreSQL 9.2.1-2.1C
    Новый формат кластера идентичен формату кластера, создаваемого стандартной версией PostgreSQL.
    В кластере формат хранения типа данных timestamp установлен со значением integer_datetimes=on в соответствии с форматом, используемым стандартной версией PostgreSQL.

    Поддержка этой версии в 1С:Предприятии 8.3 реализована в версии 8.3.3 и старше.

    Для использования PostgreSQL 9.2.1-2.1C с версиями 1С:Предприятия ниже 8.3.3 необходимо его собрать с установленым значением параметра integer_datetimes=off

    Cписок поддерживаемых дистрибутивов Linux:
    RPM
    Centos 5.7, RedHat 5, Fedora 8, ASP Linux 12(14)
    Должны быть установлены:
    yum install readline
    yum install libtermcap
    yum install krb5-libs
    yum install openssl

    Centos 6, RedHat 6, Fedora 8, 9-16 (необходима установка openssl098e)
    Должны быть установлены:
    yum install readline
    yum install libtermcap
    yum install krb5-libs
    yum install openssl
    Необходима установка дополнительных пакетов совместимости:
    yum install openssl098e
    yum install compat-readline5
    yum install compat-libtermcap
    DEB
    Ubuntu 10.04, 10.10, 11.04, 11.10

    Дополнительные модули:
    plperl
    plpython
    test
    devel
    docs
    Последнее редактирование: 6 июн 2014
  3. TopicStarter Overlay
    Galich
    Offline

    Galich Опытный в 1С

    Регистрация:
    6 июн 2014
    Сообщения:
    276
    Симпатии:
    9
    Баллы:
    29
    Etersoft-овские то же "заточены" под 1С.
    Сейчас у себя стоит версия PostgreSQL от Этерсофта версии 9.0, да и 8 работала,
    проблема именно с 9.2
    Пробовал и от 1С-ников ставить.....
    Судя по интернету, проблема в libicu, 1c-овский дистриб просит libicu44, а в Убунте он уже libicu52 и ни черта не работает.
  4. LordMaverick
    Offline

    LordMaverick Профессионал в 1С

    Регистрация:
    17 мар 2014
    Сообщения:
    3.431
    Симпатии:
    372
    Баллы:
    104
    9.1 поставьте :)
  5. TopicStarter Overlay
    Galich
    Offline

    Galich Опытный в 1С

    Регистрация:
    6 июн 2014
    Сообщения:
    276
    Симпатии:
    9
    Баллы:
    29
    Задумка перейти на 9.2 не с пустого места родилась :)
    Проблема возникла с выпуском релиза 3.0.33.15 Бухгалтерии, при обновлении конфигурации на этот релиз проблем нет, а вот когда
    заходишь в программу и идет обновление информационной базы, тогда вылетает ошибка на какую то таблицу, скорее всего в 9.0 и в 9.1
    этого типа или какой-то таблицы просто нет. Пришлось обновиться файловым методом и слить базу обратно на сервак.
  6. LordMaverick
    Offline

    LordMaverick Профессионал в 1С

    Регистрация:
    17 мар 2014
    Сообщения:
    3.431
    Симпатии:
    372
    Баллы:
    104
    спойлер в №2 посмотрите

    3.0.33.15 от 30.05.14

    а уже вышли
    3.0.33.16 от 03.06.14
    и
    3.0.33.18 от 05.06.14
  7. TopicStarter Overlay
    Galich
    Offline

    Galich Опытный в 1С

    Регистрация:
    6 июн 2014
    Сообщения:
    276
    Симпатии:
    9
    Баллы:
    29
    Проблема возникла с выпуском релиза 3.0.33.15 Бухгалтерии....забыл добавить "и более поздних"
  8. LordMaverick
    Offline

    LordMaverick Профессионал в 1С

    Регистрация:
    17 мар 2014
    Сообщения:
    3.431
    Симпатии:
    372
    Баллы:
    104
    под спойлером смотрели?
    11.04 в списке присутствует и также упоминание про доп. модули
  9. TopicStarter Overlay
    Galich
    Offline

    Galich Опытный в 1С

    Регистрация:
    6 июн 2014
    Сообщения:
    276
    Симпатии:
    9
    Баллы:
    29
    речь про убунту 14.04 :)
  10. TopicStarter Overlay
    Galich
    Offline

    Galich Опытный в 1С

    Регистрация:
    6 июн 2014
    Сообщения:
    276
    Симпатии:
    9
    Баллы:
    29
    а может глянуть в сторону DB2 Express ? Есть опыт юзанья?
  11. LordMaverick
    Offline

    LordMaverick Профессионал в 1С

    Регистрация:
    17 мар 2014
    Сообщения:
    3.431
    Симпатии:
    372
    Баллы:
    104
    только федору 8 и 16, и АСП 12 ещё, в связке с постгри 8.х-9.1 для себя пробывал, чтоб знать
  12. TopicStarter Overlay
    Galich
    Offline

    Galich Опытный в 1С

    Регистрация:
    6 июн 2014
    Сообщения:
    276
    Симпатии:
    9
    Баллы:
    29
    Спасибо 1с-никам за предоставленный геморрой :) В обновлении БП 3.0.33.19 исправлено:
    Исправлена ошибка 30008663:
    В случае применения PostgreSQL обновление на версию 3.0.33 завершается ошибкой:
    "Фоновое обновление информационной базы, Ошибка СУБД:
    ERROR: column "_acc28_idrref" does not exist at character 17"
  13. LordMaverick
    Offline

    LordMaverick Профессионал в 1С

    Регистрация:
    17 мар 2014
    Сообщения:
    3.431
    Симпатии:
    372
    Баллы:
    104
    снова пятничное обновление :)
    частенько они у них косячные капитально
    что у них за мода пошла в конец дня пятницы обновы выкидывать

    по теме
    попробую сейчас 13.10 поставить с "родным" постгри от 1С (с ИТС)
    хотел в виртуалке сперва, потом решил на железе
  14. TopicStarter Overlay
    Galich
    Offline

    Galich Опытный в 1С

    Регистрация:
    6 июн 2014
    Сообщения:
    276
    Симпатии:
    9
    Баллы:
    29
    жду результата
  15. LordMaverick
    Offline

    LordMaverick Профессионал в 1С

    Регистрация:
    17 мар 2014
    Сообщения:
    3.431
    Симпатии:
    372
    Баллы:
    104
    кстати, а это читали?
    http://www.alsigned.ru/?p=1832
    пункт №4

    или соберите сразу на сервере из исходником, они в доступе есть (с патчем обязательно)

    или вот сверьте ваш процесс с процедурой
    http://infostart.ru/public/274748/
    Последнее редактирование: 8 июн 2014
  16. TopicStarter Overlay
    Galich
    Offline

    Galich Опытный в 1С

    Регистрация:
    6 июн 2014
    Сообщения:
    276
    Симпатии:
    9
    Баллы:
    29
    Ага, видел....не помогает...

Поделиться этой страницей