7.7 Три справочника

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Dem0lisher, 9 авг 2009.

  1. TopicStarter Overlay
    Dem0lisher
    Offline

    Dem0lisher Профессионал в 1С

    Регистрация:
    4 авг 2009
    Сообщения:
    1.023
    Симпатии:
    51
    Баллы:
    54
    Здравствуйте!
    Есть 3 справочника: Животные, Корма(кроме наименования тут имеется цена корма), Рацион..
    Справочник "Рацион" подчинен справочнику "Животные" в нем для каждого животного из зоопарка перечень кормов с указанием нормы на день.
    Документ Зоопарк: в табличной части вводится животное из справочника и их численность, по кнопке "Рассчитать" вычисляется содержание одного животного в день.
    Не представляю, как это реализовать. Если на словах-более менее, то с реализацией хуже!
    После ИспользоватьВладельца(Животное); без которого тут очевидно не обойтись надо как-то под этим животным попасть в его рацион, затем считать оттуда корма, потом, для каждого корма по отдельности залезть в справочник "Корма " и перемножить количество нужного в день объема каждого корма на его стоимость!
    Выручайте!
  2. MaxxaM
    Offline

    MaxxaM Опытный в 1С

    Регистрация:
    16 окт 2007
    Сообщения:
    288
    Симпатии:
    2
    Баллы:
    29
    Ну где то так :

    Код:
    спр1=создатьОбъект("Справочник.Рацион");
    выбратьСтроки();
    Пока ПолучитьСтроку()=1 цикл
    сум=0;
    спр1.ИспользоватьВладельца(Животные);
    если спр1.ВыбратьЭлементы()=1 тогда
    Пока  спр1.ПолучитьСтроку()=1 цикл
    сум=спр1.Норма*спр1.Корм.Цена; 
    КонецЦикла;
    иначе
    сообщить("нет  норм для  "+животное);
    КонецЕсли;
    содержание_одного_животного_в_день=сум;
    КонецЦикла;
    
    
    :unsure:
  3. TopicStarter Overlay
    Dem0lisher
    Offline

    Dem0lisher Профессионал в 1С

    Регистрация:
    4 авг 2009
    Сообщения:
    1.023
    Симпатии:
    51
    Баллы:
    54
    Ага, Спасибо, все понял, только вызывает сомнение одна строчка

    сум=спр1.Норма*спр1.Корм.Цена;
    Цена корма находится не в справочнике "Рацион", а в справочнике "Корма", я так думаю, чтобы получить стоимость кормежки зверя надо как то и там найти именно ту строчку с именно тем кормом, с которым работаем в данный момент, и перемножить, а вот как выбрать именно его оттуда-незнаю, , т.е
    будет ----
    Сум=спр1.Норма*СПР2.Корм.Цена;
    Но как в СПР2 встать именно на тот корм, который нужен в каждом конкретном случае?
  4. dianofob
    Offline

    dianofob (-_-)y-.o0O

    Регистрация:
    3 июл 2009
    Сообщения:
    711
    Симпатии:
    0
    Баллы:
    26
    НайтиПоНаименованию() потом присваиваешь переменной текущее значение..

Поделиться этой страницей