8.х Товары в резерве на складах

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем [GIGA]DEDUSHKA, 26 фев 2010.

  1. TopicStarter Overlay
    [GIGA]DEDUSHKA
    Offline

    [GIGA]DEDUSHKA Опытный в 1С

    Регистрация:
    7 мар 2008
    Сообщения:
    167
    Симпатии:
    0
    Баллы:
    26
    Этот вредный регистр накопления очищает серию номенклатуры, для заказов на производство, внутренних заказов и тех заказов покупателей, для которых не включен обособленный учет. А ведь так хочется видеть, какая конкретно серия под каким заказом зарезервирована (напр через отчет Анализ доступности товаров на складах). В конфигураторе посмотрел: этот код все убирает (в модуле набора записей):
    Код:
    Процедура КорректировкаСерийПриРезервировании()
    
    // Если в таблице движений нет серий, то модифицировать ничего не нужно.
    Если Количество() = 0 Тогда
    Возврат;
    КонецЕсли;
    
    ПустаяСерия = Справочники.СерииНоменклатуры.ПустаяСсылка();
    
    // Если серии при резервировании не используются, тогда очистим колонку "СерииНоменклатуры".
    Если Не (глЗначениеПеременной("ИспользоватьУказаниеСерийНоменклатурыПриРезервировании") И глЗначениеПеременной("ИспользоватьСерииНоменклатуры")) Тогда
    
    Для Каждого СтрокаДвижения Из ЭтотОбъект Цикл
    СтрокаДвижения.СерияНоменклатуры = ПустаяСерия;
    КонецЦикла;	
    
    Иначе
    
    // Для каждого заказа определим ведется ли обособленный учет, если нет, очистим серию.
    Для Каждого СтрокаДвижения Из ЭтотОбъект Цикл
    
    Если ТипЗнч(СтрокаДвижения.ДокументРезерва) <> Тип("ДокументСсылка.ЗаказПокупателя") Тогда
    СтрокаДвижения.СерияНоменклатуры = ПустаяСерия;
    Продолжить;
    КонецЕсли;	
    
    ОбособленныйУчетПоЗаказу = СтрокаДвижения.ДокументРезерва.ДоговорКонтрагента.ОбособленныйУчетТоваровПоЗаказамПокупателей;
    
    Если Не(ОбособленныйУчетПоЗаказу) Тогда
    СтрокаДвижения.СерияНоменклатуры = ПустаяСерия;
    КонецЕсли;	
    
    КонецЦикла;	
    
    КонецЕсли;
    
    КонецПроцедуры
    
    Скажите, если я его закоментю, какие последствия я могу получить?
  2. mialord
    Offline

    mialord Модераторы Команда форума Модератор

    Регистрация:
    31 июл 2009
    Сообщения:
    5.398
    Симпатии:
    40
    Баллы:
    54
    Здраствуйте!
    Ошибки будут при проведении документов.
    Если обособ-ого учёта нет то двигать по сериям нельзя, добавьте свой реквизит и пишите туда хоть петю с васей.
  3. TopicStarter Overlay
    [GIGA]DEDUSHKA
    Offline

    [GIGA]DEDUSHKA Опытный в 1С

    Регистрация:
    7 мар 2008
    Сообщения:
    167
    Симпатии:
    0
    Баллы:
    26
    Жаль. Петя с Васей тут не помогут. Придется и отчеты переделывать, чтобы они знали, кто такие Петя с Васей. Получается крайне тяжелая работа.
    P.S. Я не такой спец в 1С, но мне кажется, что тут явное неудобство. Кладовщик получая ТМЦ под различные внутренние заказы или заказы на производство не знает какие из них кому предназначены. То есть с точки зрения логики 1С - без разницы какую серию номенклатуры выдавать. А ведь с точки зрения разных качества и себестоимости продукции это очень важно иметь информацию о заказе-резерве
  4. tirk
    Offline

    tirk Опытный в 1С

    Регистрация:
    1 сен 2008
    Сообщения:
    1.142
    Симпатии:
    0
    Баллы:
    26
    так как отчеты написаны в основном в "универсальном" большенство отчетов автоматически подцепит новые поля отчета. Попробуйте на тестовой а потом дальше думать)
  5. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    Вы сами ответили на свой вопрос - Вам необходим режим обособленного учета.
    В производстве действительно не ведется учет по сериям. Часть истины в этом есть, но есть те тонкости, которые не учитывает типовая. На эту тему много обсуждений было на партнерском.
    Итог: типовая не поддерживает работу с сериями в производстве.

Поделиться этой страницей