7.7 Товарный отчет по закупочным ценам

Тема в разделе "Отчеты и обработки для "1С:Предприятие 7.7"", создана пользователем andy_1983, 22 сен 2016.

  1. TopicStarter Overlay
    andy_1983
    Offline

    andy_1983

    Регистрация:
    24 сен 2015
    Сообщения:
    4
    Симпатии:
    0
    Баллы:
    1
    Типовая конфигурация ТиС ред. 9.2. В ней имеется Товарный отчет. который формирует Приход и Расход по складу в розничных ценах. Подскажите, можно ли сделать так, чтобы он все так же формировал, но при этом использовал закупочные цены?
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Конечно можно. На вопрос "а что для этого нужно" - покажите отчет
  3. TopicStarter Overlay
    andy_1983
    Offline

    andy_1983

    Регистрация:
    24 сен 2015
    Сообщения:
    4
    Симпатии:
    0
    Баллы:
    1
    Обычный Товарный отчет в Типовой конфигурации
    Перем ТекНомерОтчета; // номер отчета из константы
    Перем Т;
    Перем Сформирован;

    Процедура Сформировать(ЗакрытьЭкран=0)
    Перем НачСтоимость, КонСтоимость;
    Перем СуммаПоДок, СписокПрихода, СписокРасхода;

    Перем Запрос, ТекстЗапроса;

    Если ВыбСклад.Актуальность=1 Тогда

    Фирма = глЗначениеПоУмолчанию("ОсновнаяФирма");
    ВыбЮрЛицо = ?(ПустоеЗначение(Фирма)=1,"",Фирма.ЮрЛицо);

    Сформирован=0;

    Запрос = СоздатьОбъект("Запрос");

    Если глПроверкаДаты(ДатаНачала,ДатаКонца)=0 Тогда
    Возврат;
    КонецЕсли;

    Если ПустоеЗначение(ВыбСклад) = 1 Тогда
    Предупреждение("Не выбран склад", 60);
    Возврат;
    КонецЕсли;

    Если ВыбТипыЦен.Выбран()=1 Тогда
    Иначе
    Предупреждение("Выберите типы цен!");
    Возврат;
    КонецЕсли;

    Если (ТипЗначенияСтр(Т) <> "Таблица") Тогда
    Т = СоздатьОбъект("Таблица");
    Иначе
    Т.Очистить();
    КонецЕсли;

    Т.ИсходнаяТаблица( "ТОРГ-29" );

    ТекстЗапроса =
    "//{{ЗАПРОС(Остатки)
    |ПЕРИОД С ДатаНачала По ДатаКонца;
    |Склад = Регистр.ОстаткиТМЦ.Склад;
    |Номенклатура = Регистр.ОстаткиТМЦ.Номенклатура;
    |ЦенаПрод = Регистр.ОстаткиТМЦ.ЦенаПрод;
    |Количество = Регистр.ОстаткиТМЦ.Количество;
    |Функция КоличествоНачОст = НачОст(Количество);
    |Функция КоличествоКонОст = КонОст(Количество);
    |Группировка Номенклатура;
    |Группировка ЦенаПрод;
    |Группировка Количество;
    |Условие(Склад=ВыбСклад);
    |"//}}ЗАПРОС
    ;
    // Если ошибка в запросе, то выход из процедуры
    Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
    Возврат;
    КонецЕсли;

    НачСтоимость=0;
    КонСтоимость=0;
    Пока Запрос.Группировка(1) = 1 Цикл
    Пока Запрос.Группировка(2) = 1 Цикл
    Пока Запрос.Группировка(3) = 1 Цикл
    НачСтоимость=НачСтоимость+Запрос.ЦенаПрод*Запрос.КоличествоНачОст;
    КонСтоимость=КонСтоимость+Запрос.ЦенаПрод*Запрос.КоличествоКонОст;
    КонецЦикла;
    КонецЦикла;
    КонецЦикла;

    ТекстЗапроса =
    "//{{ЗАПРОС(Остатки)
    |ПЕРИОД С ДатаНачала По ДатаКонца;
    |Склад = Регистр.ОстаткиТМЦ.Склад;
    |Номенклатура = Регистр.ОстаткиТМЦ.Номенклатура;
    |ЦенаПрод = Регистр.ОстаткиТМЦ.ЦенаПрод;
    |Количество = Регистр.ОстаткиТМЦ.Количество;
    |Докум = Регистр.ОстаткиТМЦ.ТекущийДокумент;
    |Функция КоличествоПриход = Приход(Количество);
    |Функция КоличествоРасход = Расход(Количество);
    |Группировка Докум;
    |Группировка Номенклатура;
    |Группировка ЦенаПрод;
    |Группировка Количество;
    |Условие(Склад=ВыбСклад);
    |"//}}ЗАПРОС
    ;
    // Если ошибка в запросе, то выход из процедуры
    Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
    Возврат;
    КонецЕсли;


    СписокПрихода = СоздатьОбъект("ТаблицаЗначений");
    СписокПрихода.НоваяКолонка("Докум");
    СписокПрихода.НоваяКолонка("СуммаТовара","Число",15,2);
    СписокПрихода.НоваяКолонка("СуммаСкидки","Число",15,2);
    СписокПрихода.Выгрузить(СписокРасхода);

    Пока Запрос.Группировка(1) = 1 Цикл
    СписокПрихода.НоваяСтрока();
    СписокРасхода.НоваяСтрока();
    СписокПрихода.Докум=Запрос.Докум;
    СписокРасхода.Докум=Запрос.Докум;
    СписокПрихода.СуммаТовара=0;
    СписокРасхода.СуммаТовара=0;
    Пока Запрос.Группировка(2) = 1 Цикл
    Пока Запрос.Группировка(3) = 1 Цикл
    Пока Запрос.Группировка(4) = 1 Цикл
    СписокПрихода.СуммаТовара=СписокПрихода.СуммаТовара+Запрос.ЦенаПрод*Запрос.КоличествоПриход;
    СписокРасхода.СуммаТовара=СписокРасхода.СуммаТовара+Запрос.ЦенаПрод*Запрос.КоличествоРасход;
    КонецЦикла;
    КонецЦикла;
    КонецЦикла;
    Если (Запрос.Докум.Вид()="ПереоценкаРозница") или ((Найти(Врег(Запрос.Докум.Вид()),"РЕАЛИЗАЦИЯ")>0) и (СписокПрихода.СуммаТовара<>0)) Тогда
    Разница=СписокПрихода.СуммаТовара-СписокРасхода.СуммаТовара;
    Скидка = 0;
    Если (Найти(Врег(Запрос.Докум.Вид()),"РЕАЛИЗАЦИЯ")>0) Тогда
    Скидка=-1*(Разница+СписокПрихода.СуммаТовара);
    КонецЕсли;
    Если Разница<>0 Тогда
    Если Разница>0 Тогда
    СписокПрихода.СуммаТовара=Разница;
    СписокРасхода.СуммаТовара=0;
    Иначе
    СписокПрихода.СуммаТовара=0;
    СписокРасхода.СуммаТовара=(-1)*Разница;
    СписокРасхода.СуммаСкидки=Скидка;
    КонецЕсли;
    Иначе
    СписокПрихода.СуммаТовара=0;
    СписокРасхода.СуммаТовара=0;
    КонецЕсли;
    ИначеЕсли Запрос.Докум.Вид()="ЧекККМ" Тогда
    СписокРасхода.СуммаСкидки=Запрос.Докум.Итог("СуммаСкидки");
    //СписокРасхода.СуммаТовара=СписокРасхода.СуммаТовара-СписокРасхода.СуммаСкидки;
    КонецЕсли;
    КонецЦикла;

    СписокПрихода.ВыбратьСтроки();
    Пока СписокПрихода.ПолучитьСтроку()=1 Цикл
    Если СписокПрихода.СуммаТовара=0 Тогда
    СписокПрихода.УдалитьСтроку();
    СписокПрихода.ВыбратьСтроки();
    КонецЕсли;
    КонецЦикла;

    СписокРасхода.ВыбратьСтроки();
    Пока СписокРасхода.ПолучитьСтроку()=1 Цикл
    Если СписокРасхода.СуммаТовара=0 Тогда
    СписокРасхода.УдалитьСтроку();
    СписокРасхода.ВыбратьСтроки();
    КонецЕсли;
    КонецЦикла;


    СуммаЧеков=0;
    СуммаСкидкиЧеков=0;
    Если Разворачивать=0 Тогда
    СписокРасхода.ВыбратьСтроки();
    Пока СписокРасхода.ПолучитьСтроку()=1 Цикл
    Докум = СписокРасхода.Докум;
    Если Докум.Вид()="ЧекККМ" Тогда
    СуммаЧеков=СуммаЧеков+СписокРасхода.СуммаТовара;
    СуммаСкидкиЧеков=СуммаСкидкиЧеков+СписокРасхода.СуммаСкидки;
    КонецЕсли;
    КонецЦикла;
    КонецЕсли;

    глЧислоСтрок = 0;
    // Создание Таблицы для выходного отчета
    Т.ВывестиСекцию("Заголовок");
    Т.ВывестиСекцию("Шапка");

    НачПовт = Т.ВысотаСекции("Заголовок");
    КонПовт = НачПовт + Т.ВысотаСекции("Шапка");

    Т.ПовторятьПриПечатиСТроки(НачПовт + 1, КонПовт);

    глОживить(5);
    Ном=0;

    Т.ВывестиСекцию("ОстатокНачала");

    Т.ВывестиСекцию("Приход");
    глОживить(3);

    ПрихСтоимость=0;
    СписокПрихода.ВыбратьСтроки();
    Пока СписокПрихода.ПолучитьСтроку() = 1 Цикл
    Докум = СписокПрихода.Докум;
    СуммаТовара = СписокПрихода.СуммаТовара;
    ПрихСтоимость = ПрихСтоимость+СписокПрихода.СуммаТовара;
    Если глЕстьРеквизитШапки("НомерДокВходящий", Докум.Вид()) = 1 Тогда
    НомерДокумента = Докум.НомерДокВходящий;
    Иначе
    НомерДокумента = Докум.НомерДок;
    КонецЕсли;

    Если глЕстьРеквизитШапки("ДатаДокВходящий", Докум.Вид()) = 1 Тогда
    ДатаДокумента = Докум.ДатаДокВходящий;
    Иначе
    ДатаДокумента = Докум.ДатаДок;
    КонецЕсли;

    Ном = Ном + 1;

    Т.ВывестиСекцию("Строка");
    глОживить(1);
    КонецЦикла;

    // итого приход
    Т.ВывестиСекцию("ИтогоПриход");
    глОживить(1);

    // итого приход + остаток
    Т.ВывестиСекцию("ВсегоПриход");
    глОживить(1);

    // расходы

    Т.НоваяСтраница();
    //Т.ВывестиСекцию("Шапка");
    Т.ВывестиСекцию("Расход");
    глОживить(1);

    РасхСтоимость=0;
    СкидСтоимость=0;
    СписокРасхода.ВыбратьСтроки();
    Пока СписокРасхода.ПолучитьСтроку() = 1 Цикл
    Докум = СписокРасхода.Докум;
    ЧОтметки7=0;
    Отметки7="";
    ЧОтметки8=0;
    Отметки8="";
    Если Разворачивать=1 Тогда
    СуммаТовара = СписокРасхода.СуммаТовара;
    РасхСтоимость = РасхСтоимость+СписокРасхода.СуммаТовара;
    СуммаСкидки = СписокРасхода.СуммаСкидки;
    Если (Докум.Вид()="Реализация") и (СуммаСкидки<>0) Тогда
    ЧОтметки7=Докум.Итог("Сумма");
    Отметки7=глФРМ(ЧОтметки7);
    ЧОтметки8=РасхСтоимость-СуммаСкидки-ЧОтметки7;
    Отметки8=глФРМ(ЧОтметки8);;
    КонецЕсли;
    СкидСтоимость = СкидСтоимость+СписокРасхода.СуммаСкидки;
    НомерДокумента = ?(Докум.Вид()="ЧекККМ",Докум.НомерЧекаККМ,Докум.НомерДок);
    ДатаДокумента = Докум.ДатаДок;

    Ном = Ном + 1;
    Т.ВывестиСекцию("Строка");
    глОживить(1);
    Иначе
    Если Докум.Вид()<>"ЧекККМ" Тогда
    СуммаТовара = СписокРасхода.СуммаТовара;
    РасхСтоимость = РасхСтоимость+СписокРасхода.СуммаТовара;
    СуммаСкидки = СписокРасхода.СуммаСкидки;
    Если (Докум.Вид()="Реализация") и (СуммаСкидки<>0) Тогда
    ЧОтметки7=Докум.Итог("Сумма");
    Отметки7=глФРМ(ЧОтметки7);
    ЧОтметки8=СуммаТовара-СуммаСкидки-ЧОтметки7;
    Отметки8=глФРМ(ЧОтметки8);;
    КонецЕсли;
    СкидСтоимость = СкидСтоимость+СписокРасхода.СуммаСкидки;
    НомерДокумента = ?(Докум.Вид()="ЧекККМ",Докум.НомерЧекаККМ,Докум.НомерДок);
    ДатаДокумента = Докум.ДатаДок;

    Ном = Ном + 1;
    Т.ВывестиСекцию("Строка");
    глОживить(1);
    Иначе
    СкидСтоимость = СкидСтоимость+СписокРасхода.СуммаСкидки;
    КонецЕсли;
    КонецЕсли;
    КонецЦикла;
    Если Разворачивать=0 Тогда
    Т.ВывестиСекцию("Чеки");
    глОживить(1);
    РасхСтоимость = РасхСтоимость+СуммаЧеков;
    КонецЕсли;

    Т.ВывестиСекцию("ИтогоРасход");
    глОживить(1);

    Т.ВывестиСекцию("ОстатокКонец");
    глОживить(1);

    Т.ВывестиСекцию("Подвал");
    глОживить(4);
    //Вызов выходного отчета в окно просмотра и редактирования.
    Т.Опции(0, 0, 0, 0, "ТоварныйОтчет", "ТоварныйОтчет");
    //Т.Защита(Константа.ФлагЗащитыТаблиц);
    Т.ТолькоПросмотр(1);
    Т.ОбластьПечати(2);
    Если глПолучитьПолномочие("РазрешитьРедактированиеТаблиц") = 0 Тогда
    Т.Защита(1);
    КонецЕсли;
    Т.ПараметрыСтраницы(1,100,,20,0,0,0,0,0,1);
    Т.Показать("Товарный отчет № " + Номер, "");

    Сформирован = 1;
    Номер = Номер + 1;
    ТекНомерОтчета = Номер;

    Если (ЗакрытьЭкран = 1)
    Тогда
    СтрокаДействийФормы = "#Закрыть";
    КонецЕсли;
    Иначе
    Фирма = глЗначениеПоУмолчанию("ОсновнаяФирма");
    ВыбЮрЛицо = ?(ПустоеЗначение(Фирма)=1,"",Фирма.ЮрЛицо);

    Сформирован=0;

    Запрос = СоздатьОбъект("Запрос");

    Если глПроверкаДаты(ДатаНачала,ДатаКонца)=0 Тогда
    Возврат;
    КонецЕсли;

    Если ПустоеЗначение(ВыбСклад) = 1 Тогда
    Предупреждение("Не выбран склад", 60);
    Возврат;
    КонецЕсли;

    Если (ТипЗначенияСтр(Т) <> "Таблица") Тогда
    Т = СоздатьОбъект("Таблица");
    Иначе
    Т.Очистить();
    КонецЕсли;

    Т.ИсходнаяТаблица( "ТОРГ-29" );

    ТекстЗапроса =
    "//{{ЗАПРОС(Остатки)
    |ПЕРИОД С ДатаНачала По ДатаКонца;
    |Склад = Регистр.Остатки.Склад;
    |Сумма = Регистр.Остатки.Сумма;
    |Функция СуммаНачОст = НачОст(Сумма);
    |Функция СуммаКонОст = КонОст(Сумма);
    |Группировка Склад;
    |Условие(Склад=ВыбСклад);
    |"//}}ЗАПРОС
    ;
    // Если ошибка в запросе, то выход из процедуры
    Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
    Возврат;
    КонецЕсли;

    НачСтоимость=0;
    КонСтоимость=0;
    Пока Запрос.Группировка(1) = 1 Цикл
    НачСтоимость=Запрос.СуммаНачОст;
    КонСтоимость=Запрос.СуммаКонОст;
    КонецЦикла;

    ТекстЗапроса =
    "//{{ЗАПРОС(Остатки)
    |ПЕРИОД С ДатаНачала По ДатаКонца;
    |Склад = Регистр.Остатки.Склад;
    |Сумма = Регистр.Остатки.Сумма;
    |Докум = Регистр.Остатки.ТекущийДокумент;
    |Функция СуммаПриход = Приход(Сумма);
    |Функция СуммаРасход = Расход(Сумма);
    |Группировка Докум;
    |Условие(Склад=ВыбСклад);
    |"//}}ЗАПРОС
    ;
    // Если ошибка в запросе, то выход из процедуры
    Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
    Возврат;
    КонецЕсли;


    СписокПрихода = СоздатьОбъект("ТаблицаЗначений");
    СписокПрихода.НоваяКолонка("Докум");
    СписокПрихода.НоваяКолонка("СуммаТовара","Число",15,2);
    СписокПрихода.НоваяКолонка("СуммаСкидки","Число",15,2);
    СписокПрихода.Выгрузить(СписокРасхода);

    Пока Запрос.Группировка(1) = 1 Цикл
    СписокПрихода.НоваяСтрока();
    СписокРасхода.НоваяСтрока();
    СписокПрихода.Докум=Запрос.Докум;
    СписокРасхода.Докум=Запрос.Докум;
    СписокПрихода.СуммаТовара=0;
    СписокРасхода.СуммаТовара=0;
    СписокПрихода.СуммаТовара=Запрос.СуммаПриход;
    СписокРасхода.СуммаТовара=Запрос.СуммаРасход;
    Если (Запрос.Докум.Вид()="ПереоценкаРозница") или ((Запрос.Докум.Вид()="Реализация") и (СписокПрихода.СуммаТовара<>0)) Тогда
    Разница=СписокПрихода.СуммаТовара-СписокРасхода.СуммаТовара;
    Скидка = 0;
    Если (Запрос.Докум.Вид()="Реализация") Тогда
    Скидка=-1*(Разница+СписокПрихода.СуммаТовара);
    КонецЕсли;
    Если Разница<>0 Тогда
    Если Разница>0 Тогда
    СписокПрихода.СуммаТовара=Разница;
    СписокРасхода.СуммаТовара=0;
    Иначе
    СписокПрихода.СуммаТовара=0;
    СписокРасхода.СуммаТовара=(-1)*Разница;
    СписокРасхода.СуммаСкидки=Скидка;
    КонецЕсли;
    Иначе
    СписокПрихода.СуммаТовара=0;
    СписокРасхода.СуммаТовара=0;
    КонецЕсли;
    КонецЕсли;
    КонецЦикла;

    СписокПрихода.ВыбратьСтроки();
    Пока СписокПрихода.ПолучитьСтроку()=1 Цикл
    Если СписокПрихода.СуммаТовара=0 Тогда
    СписокПрихода.УдалитьСтроку();
    СписокПрихода.ВыбратьСтроки();
    КонецЕсли;
    КонецЦикла;

    СписокРасхода.ВыбратьСтроки();
    Пока СписокРасхода.ПолучитьСтроку()=1 Цикл
    Если СписокРасхода.СуммаТовара=0 Тогда
    СписокРасхода.УдалитьСтроку();
    СписокРасхода.ВыбратьСтроки();
    КонецЕсли;
    КонецЦикла;

    СуммаЧеков=0;
    СуммаСкидкиЧеков=0;

    глЧислоСтрок = 0;
    // Создание Таблицы для выходного отчета
    Т.ВывестиСекцию("Заголовок");
    Т.ВывестиСекцию("Шапка");

    НачПовт = Т.ВысотаСекции("Заголовок");
    КонПовт = НачПовт + Т.ВысотаСекции("Шапка");

    Т.ПовторятьПриПечатиСТроки(НачПовт + 1, КонПовт);

    глОживить(5);
    Ном=0;

    Т.ВывестиСекцию("ОстатокНачала");

    Т.ВывестиСекцию("Приход");
    глОживить(3);

    ПрихСтоимость=0;
    СписокПрихода.ВыбратьСтроки();
    Пока СписокПрихода.ПолучитьСтроку() = 1 Цикл
    Докум = СписокПрихода.Докум;
    СуммаТовара = СписокПрихода.СуммаТовара;
    ПрихСтоимость = ПрихСтоимость+СписокПрихода.СуммаТовара;
    Если глЕстьРеквизитШапки("НомерДокВходящий", Докум.Вид()) = 1 Тогда
    НомерДокумента = Докум.НомерДокВходящий;
    Иначе
    НомерДокумента = Докум.НомерДок;
    КонецЕсли;

    Если глЕстьРеквизитШапки("ДатаДокВходящий", Докум.Вид()) = 1 Тогда
    ДатаДокумента = Докум.ДатаДокВходящий;
    Иначе
    ДатаДокумента = Докум.ДатаДок;
    КонецЕсли;

    Ном = Ном + 1;

    Т.ВывестиСекцию("Строка");
    глОживить(1);
    КонецЦикла;

    // итого приход
    Т.ВывестиСекцию("ИтогоПриход");
    глОживить(1);

    // итого приход + остаток
    Т.ВывестиСекцию("ВсегоПриход");
    глОживить(1);

    // расходы

    Т.НоваяСтраница();
    //Т.ВывестиСекцию("Шапка");
    Т.ВывестиСекцию("Расход");
    глОживить(1);

    РасхСтоимость=0;
    СкидСтоимость=0;
    СписокРасхода.ВыбратьСтроки();
    Пока СписокРасхода.ПолучитьСтроку() = 1 Цикл
    Докум = СписокРасхода.Докум;
    СуммаТовара = СписокРасхода.СуммаТовара;
    РасхСтоимость = РасхСтоимость+СписокРасхода.СуммаТовара;
    СуммаСкидки = СписокРасхода.СуммаСкидки;
    СкидСтоимость = СкидСтоимость+СписокРасхода.СуммаСкидки;
    НомерДокумента = ?(Докум.Вид()="ЧекККМ",Докум.НомерЧекаККМ,Докум.НомерДок);
    ДатаДокумента = Докум.ДатаДок;

    Ном = Ном + 1;
    Т.ВывестиСекцию("Строка");
    глОживить(1);
    КонецЦикла;

    Т.ВывестиСекцию("ИтогоРасход");
    глОживить(1);

    Т.ВывестиСекцию("ОстатокКонец");
    глОживить(1);

    Т.ВывестиСекцию("Подвал");
    глОживить(4);
    //Вызов выходного отчета в окно просмотра и редактирования.
    Т.Опции(0, 0, 0, 0, "ТоварныйОтчет", "ТоварныйОтчет");
    //Т.Защита(Константа.ФлагЗащитыТаблиц);
    Т.ТолькоПросмотр(1);
    Т.ОбластьПечати(2);
    Если глПолучитьПолномочие("РазрешитьРедактированиеТаблиц") = 0 Тогда
    Т.Защита(1);
    КонецЕсли;
    Т.ПараметрыСтраницы(1,100,,20,0,0,0,0,0,1);
    Т.Показать("Товарный отчет № " + Номер, "");

    Сформирован = 1;
    Номер = Номер + 1;
    ТекНомерОтчета = Номер;

    Если (ЗакрытьЭкран = 1)
    Тогда
    СтрокаДействийФормы = "#Закрыть";
    КонецЕсли;
    КонецЕсли;
    КонецПроцедуры // Сформировать()

    Процедура ВводНового()
    Номер = ТекНомерОтчета;
    КонецПроцедуры // ВводНового()

    Процедура ПриОткрытии(ФлагЧтенияНастройки)

    Если ФлагЧтенияНастройки = 0 Тогда
    ДатаНачала = глЗначениеПоУмолчанию("ОсновнаяДатаНачалаОтчетов");
    Если ПустоеЗначение(ДатаНачала) = 1 Тогда
    ДатаНачала = НачМесяца(ДатаКонца);
    КонецЕсли;
    КонецЕсли;

    Номер = Константа.СчетчикТоварныхОтчетов;
    Номер = 1 + Номер;
    ТекНомерОтчета = Номер;

    Форма.Обновить(1);

    КонецПроцедуры // ПриОткрытии()

    Процедура ПриЗакрытии()
    Константа.СчетчикТоварныхОтчетов = Номер;
    КонецПроцедуры // ПриЗакрытии()

    //******************************************************************************
    ДатаКонца = ПолучитьДатуТА();
    --- Объединение сообщений, 23 сен 2016 ---
    Для чего это нужно. В одном магазине два хозяина. Один продает одну группу товаров, другой другую. Поступление товара идет на Основной склад по Закупочным ценам, а потом делается Перемещение на на два разных склада, но уже с Розничными ценами. Поставщики иногда привозят товары для двух складов по одной накладной. Вот им и нужно знать сколько каждый потратил денег (Товарный отчет по закупочным ценам) и сколько заработал (Обычный Товарный отчет который нормально работает) на каждом складе. Как-то так.
    Последнее редактирование: 23 сен 2016

Поделиться этой страницей