7.7 Товарищи программисты помогите ! СРОЧНО

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем wise, 13 мар 2007.

  1. TopicStarter Overlay
    wise
    Offline

    wise

    Регистрация:
    25 авг 2006
    Сообщения:
    21
    Симпатии:
    0
    Баллы:
    1
    Конфигурация для Бюджета (608) Платформа 7.7

    Проблема такая:
    Добавили новый вид субконто у счету 304.05 - ДетализацияЭКР (субконто5)
    В базе есть множество документов в которых счет 304.05 без нового субконто.
    Хочется программно добавить это значение.

    Допустим документ Списание с лицевого счета
    Делаю выборку документов, отбираю нужные по условию

    Код:
    Док = СоздатьОбъект ("Документ.СписаниеСоСчета");
    Док.ВыбратьДокументы(Дата1,Дата2);
    Пока Док.ПолучитьДокумент()= 1 Цикл
    Док.ВыбратьСтроки();
    Пока Док.ПолучитьСтроку()=1 Цикл
    Если (Док.КБККт = ФКР1) и (Док.ОГСКт = КОСГУ) Тогда 
    Док.ФКР = ФКР2;
    Док.ЭКР = КОСГУ;
    Док.ДетализацияЭКР = ДОПЭК;
    //кредит
    Док.КБККт = ФКР2;
    
    Док.НазначитьТип("СубконтоКт5","Субконто.ДетализацияЭКР"); 
    Док.УстановитьАтрибут("СубконтоКт5",ДОПЭК);  
    
    Док.КБКДт = ФКР2;  
    Док.Записать();
    КонецЕсли;
    КонецЦикла;
    КонецЦикла;            
    
    И ничего не происходит ... ну т.е в доках новое субконто не добовляется...
    Подскажите как это сделать ?
  2. TopicStarter Overlay
    wise
    Offline

    wise

    Регистрация:
    25 авг 2006
    Сообщения:
    21
    Симпатии:
    0
    Баллы:
    1
    Понимае пришло... все вопрос исчерпан!

Поделиться этой страницей