7.7 Тормозит метод сводныйостаток в тис

Тема в разделе "Типовые решения "1С:Предприятие 7.7"", создана пользователем audiserg, 4 дек 2007.

  1. TopicStarter Overlay
    audiserg
    Offline

    audiserg

    Регистрация:
    21 янв 2007
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    1
    В списке партий, для отображения остатков, использую функцию в строке показать остаток, сама форма и процедура выглядит примерно так

    Код:
    Функция ПолучитьОстатокПартии(Партия)
    
    Если ПустоеЗначение(Партия) = 1 Тогда
    Возврат "";
    КонецЕсли;
    НайденныйОстаток = ПартииНаличие.СводныйОстаток(,,,,Партия,,, "Количество");
    
    Если НайденныйОстаток = 0 Тогда
    Возврат "";
    Иначе
    Возврат найденныйОстаток;
    КонецЕсли;
    КонецФункции // ПолучитьОстатокПартии()
    .......
    ПартииНаличие=СоздатьОбъект("Регистр.ПартииНаличие"); 
    ПартииНаличие.ОстаткиПолучить();
    
    при вызыве справочника партий, и скролинге все жутко тормозит. Понимаю что это все обсуждалось нераз но ничего ненашел, ткните носом. Может остатки все сначала как нибудь можно получить, ХЕЛП!!!

    Используйте тэг
    Код:
    [/color]
  2. yourname
    Offline

    yourname Опытный в 1С

    Регистрация:
    15 июл 2007
    Сообщения:
    84
    Симпатии:
    0
    Баллы:
    26
    Все ну очень просто. Основные правила программирования в опер учете. Не рекомендуется получать сводные остатки если значения первых изменений не указаны. Попробуй у регистра поставить галочку "Отбор итогов"
  3. TopicStarter Overlay
    audiserg
    Offline

    audiserg

    Регистрация:
    21 янв 2007
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    1
    если можно то поподробней, что должно быть указанно(недопонял ж) )
  4. TopicStarter Overlay
    audiserg
    Offline

    audiserg

    Регистрация:
    21 янв 2007
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    1
    галочка "быстрое получение итогов" непомогла, Все дело в неуказанных измерениях?
  5. TopicStarter Overlay
    audiserg
    Offline

    audiserg

    Регистрация:
    21 янв 2007
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    1
    большое огромное спасибо, поменялпорядок в регистре и все заработало нормально

Поделиться этой страницей