8.х УТ ТОРГ 12

Тема в разделе ""1С:Управление торговлей УТ"", создана пользователем Serge5082, 3 июн 2016.

  1. TopicStarter Overlay
    Serge5082
    Offline

    Serge5082

    Регистрация:
    28 янв 2016
    Сообщения:
    4
    Симпатии:
    0
    Баллы:
    1
    Доброе время суток, подскажите как мне сделать так что бы в поле наименование и т.д. проставлялось наименование номенклатуры, группа номенклатуры и артикул
  2. feanor_omsk
    Offline

    feanor_omsk Опытный в 1С

    Регистрация:
    13 апр 2015
    Сообщения:
    162
    Симпатии:
    19
    Баллы:
    29
    Во все печатные формы в УТ 11 в колонку "наименование" попадает реквизит НП "Наименование для печати".
    В настройках вида номенклатуры имеется возможность заполнения данного наименования по шаблону как Вам угодно.
    Затем уже кнопкой справа от реквизита "наименование для печати" заполнить данный реквизит по шаблону. Либо написать обработку, которая по всей номенклатуре автоматически данную кнопочку прокликает)).
  3. TopicStarter Overlay
    Serge5082
    Offline

    Serge5082

    Регистрация:
    28 янв 2016
    Сообщения:
    4
    Симпатии:
    0
    Баллы:
    1
    у меня УТ 10.3, вопрос то в том как это сделать
  4. nomad_irk
    Offline

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.566
    Симпатии:
    717
    Баллы:
    204
    Создаете внешнюю печатную форму, заменяете ей типовую.
  5. TopicStarter Overlay
    Serge5082
    Offline

    Serge5082

    Регистрация:
    28 янв 2016
    Сообщения:
    4
    Симпатии:
    0
    Баллы:
    1
    создать создал но не получается, может подскажите по коду
    вот код
    Код:
    Перем мВалютаРегламентированногоУчета Экспорт;
    
    Функция Печать() Экспорт
        Возврат ПечатьТорг12();
    КонецФункции // Печать
    
    Функция ПечатьТОРГ12(БезУслуг = Ложь) Экспорт
         
            ДопКолонка = Константы.ДополнительнаяКолонкаПечатныхФормДокументов.Получить();
            Если ДопКолонка = Перечисления.ДополнительнаяКолонкаПечатныхФормДокументов.Артикул Тогда
                ТоварКод = "Артикул";
            Иначе
                ТоварКод = "Код";
            КонецЕсли;
            ЕдиницаИзмеренияВеса = Константы.ЕдиницаИзмеренияВеса.Получить();
         
            Запрос = Новый Запрос;
            Запрос.УстановитьПараметр("ДатаСреза",          СсылкаНаОбъект.Дата);
            Запрос.УстановитьПараметр("СтруктурнаяЕдиница", СсылкаНаОбъект.Склад);
            Запрос.УстановитьПараметр("ТекущийДокумент",    СсылкаНаОбъект.Ссылка);
            Запрос.УстановитьПараметр("ПустойКонтрагент",   Справочники.Контрагенты.ПустаяСсылка());
         
            Запрос.Текст =
            "ВЫБРАТЬ
            |    Номер,
            |    Дата КАК ДатаДокумента,
            |    Организация,
            |    Организация КАК ЮрФизЛицо,
            |    Организация КАК Поставщик,
            |    Организация КАК Контрагент,
            |    Организация КАК Руководители,
            |    АдресДоставки КАК АдресДоставки,
            |    ВЫБОР КОГДА Грузополучатель = &ПустойКонтрагент
            |         ТОГДА Контрагент
            |         ИНАЧЕ Грузополучатель КОНЕЦ КАК Грузополучатель,
            |    ВЫБОР КОГДА Грузоотправитель = &ПустойКонтрагент
            |         ТОГДА Организация
            |         ИНАЧЕ Грузоотправитель КОНЕЦ КАК Грузоотправитель,
            |    БанковскийСчетОрганизации КАК БанковскийСчет,
            |    Контрагент КАК Покупатель,
            |    Контрагент КАК Плательщик,
            |    Сделка,
            |    ДоговорКонтрагента.Представление  КАК Основание,
            |    ДоговорКонтрагента.ВедениеВзаиморасчетов КАК ВедениеВзаиморасчетов,
            |    ОтветственныеЛица.ФизическоеЛицо КАК ОтветственноеЛицо,
            |    Подразделение,
            |    ВалютаДокумента,
            |    КурсВзаиморасчетов      КАК Курс,
            |    КратностьВзаиморасчетов КАК Кратность,
            |    УчитыватьНДС,
            |    СуммаВключаетНДС,
            |    ОтпускРазрешил,
            |    ОтпускПроизвел,
            |    ДоверенностьНомер,
            |    ДоверенностьДата,
            |    ДоверенностьВыдана,
            |    ДоверенностьЧерезКого
            |ИЗ
            |    Документ.РеализацияТоваровУслуг КАК РеализацияТоваровУслуг
            |
            |ЛЕВОЕ СОЕДИНЕНИЕ
            |    РегистрСведений.ОтветственныеЛица.СрезПоследних(&ДатаСреза, СтруктурнаяЕдиница = &СтруктурнаяЕдиница) КАК ОтветственныеЛица
            |ПО
            |    ОтветственныеЛица.СтруктурнаяЕдиница = РеализацияТоваровУслуг.Склад
            |
            |ГДЕ
            |    РеализацияТоваровУслуг.Ссылка = &ТекущийДокумент
            |";
         
            Шапка = Запрос.Выполнить().Выбрать();
            Шапка.Следующий();
         
            Запрос = Новый Запрос;
            Запрос.УстановитьПараметр("ТекущийДокумент", СсылкаНаОбъект.Ссылка);
         
            // Вычислим курс документа для печати
            Если СсылкаНаОбъект.ВалютаДокумента <> мВалютаРегламентированногоУчета
              И СсылкаНаОбъект.ДоговорКонтрагента.РасчетыВУсловныхЕдиницах
              И СсылкаНаОбъект.ДоговорКонтрагента.ВестиПоДокументамРасчетовСКонтрагентом Тогда
             
                ЗапросКурсАванса = Новый Запрос;
                ЗапросКурсАванса.УстановитьПараметр("ДокументСсылка", СсылкаНаОбъект.Ссылка);
                ЗапросКурсАванса.Текст =
                "ВЫБРАТЬ
                |    Док.СуммаВзаиморасчетов,
                |    Док.СуммаРегл
                |ИЗ
                |    Документ.РеализацияТоваровУслуг.ДокументыРасчетовСКонтрагентом КАК Док
                |ГДЕ Док.Ссылка = &ДокументСсылка
                |ИТОГИ СУММА(СуммаВзаиморасчетов), СУММА(СуммаРегл) ПО ОБЩИЕ";
             
                Выборка = ЗапросКурсАванса.Выполнить().Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
                Если Выборка.Следующий() Тогда
                    КурсОплаты                 = ?(Выборка.СуммаВзаиморасчетов = 0, 0, Выборка.СуммаРегл/Выборка.СуммаВзаиморасчетов);
                    ВыборкаСуммаВзаиморасчетов = Выборка.СуммаВзаиморасчетов;
                    ВыборкаСуммаРегл           = Выборка.СуммаРегл;
                Иначе
                    КурсОплаты                 = 0;
                    ВыборкаСуммаВзаиморасчетов = 0;
                    ВыборкаСуммаРегл           = 0;
                КонецЕсли;
             
                СуммаВзаиморасчетов = МодульВалютногоУчета.ПересчитатьИзВалютыВВалюту(УчетНДС.ПолучитьСуммуДокументаСНДС(СсылкаНаОбъект.Ссылка),
                СсылкаНаОбъект.ВалютаДокумента, СсылкаНаОбъект.ДоговорКонтрагента.ВалютаВзаиморасчетов,
                ЗаполнениеДокументов.КурсДокумента(СсылкаНаОбъект.Ссылка, мВалютаРегламентированногоУчета), СсылкаНаОбъект.КурсВзаиморасчетов,
                ЗаполнениеДокументов.КратностьДокумента(СсылкаНаОбъект.Ссылка, мВалютаРегламентированногоУчета), СсылкаНаОбъект.КратностьВзаиморасчетов);
                НеоплаченнаяСумма = СуммаВзаиморасчетов - ВыборкаСуммаВзаиморасчетов;
                Если НеоплаченнаяСумма > 0 Тогда
                    КурсДляПечати = (НеоплаченнаяСумма * СсылкаНаОбъект.КурсВзаиморасчетов + ВыборкаСуммаРегл)/(НеоплаченнаяСумма + ВыборкаСуммаВзаиморасчетов);
                Иначе
                    КурсДляПечати = КурсОплаты;
                КонецЕсли;
             
                Если КурсДляПечати = 0 Тогда
                    Запрос.УстановитьПараметр("Курс",      СсылкаНаОбъект.КурсВзаиморасчетов);
                    Запрос.УстановитьПараметр("Кратность", СсылкаНаОбъект.КратностьВзаиморасчетов);
                Иначе
                    Запрос.УстановитьПараметр("Курс",      КурсДляПечати);
                    Запрос.УстановитьПараметр("Кратность", 1);
                КонецЕсли;
             
            ИначеЕсли СсылкаНаОбъект.ВалютаДокумента = СсылкаНаОбъект.ДоговорКонтрагента.ВалютаВзаиморасчетов Тогда
             
                // Документ оформлен в валюте взаиморасчетов
                Запрос.УстановитьПараметр("Курс", СсылкаНаОбъект.КурсВзаиморасчетов);
                Запрос.УстановитьПараметр("Кратность", СсылкаНаОбъект.КратностьВзаиморасчетов);
             
            Иначе
             
                // Документ оформлен в валюте регламентированного учета
                Запрос.УстановитьПараметр("Курс",      1);
                Запрос.УстановитьПараметр("Кратность", 1);
             
            КонецЕсли;
         
            Запрос.Текст =
            "ВЫБРАТЬ
            |    ВложенныйЗапрос.Номенклатура                                  КАК Номенклатура,
            |    ВЫРАЗИТЬ(ВложенныйЗапрос.Номенклатура.НаименованиеПолное КАК Строка(1000)) КАК ТоварНаименование,
            |    ВложенныйЗапрос.Номенклатура." + ТоварКод + "                 КАК ТоварКод,
            |    ВложенныйЗапрос.ЕдиницаИзмерения.Представление                КАК БазоваяЕдиницаНаименование,
            |    ВложенныйЗапрос.ЕдиницаИзмерения.ЕдиницаПоКлассификатору.Код  КАК БазоваяЕдиницаКодПоОКЕИ,
            |    ВложенныйЗапрос.ЕдиницаИзмерения     КАК ЕдиницаИзмерения,
            |    ВложенныйЗапрос.ЕдиницаИзмеренияМест.Представление            КАК ВидУпаковки,
            |    ВложенныйЗапрос.КоэффициентМест / ВложенныйЗапрос.Коэффициент КАК КоличествоВОдномМесте,
            |    ВЫБОР
            |        КОГДА ВложенныйЗапрос.КоличествоМест > 0 ТОГДА ВложенныйЗапрос.КоличествоМест * ВложенныйЗапрос.ЕдиницаИзмеренияМест.Вес
            |        ИНАЧЕ ВложенныйЗапрос.Количество * ВложенныйЗапрос.ЕдиницаИзмерения.Вес
            |    КОНЕЦ КАК МассаБрутто,
            |    ВложенныйЗапрос.Характеристика       КАК Характеристика,
            |    ВложенныйЗапрос.Серия                КАК Серия,
            |    ВложенныйЗапрос.СтавкаНДС            КАК СтавкаНДС,
            |    ВложенныйЗапрос.Цена                 КАК Цена,
            |    ВЫБОР
            |        КОГДА((ВложенныйЗапрос.ПроцентСкидкиНаценки = 0) И
            |             (ВложенныйЗапрос.ПроцентАвтоматическихСкидок = 0))
            |    ТОГДА ЛОЖЬ
            |    ИНАЧЕ Истина
            |    КОНЕЦ                                КАК ЕстьСкидкиПоСтроке,
            |    ВложенныйЗапрос.Количество           КАК Количество,
            |    ВложенныйЗапрос.КоличествоМест       КАК КоличествоМест,
            |    ВложенныйЗапрос.Сумма                КАК Сумма,
            |    ВложенныйЗапрос.СуммаНДС             КАК СуммаНДС,
            |    ВложенныйЗапрос.НомерСтроки          КАК НомерСтроки,
            |    ВложенныйЗапрос.Метка                КАК Метка
            |ИЗ
            |
            |    (
            |    ВЫБРАТЬ
            |        РеализацияТоваровУслуг.Номенклатура,
            |        РеализацияТоваровУслуг.Коэффициент,
            |        РеализацияТоваровУслуг.ЕдиницаИзмерения,
            |        РеализацияТоваровУслуг.ЕдиницаИзмеренияМест,
            |        РеализацияТоваровУслуг.ЕдиницаИзмеренияМест.Коэффициент     КАК КоэффициентМест,
            |        РеализацияТоваровУслуг.ХарактеристикаНоменклатуры           КАК Характеристика,
            |        РеализацияТоваровУслуг.СерияНоменклатуры                    КАК Серия,
            |        РеализацияТоваровУслуг.СтавкаНДС,
            |        РеализацияТоваровУслуг.Цена * &Курс / &Кратность            КАК Цена,
            |        РеализацияТоваровУслуг.ПроцентСкидкиНаценки,
            |        РеализацияТоваровУслуг.ПроцентАвтоматическихСкидок,
            |        СУММА(РеализацияТоваровУслуг.Количество)                    КАК Количество,
            |        СУММА(РеализацияТоваровУслуг.КоличествоМест)                КАК КоличествоМест,
            |        СУММА(РеализацияТоваровУслуг.Сумма    * &Курс / &Кратность) КАК Сумма,
            |        СУММА(РеализацияТоваровУслуг.СуммаНДС * &Курс / &Кратность) КАК СуммаНДС,
            |        МИНИМУМ(РеализацияТоваровУслуг.НомерСтроки)                 КАК НомерСтроки,
            |        0                                                           КАК Метка
            |    ИЗ
            |        Документ.РеализацияТоваровУслуг.Товары КАК РеализацияТоваровУслуг
            |    ГДЕ
            |        РеализацияТоваровУслуг.Ссылка = &ТекущийДокумент
            |
            |СГРУППИРОВАТЬ ПО
            |        РеализацияТоваровУслуг.Номенклатура,
            |        РеализацияТоваровУслуг.Коэффициент,
            |        РеализацияТоваровУслуг.ЕдиницаИзмерения,
            |        РеализацияТоваровУслуг.ЕдиницаИзмеренияМест,
            |        РеализацияТоваровУслуг.ХарактеристикаНоменклатуры,
            |        РеализацияТоваровУслуг.СерияНоменклатуры,
            |        РеализацияТоваровУслуг.СтавкаНДС,
            |        РеализацияТоваровУслуг.Цена,
            |        РеализацияТоваровУслуг.ПроцентСкидкиНаценки,
            |        РеализацияТоваровУслуг.ПроцентАвтоматическихСкидок
            |    ) КАК ВложенныйЗапрос
            |";
         
            Если НЕ БезУслуг Тогда
             
                СтрокаВыборкиПоляСодержания = ОбработкаТабличныхЧастей.ПолучитьЧастьЗапросаДляВыбораСодержания("РеализацияТоваровУслуг");
             
                Запрос.Текст = Запрос.Текст + "
                |
                |ОБЪЕДИНИТЬ ВСЕ
                |
                |ВЫБРАТЬ
                |    РеализацияТоваровУслуг.Номенклатура                  КАК Номенклатура,
                |    " + СтрокаВыборкиПоляСодержания + "                  КАК ТоварНаименование,
                |    РеализацияТоваровУслуг.Номенклатура." + ТоварКод + " КАК ТоварКод,
                |    РеализацияТоваровУслуг.Номенклатура.ЕдиницаХраненияОстатков.Представление КАК БазоваяЕдиницаНаименование,
                |    РеализацияТоваровУслуг.Номенклатура.ЕдиницаХраненияОстатков.ЕдиницаПоКлассификатору.Код КАК БазоваяЕдиницаКодПоОКЕИ,
                |    РеализацияТоваровУслуг.Номенклатура.ЕдиницаХраненияОстатков КАК ЕдиницаИзмерения,
                |    NULL                                                 КАК ВидУпаковки,
                |    NULL                                                 КАК КоличествоВОдномМесте,
                |    0                                                    КАК МассаБрутто,
                |    NULL                                                 КАК Характеристика,
                |    NULL                                                 КАК Серия,
                |    РеализацияТоваровУслуг.СтавкаНДС                     КАК СтавкаНДС,
                |    РеализацияТоваровУслуг.Цена * &Курс / &Кратность     КАК Цена,
                |    ВЫБОР
                |        КОГДА(РеализацияТоваровУслуг.ПроцентСкидкиНаценки = 0)
                |    ТОГДА ЛОЖЬ
                |    ИНАЧЕ Истина
                |    КОНЕЦ                                                КАК ЕстьСкидкиПоСтроке,
                |    РеализацияТоваровУслуг.Количество                    КАК Количество,
                |    NULL                                                 КАК КоличествоМест,
                |    РеализацияТоваровУслуг.Сумма    * &Курс / &Кратность КАК Сумма,
                |    РеализацияТоваровУслуг.СуммаНДС * &Курс / &Кратность КАК СуммаНДС,
                |    РеализацияТоваровУслуг.НомерСтроки                   КАК НомерСтроки,
                |    1                                                    КАК Метка
                |ИЗ
                |    Документ.РеализацияТоваровУслуг.Услуги КАК РеализацияТоваровУслуг
                |
                |ГДЕ
                |    РеализацияТоваровУслуг.Ссылка = &ТекущийДокумент
                |";
            КонецЕсли;
         
            Запрос.Текст = Запрос.Текст + "
            |
            |ОБЪЕДИНИТЬ ВСЕ
            |
            |ВЫБРАТЬ
            |    РеализацияТоваровУслуг.Номенклатура                    КАК Номенклатура,
            |    ВЫРАЗИТЬ(РеализацияТоваровУслуг.Номенклатура.НаименованиеПолное КАК Строка(1000)) КАК ТоварНаименование,
            |    РеализацияТоваровУслуг.Номенклатура." + ТоварКод + "   КАК ТоварКод,
            |    РеализацияТоваровУслуг.Номенклатура.ЕдиницаХраненияОстатков.Представление               КАК БазоваяЕдиницаНаименование,
            |    РеализацияТоваровУслуг.Номенклатура.ЕдиницаХраненияОстатков.ЕдиницаПоКлассификатору.Код КАК БазоваяЕдиницаКодПоОКЕИ,
            |    РеализацияТоваровУслуг.Номенклатура.ЕдиницаХраненияОстатков                             КАК ЕдиницаИзмерения,
            |    NULL                                                  КАК ВидУпаковки,
            |    NULL                                                  КАК КоличествоВОдномМесте,
            |    РеализацияТоваровУслуг.Количество * РеализацияТоваровУслуг.Номенклатура.ЕдиницаХраненияОстатков.Вес КАК МассаБрутто,
            |    NULL                                                  КАК Характеристика,
            |    NULL                                                  КАК Серия,
            |    ""Без НДС""                                           КАК СтавкаНДС,
            |    РеализацияТоваровУслуг.Цена                           КАК Цена,
            |    Ложь                                                  КАК ЕстьСкидкиПоСтроке,
            |    РеализацияТоваровУслуг.Количество                     КАК Количество,
            |    NULL                                                  КАК КоличествоМест,
            |    РеализацияТоваровУслуг.Сумма                          КАК Сумма,
            |    0                                                     КАК СуммаНДС,
            |    РеализацияТоваровУслуг.НомерСтроки                    КАК НомерСтроки,
            |    2                                                     КАК Метка
            |ИЗ
            |(
            |    ВЫБРАТЬ
            |        РеализацияТоваровУслуг.Номенклатура                      КАК Номенклатура,
            |        РеализацияТоваровУслуг.Цена * &Курс / &Кратность         КАК Цена,
            |        СУММА(РеализацияТоваровУслуг.Количество)                 КАК Количество,
            |        СУММА(РеализацияТоваровУслуг.Сумма * &Курс / &Кратность) КАК Сумма,
            |        МИНИМУМ(РеализацияТоваровУслуг.НомерСтроки)              КАК НомерСтроки
            |    ИЗ
            |        Документ.РеализацияТоваровУслуг.ВозвратнаяТара КАК РеализацияТоваровУслуг
            |
            |    ГДЕ
            |        РеализацияТоваровУслуг.Ссылка = &ТекущийДокумент
            |    СГРУППИРОВАТЬ ПО
            |        РеализацияТоваровУслуг.Номенклатура,
            |        РеализацияТоваровУслуг.Цена
            |) КАК РеализацияТоваровУслуг
            |УПОРЯДОЧИТЬ ПО Метка ВОЗР, НомерСтроки ВОЗР
            |
            |";
    --- Объединение сообщений, 3 июн 2016 ---
    верней вот сама печатная форма
    --- Объединение сообщений, 3 июн 2016 ---
    народ помоги пожалуйста, запутался в трех соснах

    Вложения:

    • TORG12.epf
      Размер файла:
      16,9 КБ
      Просмотров:
      1
    Последнее редактирование модератором: 3 июн 2016
  6. nsk1C
    Offline

    nsk1C Опытный в 1С

    Регистрация:
    25 май 2016
    Сообщения:
    176
    Симпатии:
    15
    Баллы:
    29
    Чего велосипед-то изобретать
    Там в существующей ПечатьДокумента()
    • - см. модуль объекта после
      Макет = ПолучитьМакет("Накладная");
      ну, и сам макет
    и Номенклатура (чтобы получить группу), и (Номенклатура.ПолноеНаименование КАК Товар), и Артикул уже получаются запросами.
    Бери, да пользуйся (копируй или редактируй)
  7. TopicStarter Overlay
    Serge5082
    Offline

    Serge5082

    Регистрация:
    28 янв 2016
    Сообщения:
    4
    Симпатии:
    0
    Баллы:
    1
    если честно не чего не понял, извините за тупость мою
  8. nsk1C
    Offline

    nsk1C Опытный в 1С

    Регистрация:
    25 май 2016
    Сообщения:
    176
    Симпатии:
    15
    Баллы:
    29
    В модуле объекта документа Реализация товаров и услуг ПечатьДокумента() уже есть готовые запросы.
    Почему бы просто не скопировать оттуда?

    Другое дело, что ТОРГ-12 используется не только в этом документе

    Потом, непонятно - что именно не получается
Похожие темы
  1. DimitSok
    Ответов:
    8
    Просмотров:
    1.154
Загрузка...

Поделиться этой страницей