7.7 торг-12

Тема в разделе "Типовые решения "1С:Предприятие 7.7"", создана пользователем qweasd, 23 авг 2011.

  1. TopicStarter Overlay
    qweasd
    Offline

    qweasd

    Регистрация:
    8 мар 2010
    Сообщения:
    20
    Симпатии:
    0
    Баллы:
    1
    помоги пожал разобраться, есть документ возврат от поставщика, ее необходимо распечатать как ТОРГ-12, но при открытии много полей не отпределяются,пишутся в виде кода, открыла форму возврата от поставщика в конфигураторе, однако таблицы там не обнаружила, печатная форма торг -12 из prnForms отличается от того что выводит на печать, как найти форму на которую ссылается данный документ ,привожу часть кода

    Процедура ПоКнопкеПечать(СразуНаПринтер = 0,КолЭкз = 1)

    // проверим полномочия печати непроведенных документов
    Если Проведен() = 0 Тогда
    Если глПолучитьПолномочие("РазрешитьПечатьНепроведенныхДокументов") = 0 Тогда
    Предупреждение("Недостаточно полномочий для печати непроведенного документа!", 60);
    Возврат;
    КонецЕсли;
    КонецЕсли;

    Если ПустоеЗначение(НомерТекущейФормы) = 1 Тогда
    НомерТекущейФормы = 1;
    Форма.кнПечать.Заголовок(ТаблицаПечФорм.ПолучитьЗначение(НомерТекущейФормы, "Кнопка"));
    КонецЕсли;

    Если НомерТекущейФормы = 1 Тогда
    Печать(СразуНаПринтер, КолЭкз);
    Иначе
    Параметры = СоздатьОбъект("СписокЗначений");
    Параметры.ДобавитьЗначение(глВзятьКонтекст(Контекст), "Контекст");
    Параметры.ДобавитьЗначение(СразуНаПринтер, "Устройство");
    Параметры.ДобавитьЗначение(КолЭкз, "КоличествоКопий");

    ОткрытьФорму("Отчет", Параметры, глКаталогПечФорм+ТаблицаПечФорм.ПолучитьЗначение(НомерТекущейФормы,"Файл"));
    КонецЕсли;

    КонецПроцедуры // ПоКнопкеПечать()


    буду благодарна конфиг комплекс 7.7
  2. shurikvz
    Offline

    shurikvz Модераторы Команда форума Модератор

    Регистрация:
    1 окт 2009
    Сообщения:
    8.409
    Симпатии:
    316
    Баллы:
    104
    В конфигураторе в общих макетах посмотрите.
  3. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Общий макет править не нужно.... Лучше скопируйте его отдельно - в маеты формы документа ворзврат например.
  4. TopicStarter Overlay
    qweasd
    Offline

    qweasd

    Регистрация:
    8 мар 2010
    Сообщения:
    20
    Симпатии:
    0
    Баллы:
    1
    спасибо
  5. TopicStarter Overlay
    qweasd
    Offline

    qweasd

    Регистрация:
    8 мар 2010
    Сообщения:
    20
    Симпатии:
    0
    Баллы:
    1
    а не подскажите в каком каталоге они хранятся? макеты
  6. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Стандартно в: КаталогБД\ExtForms\PrnForms
Похожие темы
  1. Skazi
    Ответов:
    2
    Просмотров:
    701
Загрузка...

Поделиться этой страницей