8.х ТОРГ-12

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Goth, 2 май 2007.

  1. TopicStarter Overlay
    Goth
    Offline

    Goth

    Регистрация:
    4 апр 2007
    Сообщения:
    32
    Симпатии:
    0
    Баллы:
    1
    Всем привет. Вопрос такой: Во внешней обработке есть табличный доумент, он заполняется документами, таким образом, чтобы напростив каждой строчки стоял флажок. Как сделать так чтобы, если я поставил галочку во флажок, данные из этого документа, напротив которго стоит галочка, добавлялись в печатную форму ТОРГ-12. Спасибо.

    Вложения:

  2. СисПро
    Offline

    СисПро

    Регистрация:
    24 апр 2007
    Сообщения:
    11
    Симпатии:
    0
    Баллы:
    1
    Всем привет. Вопрос такой: Во внешней обработке есть табличный доумент, он заполняется документами, таким образом, чтобы напростив каждой строчки стоял флажок. Как сделать так чтобы, если я поставил галочку во флажок, данные из этого документа, напротив которго стоит галочка, добавлялись в печатную форму ТОРГ-12. Спасибо.

    Для каждой СтрокиТаблицыВнешнейОбработки Из ТаблицаВнешнейОбработки Цикл
    Если ГалочкаСтоит Тогда
    БерёмНужныеДанныеИзЭтогоДокументаИДобавляемВПечатнуюФорму();
    КонецЕсли;
  3. TopicStarter Overlay
    Goth
    Offline

    Goth

    Регистрация:
    4 апр 2007
    Сообщения:
    32
    Симпатии:
    0
    Баллы:
    1
    А в какую процедуру это писать? И кстати как добавлять данные в печатную форму?

    Код:
    Для Каждого СтрокиТаблицыЗаказов ИЗ ТаблицаЗаказов Цикл 
    Если ЭлементыФормы.ФлагЗаказа.Значение=Истина И ЭлементыФормы.ФлагПроведенных.Значение=Истина Тогда
    НапечататьДокумент(ПечатьТОРГ12(ЭтотЗаказ));
    КонецЕсли;    
    ОбработкаПрерыванияПользователя();    
    КонецЦикла;
    
Похожие темы
  1. Skazi
    Ответов:
    2
    Просмотров:
    703
Загрузка...

Поделиться этой страницей