7.7 торг-12 нужен кпп

Тема в разделе "Отчеты и обработки для "1С:Предприятие 7.7"", создана пользователем fialka_night, 10 авг 2009.

  1. Elena_
    Offline

    Elena_

    Регистрация:
    28 окт 2013
    Сообщения:
    25
    Симпатии:
    0
    Баллы:
    1
    Для тех кто столкнется с такой же проблемой.

    Код:
     // формирование адреса плательщика
    СчетКонтрагента = "";
    СчетКонтрагента = глРасчетныйСчетКонтрагента(Контрагент);
    ИННКонтрагента = ?(Контрагент.ВидКонтрагента = Перечисление.ВидыКонтрагентов.ЧастноеЛицо, СРЕД(Контрагент.ИНН,1,12),СРЕД(Контрагент.ИНН,1,10));
    КППКонтрагента = ?(Контрагент.ВидКонтрагента = Перечисление.ВидыКонтрагентов.ЧастноеЛицо,"",СРЕД(Контрагент.ИНН,12));
    КонтрагентАдрес = СокрЛП(Контрагент.ПолнНаименование)+?(ПустоеЗначение(ИННКонтрагента) = 0, ", ИНН " + ИННКонтрагента, "")+?(ПустоеЗначение(КППКонтрагента) = 0, ", КПП " + КППКонтрагента, "")+", "+СокрЛП(Контрагент.ЮридическийАдрес)+", тел: "+СокрЛП(Контрагент.Телефоны);
    Если ПустоеЗначение(СчетКонтрагента) = 0 Тогда
    глДобавитьРеквизит(КонтрагентАдрес, ", р/с ", СокрЛП(СчетКонтрагента.Номер) + " в " + СчетКонтрагента.БанкОрганизации);
    глДобавитьРеквизит(КонтрагентАдрес, ", БИК ", СокрЛП(СчетКонтрагента.БанкОрганизации.Код));
    глДобавитьРеквизит(КонтрагентАдрес, ", корр/с ", СчетКонтрагента.БанкОрганизации.КоррСчет);
    КонецЕсли;
    ПлательщикОКПО = Контрагент.ОКПО;
    // формирование адреса грузополучателя
    Если ПустоеЗначение(Грузополучатель) = 1 Тогда
    ГрузополучательАдрес = СокрЛП(Контрагент.ПолнНаименование)+?(ПустоеЗначение(ИННКонтрагента) = 0, ", ИНН " + ИННКонтрагента, "")+", "+СокрЛП(Контрагент.ПочтовыйАдрес)+", тел: "+СокрЛП(Контрагент.Телефоны);
    Если ПустоеЗначение(СчетКонтрагента) = 0 Тогда
    глДобавитьРеквизит(ГрузополучательАдрес, ", р/с ", СокрЛП(СчетКонтрагента.Номер) + " в " + СчетКонтрагента.БанкОрганизации);
    глДобавитьРеквизит(ГрузополучательАдрес, ", БИК ", СокрЛП(СчетКонтрагента.БанкОрганизации.Код));
    глДобавитьРеквизит(ГрузополучательАдрес, ", корр/с ", СчетКонтрагента.БанкОрганизации.КоррСчет);
    КонецЕсли;
    ГрузополучательОКПО = Контрагент.ОКПО;
    Иначе
    СчетКонтрагента = "";
    СчетКонтрагента = глРасчетныйСчетКонтрагента(Грузополучатель);
    ИННКонтрагента = ?(Грузополучатель.ВидКонтрагента = Перечисление.ВидыКонтрагентов.ЧастноеЛицо, СРЕД(Грузополучатель.ИНН,1,12),СРЕД(Грузополучатель.ИНН,1,10));
    КППКонтрагента = ?(Грузополучатель.ВидКонтрагента = Перечисление.ВидыКонтрагентов.ЧастноеЛицо,"",СРЕД(Грузополучатель.ИНН,12));
    ГрузополучательАдрес = СокрЛП(Грузополучатель.ПолнНаименование)+?(ПустоеЗначение(ИННКонтрагента) = 0, ", ИНН " + ИННКонтрагента, "")+?(ПустоеЗначение(КППКонтрагента) = 0, ", КПП " + КППКонтрагента, "")+", "+СокрЛП(Грузополучатель.ПочтовыйАдрес)+", тел: "+СокрЛП(Грузополучатель.Телефоны);
    Если ПустоеЗначение(СчетКонтрагента) = 0 Тогда 
    глДобавитьРеквизит(ГрузополучательАдрес, ", р/с ", СокрЛП(СчетКонтрагента.Номер) + " в " + СчетКонтрагента.БанкОрганизации);
    глДобавитьРеквизит(ГрузополучательАдрес, ", БИК ", СокрЛП(СчетКонтрагента.БанкОрганизации.Код));
    глДобавитьРеквизит(ГрузополучательАдрес, ", корр/с ", СчетКонтрагента.БанкОрганизации.КоррСчет);
    КонецЕсли;
    ГрузополучательОКПО = Грузополучатель.ОКПО;
    КонецЕсли;   
    Еще раз.... Спасибо! :sm_rose:

Поделиться этой страницей