7.7 торг-12 нужен кпп

Тема в разделе "Отчеты и обработки для "1С:Предприятие 7.7"", создана пользователем fialka_night, 10 авг 2009.

  1. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    По аналогии
    Код:
    КППКонтрагента = ?(Грузополучатель.ВидКонтрагента = Перечисление.ВидыКонтрагентов.ЧастноеЛицо, СРЕД(Грузополучатель.ИНН,14),СРЕД(Грузополучатель.ИНН,12));
  2. Elena_
    Offline

    Elena_

    Регистрация:
    28 окт 2013
    Сообщения:
    25
    Симпатии:
    0
    Баллы:
    1
    Добавить ниже новую строку?
  3. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Ну... в принципе не помешает)))))))
    Реквизит Грузополучатель.ИНН содержи ИНН и КПП (разделитель / или \)
    Вам зачем-то понадобилось выделить отдельно в переменную ИНН и КПП.
    Как выделить я вам подсказал. Что с этим делать - ваши проблемы))))))
  4. Elena_
    Offline

    Elena_

    Регистрация:
    28 окт 2013
    Сообщения:
    25
    Симпатии:
    0
    Баллы:
    1
    не выводит

    клиент требует чтобы в торг-12 КПП было.
  5. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    В самой форме справочника он у вас забит?
    Инн должен иметь вид типа 12345678912/123456789..
    К тому же я ошибся. У ФизЛиц КПП нет... Поэтому код такой
    Код:
    КППКонтрагента = ?(Грузополучатель.ВидКонтрагента = Перечисление.ВидыКонтрагентов.ЧастноеЛицо, "",СРЕД(Грузополучатель.ИНН,12));
  6. Elena_
    Offline

    Elena_

    Регистрация:
    28 окт 2013
    Сообщения:
    25
    Симпатии:
    0
    Баллы:
    1
    Исправила, но всё равно КПП не печатается

    Да, забит
  7. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    А вы в шаблоны добавили переменную которую вычисляем?
    В типовой есть код типа
    Код:
    глДобавитьРеквизит(ГрузополучательАдрес, ", корр/с ", СчетКонтрагента.БанкОрганизации.КоррСчет);
    Вы вообще переделываете печать в модуле формы документа или ВПФ?
  8. Elena_
    Offline

    Elena_

    Регистрация:
    28 окт 2013
    Сообщения:
    25
    Симпатии:
    0
    Баллы:
    1
    в модуле формы (Документ Расходная накладная-Форма-закладка Модуль)
  9. Elena_
    Offline

    Elena_

    Регистрация:
    28 окт 2013
    Сообщения:
    25
    Симпатии:
    0
    Баллы:
    1
    "А вы в шаблоны добавили переменную которую вычисляем?" Это как?
    "В типовой есть код типа
    глДобавитьРеквизит(ГрузополучательАдрес, ", корр/с ", СчетКонтрагента.БанкОрганизации.КоррСчет);" Такой код есть или же Вы имеете ввиду для КПП такой надо сделать?

    // формирование адреса грузополучателя
    Если ПустоеЗначение(Грузополучатель) = 1 Тогда
    ГрузополучательАдрес = СокрЛП(Контрагент.ПолнНаименование)+?(ПустоеЗначение(ИННКонтрагента) = 0, ", ИНН " + ИННКонтрагента, "")+", "+СокрЛП(Контрагент.ПочтовыйАдрес)+", тел: "+СокрЛП(Контрагент.Телефоны);
    Если ПустоеЗначение(СчетКонтрагента) = 0 Тогда
    глДобавитьРеквизит(ГрузополучательАдрес, ", р/с ", СокрЛП(СчетКонтрагента.Номер) + " в " + СчетКонтрагента.БанкОрганизации);
    глДобавитьРеквизит(ГрузополучательАдрес, ", БИК ", СокрЛП(СчетКонтрагента.БанкОрганизации.Код));
    глДобавитьРеквизит(ГрузополучательАдрес, ", корр/с ", СчетКонтрагента.БанкОрганизации.КоррСчет);
    КонецЕсли;
    ГрузополучательОКПО = Контрагент.ОКПО;
    Иначе
    СчетКонтрагента = "";
    СчетКонтрагента = глРасчетныйСчетКонтрагента(Грузополучатель);
    ИННКонтрагента = ?(Грузополучатель.ВидКонтрагента = Перечисление.ВидыКонтрагентов.ЧастноеЛицо, СРЕД(Грузополучатель.ИНН,1,12),СРЕД(Грузополучатель.ИНН,1,10));
    КППКонтрагента = ?(Грузополучатель.ВидКонтрагента = Перечисление.ВидыКонтрагентов.ЧастноеЛицо,"",СРЕД(Грузополучатель.ИНН,12));
    ГрузополучательАдрес = СокрЛП(Грузополучатель.ПолнНаименование)+?(ПустоеЗначение(ИННКонтрагента) = 0, ", ИНН " + ИННКонтрагента, "")+", "+СокрЛП(Грузополучатель.ПочтовыйАдрес)+", тел: "+СокрЛП(Грузополучатель.Телефоны);
    Если ПустоеЗначение(СчетКонтрагента) = 0 Тогда
    глДобавитьРеквизит(ГрузополучательАдрес, ", р/с ", СокрЛП(СчетКонтрагента.Номер) + " в " + СчетКонтрагента.БанкОрганизации);
    глДобавитьРеквизит(ГрузополучательАдрес, ", БИК ", СокрЛП(СчетКонтрагента.БанкОрганизации.Код));
    глДобавитьРеквизит(ГрузополучательАдрес, ", корр/с ", СчетКонтрагента.БанкОрганизации.КоррСчет);
    КонецЕсли;
    ГрузополучательОКПО = Грузополучатель.ОКПО;
    КонецЕсли;
    Код:
     // формирование адреса грузополучателя
    Если ПустоеЗначение(Грузополучатель) = 1 Тогда
    ГрузополучательАдрес = СокрЛП(Контрагент.ПолнНаименование)+?(ПустоеЗначение(ИННКонтрагента) = 0, ", ИНН " + ИННКонтрагента, "")+", "+СокрЛП(Контрагент.ПочтовыйАдрес)+", тел: "+СокрЛП(Контрагент.Телефоны);
    Если ПустоеЗначение(СчетКонтрагента) = 0 Тогда
    глДобавитьРеквизит(ГрузополучательАдрес, ", р/с ", СокрЛП(СчетКонтрагента.Номер) + " в " + СчетКонтрагента.БанкОрганизации);
    глДобавитьРеквизит(ГрузополучательАдрес, ", БИК ", СокрЛП(СчетКонтрагента.БанкОрганизации.Код));
    глДобавитьРеквизит(ГрузополучательАдрес, ", корр/с ", СчетКонтрагента.БанкОрганизации.КоррСчет);
    КонецЕсли;
    ГрузополучательОКПО = Контрагент.ОКПО;
    Иначе
    СчетКонтрагента = "";
    СчетКонтрагента = глРасчетныйСчетКонтрагента(Грузополучатель);
    ИННКонтрагента = ?(Грузополучатель.ВидКонтрагента = Перечисление.ВидыКонтрагентов.ЧастноеЛицо, СРЕД(Грузополучатель.ИНН,1,12),СРЕД(Грузополучатель.ИНН,1,10));
    КППКонтрагента = ?(Грузополучатель.ВидКонтрагента = Перечисление.ВидыКонтрагентов.ЧастноеЛицо,"",СРЕД(Грузополучатель.ИНН,12));
    ГрузополучательАдрес = СокрЛП(Грузополучатель.ПолнНаименование)+?(ПустоеЗначение(ИННКонтрагента) = 0, ", ИНН " + ИННКонтрагента, "")+", "+СокрЛП(Грузополучатель.ПочтовыйАдрес)+", тел: "+СокрЛП(Грузополучатель.Телефоны);
    Если ПустоеЗначение(СчетКонтрагента) = 0 Тогда
    глДобавитьРеквизит(ГрузополучательАдрес, ", р/с ", СокрЛП(СчетКонтрагента.Номер) + " в " + СчетКонтрагента.БанкОрганизации);
    глДобавитьРеквизит(ГрузополучательАдрес, ", БИК ", СокрЛП(СчетКонтрагента.БанкОрганизации.Код));
    глДобавитьРеквизит(ГрузополучательАдрес, ", корр/с ", СчетКонтрагента.БанкОрганизации.КоррСчет);
    КонецЕсли;
    ГрузополучательОКПО = Грузополучатель.ОКПО;
    КонецЕсли;   
  10. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Нужно ДОБАВИТЬ вычисленную ранее переменную КППКонтрагента в нужную процедуру глДобавитьРеквизит
  11. Elena_
    Offline

    Elena_

    Регистрация:
    28 окт 2013
    Сообщения:
    25
    Симпатии:
    0
    Баллы:
    1
    Код:
    глДобавитьРеквизит(ГрузополучательАдрес, ", КПП ", КППКонтрагента);
    Такой?
  12. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Почти. Ибо в случае ФизЛица о КПП не должно быть упоминания
    Код:
    Если ПустоеЗначение(КППКонтрагента)=0 Тогда
    глДобавитьРеквизит(ГрузополучательАдрес, ", КПП ", КППКонтрагента);
    КонецЕсли;
    
  13. Elena_
    Offline

    Elena_

    Регистрация:
    28 окт 2013
    Сообщения:
    25
    Симпатии:
    0
    Баллы:
    1
    КПП отоброжается, но мочемуто в конце, (перед банковскими реквизитами). а не после ИНН.

    Сейчас попробую

    а теперь КПП пропал

    Код:
    ГрузополучательАдрес = СокрЛП(Грузополучатель.ПолнНаименование)+?(ПустоеЗначение(ИННКонтрагента) = 0, ", ИНН " + ИННКонтрагента, "")+", "+СокрЛП(Грузополучатель.ПочтовыйАдрес)+", тел: "+СокрЛП(Грузополучатель.Телефоны);
    может вот в эту строку добавить КПП?
  14. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Правильно... После конструкции ИННКонтрагента добавьте КППКонтрагента по аналогии
  15. Elena_
    Offline

    Elena_

    Регистрация:
    28 окт 2013
    Сообщения:
    25
    Симпатии:
    0
    Баллы:
    1
    Код:
    ГрузополучательАдрес = СокрЛП(Грузополучатель.ПолнНаименование)+?(ПустоеЗначение(ИННКонтрагента) = 0, ", ИНН " + ИННКонтрагента, "")+", "+СокрЛП(Грузополучатель.КППКонтрагента)+", "+СокрЛП(Грузополучатель.ПочтовыйАдрес)+", тел: "+СокрЛП(Грузополучатель.Телефоны);
    например такой?

    по аналогии!? надо подумать..
  16. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Вот так:
    Код:
    ГрузополучательАдрес = СокрЛП(Грузополучатель.ПолнНаименование)+?(ПустоеЗначение(ИННКонтрагента) = 0, ", ИНН " + ИННКонтрагента, "")+", "+?(ПустоеЗначение(КППКонтрагента) = 0, ", КПП " + КППКонтрагента, "")+", "+СокрЛП(Грузополучатель.ПочтовыйАдрес)+", тел: "+СокрЛП(Грузополучатель.Телефоны);
  17. Elena_
    Offline

    Elena_

    Регистрация:
    28 окт 2013
    Сообщения:
    25
    Симпатии:
    0
    Баллы:
    1
    Большое спасибо!

    Код:
    ГрузополучательАдрес = СокрЛП(Грузополучатель.ПолнНаименование)+?(ПустоеЗначение(ИННКонтрагента) = 0, ", ИНН " + ИННКонтрагента, "")+?(ПустоеЗначение(КППКонтрагента) = 0, ", КПП " + КППКонтрагента, "")+", "+СокрЛП(Грузополучатель.ПочтовыйАдрес)+", тел: "+СокрЛП(Грузополучатель.Телефоны);
    Я немножко подправила, а то лишняя запятая появляется.
    По аналогии сделаю для плательщика.
  18. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Да не за что.... Просто в чем прикол - так и не понял.
    Такая вот конструкция чем не устраивала?
    Код:
    ГрузополучательАдрес = СокрЛП(Грузополучатель.ПолнНаименование)+?(ПустоеЗначение(Грузополучатель.ИНН) = 0, ", ИНН/КПП" + Грузополучатель.ИНН, "")+", "+СокрЛП(Грузополучатель.ПочтовыйАдрес)+", тел: "+СокрЛП(Грузополучатель.Телефоны);
  19. Elena_
    Offline

    Elena_

    Регистрация:
    28 окт 2013
    Сообщения:
    25
    Симпатии:
    0
    Баллы:
    1
    меня она устраивае..меня вообще устраивает и без КПП, но клиент отказывается принимать товар и сотрудничать дальше если Торг-12 не переделаем так как он хочет (у них программа не может сканировать торг-12 из-за "/").
    А что за кнопочка? Где она?
  20. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Понятно. Про кнопочку - вы ее нашли)

Поделиться этой страницей