8.х Торг-12: не выдает Основание

Тема в разделе "Отчеты и обработки для "1С:Предприятие 8"", создана пользователем duncan, 29 июл 2013.

  1. Annie
    Offline

    Annie Опытный в 1С Команда форума

    Регистрация:
    10 фев 2010
    Сообщения:
    949
    Симпатии:
    23
    Баллы:
    29
    duncan, вы меня слышите? ))) Никто вам не сможет подсказать какие данные должны быть в свойствах "ОснованиеТорг12" или "ДатаНомерДоговораВОснованииТорг12", мы не знаем какие у вас договора, какие контрагенты, какие основания и т.д. и т.п. Обратитесь к бухгалтеру, операционисту или еще кому-н., кто владеет данной информацией.
    Когда узнаете, смело заносите в регистр... (опять-таки, если это действительно нужно)
  2. TopicStarter Overlay
    duncan
    Offline

    duncan

    Регистрация:
    29 июл 2013
    Сообщения:
    28
    Симпатии:
    0
    Баллы:
    1
    Спасибо!
  3. Yuriy_Alexandrovich
    Offline

    Yuriy_Alexandrovich Профессионал в 1С Команда форума

    Регистрация:
    15 сен 2011
    Сообщения:
    1.275
    Симпатии:
    76
    Баллы:
    54
    Доброго всем
    Как ранее говорили, Посмотрите свойства и категории у выбранного контрагента "ДатаНомерДоговораВОснованииТорг12", если его нет то добавте, примерно как на изображении, тип значения "Булево", значение "Истина"
    Посмотреть вложение 15711

    Чтобы найти правильное наименование свойства, Полный Интерфейс - "Операции" - "План видов характеристик" - "Свойства объектов", ищем, что то нам подходящее по наименованию

    Вложения:

  4. TopicStarter Overlay
    duncan
    Offline

    duncan

    Регистрация:
    29 июл 2013
    Сообщения:
    28
    Симпатии:
    0
    Баллы:
    1
    Здравствуйте!
    А возможно из документа реализации из комментариев первые десять символов поместить в печатную форму торг12(основание)?
  5. TopicStarter Overlay
    duncan
    Offline

    duncan

    Регистрация:
    29 июл 2013
    Сообщения:
    28
    Симпатии:
    0
    Баллы:
    1
    Annie,
    Подскажите Пожалуйста с моим вопросом :sm_rolleyes:
  6. Annie
    Offline

    Annie Опытный в 1С Команда форума

    Регистрация:
    10 фев 2010
    Сообщения:
    949
    Симпатии:
    23
    Баллы:
    29
    Чисто теоретически можно, только вновь вопрос не для программиста ))
    Клиент, которому вы будете отсылать накладную согласен принимать такие формы или нет? На быдлокодить проблемы-то нет )
  7. TopicStarter Overlay
    duncan
    Offline

    duncan

    Регистрация:
    29 июл 2013
    Сообщения:
    28
    Симпатии:
    0
    Баллы:
    1
    Клиент такую и хочет))
  8. TopicStarter Overlay
    duncan
    Offline

    duncan

    Регистрация:
    29 июл 2013
    Сообщения:
    28
    Симпатии:
    0
    Баллы:
    1
    Каким способом это осуществить?
  9. Annie
    Offline

    Annie Опытный в 1С Команда форума

    Регистрация:
    10 фев 2010
    Сообщения:
    949
    Симпатии:
    23
    Баллы:
    29
    Ну тогда нужно комментарий выцепить из РТиУ. Вам надо первые 10 символов комментария в кач-ве Основания или Основание + 10 символов комментария?
  10. TopicStarter Overlay
    duncan
    Offline

    duncan

    Регистрация:
    29 июл 2013
    Сообщения:
    28
    Симпатии:
    0
    Баллы:
    1
    первые 10 символов = Основание

    в основание сейчас ничего не идёт
  11. Annie
    Offline

    Annie Опытный в 1С Команда форума

    Регистрация:
    10 фев 2010
    Сообщения:
    949
    Симпатии:
    23
    Баллы:
    29
    Ну тогда в этом блоке что-то подобное
    Код:
     СтруктураОтбора = Новый Структура;
    Попытка
    СтруктураОтбора.Вставить("Объект",Документ.Контрагент);
    СтруктураОтбора.Вставить("Свойство",ПланыВидовХарактеристик.СвойстваОбъектов.ДатаНомерДоговораВОснованииТорг12);
    ДатаНомерИзДоговора = РегистрыСведений.ЗначенияСвойствОбъектов.Получить(СтруктураОтбора);
    Если ЗначениеЗаполнено(ДатаНомерИзДоговора.Значение) Тогда
    Если ДатаНомерИзДоговора.Значение Тогда
    НомерДоговора = Документ.ДоговорКонтрагента.Номер;
    ДатаДоговора = Документ.ДоговорКонтрагента.Дата;
    ОбластьМакета.Параметры.Основание = "Договор " +
    ?(ЗначениеЗаполнено(НомерДоговора),"№ " + НомерДоговора," ") +
    ?(ЗначениеЗаполнено(ДатаДоговора)," от " + Формат(ДатаДоговора,"ДФ=dd.MM.yy"),"");
    КонецЕсли;
    КонецЕсли;
    Исключение
    // Если флажок не обнаружен или Ложь - ничего не меняем
    //ОбластьМакета.Параметры.Основание = "";
    //Annie. Begin
    //Здесь нужно условие, т.к. это нужно только для определенного контрагента
    Если Документ.Контрагент = ТутНуженКонкретныйКонтрагент Тогда
    ОбластьМакета.Параметры.Основание = Лев(Документ.Комментарий,10);
    КонецЕсли;
    КонецПопытки;
  12. TopicStarter Overlay
    duncan
    Offline

    duncan

    Регистрация:
    29 июл 2013
    Сообщения:
    28
    Симпатии:
    0
    Баллы:
    1
    извиняюсь за назойливость )) а что сюда добавить, чтобы не первые 10, а всё до ";" например?
  13. Annie
    Offline

    Annie Опытный в 1С Команда форума

    Регистрация:
    10 фев 2010
    Сообщения:
    949
    Симпатии:
    23
    Баллы:
    29
    Код:
    ОбластьМакета.Параметры.Основание = Сред(Документ.Комментарий, 1, Найти(Документ.Комментарий, ";")-1);
  14. TopicStarter Overlay
    duncan
    Offline

    duncan

    Регистрация:
    29 июл 2013
    Сообщения:
    28
    Симпатии:
    0
    Баллы:
    1
    не хочет, ни первые 10, ни до ";" :sm_cry:
  15. Annie
    Offline

    Annie Опытный в 1С Команда форума

    Регистрация:
    10 фев 2010
    Сообщения:
    949
    Симпатии:
    23
    Баллы:
    29
    Покажите свой код. Только весь не выкладывайте ))
  16. TopicStarter Overlay
    duncan
    Offline

    duncan

    Регистрация:
    29 июл 2013
    Сообщения:
    28
    Симпатии:
    0
    Баллы:
    1
    Вот))))

    СтруктураОтбора = Новый Структура;
    Попытка
    СтруктураОтбора.Вставить("Объект",Документ.Контрагент);
    //СтруктураОтбора.Вставить("Свойство",ПланыВидовХарактеристик.СвойстваОбъектов.ДатаНомерДоговораВОснованииТорг12);
    СтруктураОтбора.Вставить("Свойство",ПланыВидовХарактеристик.СвойстваОбъектов.ДатаНомерДоговораВОснованииТорг12);
    ДатаНомерИзДоговора = РегистрыСведений.ЗначенияСвойствОбъектов.Получить(СтруктураОтбора);
    Если ЗначениеЗаполнено(ДатаНомерИзДоговора.Значение) Тогда
    Если ДатаНомерИзДоговора.Значение Тогда
    НомерДоговора = Документ.ДоговорКонтрагента.Наименование;
    ДатаДоговора = Документ.ДоговорКонтрагента.Дата;

    ОбластьМакета.Параметры.Основание = "Договор " +
    ?(ЗначениеЗаполнено(НомерДоговора),"№ " + НомерДоговора," ") +
    ?(ЗначениеЗаполнено(ДатаДоговора)," от " + Формат(ДатаДоговора,"ДФ=dd.MM.yy"),"");
    КонецЕсли;
    КонецЕсли;
    Исключение // Если флажок не обнаружен или Ложь - ничего не меняем
    //ОбластьМакета.Параметры.Основание = "";

    Если Документ.Контрагент = "РОЗДУХОВ М.Е.ИП" Тогда
    ОбластьМакета.Параметры.Основание = Сред(Документ.Комментарий, 1, Найти(Документ.Комментарий, ";")-1);
    КонецЕсли;
    КонецПопытки;
  17. Annie
    Offline

    Annie Опытный в 1С Команда форума

    Регистрация:
    10 фев 2010
    Сообщения:
    949
    Симпатии:
    23
    Баллы:
    29
    duncan, дельный совет, почитайте книжки для начинающих (без обид)
    Код:
    //Вы тут переменную с типом Ссылка сравниваете со строкой, так не катит
    //Если Документ.Контрагент = "РОЗДУХОВ М.Е.ИП" Тогда
    Если Документ.Контрагент = Справочники.Контрагенты.НайтиПоНаименованию("РОЗДУХОВ М.Е.ИП");
    ОбластьМакета.Параметры.Основание = Сред(Документ.Комментарий, 1, Найти(Документ.Комментарий, ";")-1);
    КонецЕсли;
  18. TopicStarter Overlay
    duncan
    Offline

    duncan

    Регистрация:
    29 июл 2013
    Сообщения:
    28
    Симпатии:
    0
    Баллы:
    1
    я не обидчивый)))
    всё равно не работает)))
  19. TopicStarter Overlay
    duncan
    Offline

    duncan

    Регистрация:
    29 июл 2013
    Сообщения:
    28
    Симпатии:
    0
    Баллы:
    1
    доп документы к торг12 выдаёт как для "метро".....
  20. Annie
    Offline

    Annie Опытный в 1С Команда форума

    Регистрация:
    10 фев 2010
    Сообщения:
    949
    Симпатии:
    23
    Баллы:
    29
    Пройдитесь отладчиком, в конце концов, сложно так телепатировать )
Похожие темы
  1. qazibum
    Ответов:
    3
    Просмотров:
    406
Загрузка...

Поделиться этой страницей