7.7 То ли лыжи не едут, то ли я дурак...

Тема в разделе "Общие вопросы "1С:Предприятие 7.7"", создана пользователем VIPOS, 9 июн 2013.

  1. TopicStarter Overlay
    VIPOS
    Offline

    VIPOS Опытный в 1С

    Регистрация:
    12 сен 2012
    Сообщения:
    565
    Симпатии:
    1
    Баллы:
    29
    Доброго времени всем...
    Хочу похвастаться, что сессия здана=), но мозг после нее отключен....
    не могу понять ПОЧЕМУ не срабатывает

    Код:
    Процедура ИзменениеЦенаПриобретения()
    
    Спр= СоздатьОбъект("Справочник.Номенклатура");   
    Если Спр.НайтиПоКоду(Код)= 1 тогда
    Запись=Спр.ТекущийЭлемент();
    Запись.РозничнаяЦена.Установить(ТекущаяДата(),2 ); 
    КонецЕсли;
    КонецПроцедуры
    
    видно переучился.... :90:
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Код:
    Процедура ИзменениеЦенаПриобретения(Код)
    Спр= СоздатьОбъект("Справочник.Номенклатура");  
    Если Спр.НайтиПоКоду(Код)= 1 тогда
    Спр.РозничнаяЦена.Установить(ТекущаяДата(),2 );
    Спр.Записать();//вот тут собака порылась
    Иначе
    Сообщить("Не нашли элемент с кодом "+Код); //подстраховочка
    КонецЕсли;
    КонецПроцедуры
    
    З/Ы
    поздравляем)))))))))
  3. WaRDeR
    Offline

    WaRDeR Модераторы Команда форума Модератор

    Регистрация:
    23 ноя 2006
    Сообщения:
    3.263
    Симпатии:
    14
    Баллы:
    29
    Может во втором параметре проблема? Так же стоит учесть, что код, это всегда строковый реквизит (при любых настройках). Поэтому следует учесть, что могут быть пробелы или ведущие нули.
  4. TopicStarter Overlay
    VIPOS
    Offline

    VIPOS Опытный в 1С

    Регистрация:
    12 сен 2012
    Сообщения:
    565
    Симпатии:
    1
    Баллы:
    29
    Да не извинитке уважаемые форумчане, перепил (как никак сессия сдана) и не заметил банальных вещей=)
    РозничнаяЦена- не периодический реквизит,
    а ЦенаВРозницу - периодический.
    еще раз прощу прощения=)
  5. n.s.gnedash
    Offline

    n.s.gnedash Опытный в 1С Команда форума

    Регистрация:
    15 авг 2010
    Сообщения:
    1.359
    Симпатии:
    5
    Баллы:
    29
    рано в твоем возрасте так накидываться:)))))))
  6. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    хм... тогда должна была вываливаться ошибка........
  7. TopicStarter Overlay
    VIPOS
    Offline

    VIPOS Опытный в 1С

    Регистрация:
    12 сен 2012
    Сообщения:
    565
    Симпатии:
    1
    Баллы:
    29
    Было такое=)
  8. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Тогда изначально вопрос был задан не корректно....
  9. TopicStarter Overlay
    VIPOS
    Offline

    VIPOS Опытный в 1С

    Регистрация:
    12 сен 2012
    Сообщения:
    565
    Симпатии:
    1
    Баллы:
    29
    простите=)

    я ж говорил: перепил=)

Поделиться этой страницей