7.7 ТиС запрос к регистру ПартииНаличие по документу списания

Тема в разделе "Отчеты и обработки для "1С:Предприятие 7.7"", создана пользователем Seva, 4 окт 2018.

  1. TopicStarter Overlay
    Seva
    Offline

    Seva Опытный в 1С

    Регистрация:
    5 дек 2007
    Сообщения:
    65
    Симпатии:
    0
    Баллы:
    26
    Подскажите пожалуйста как можно изменить запрос чтобы он формировался? Нужно выбрать движения регистра ПартииНаличие из документа СписаниеТМЦ Именно запросом потому что нужна группировка по поставщику и номенклатуре.
    Нигде не могу найти информацию, пробовал так но запрос пустой.
    //*******************************************
    // Процедура генерации запроса Сформировать.
    //
    Процедура Сформировать()
    Перем Запрос, ТекстЗапроса, Таб;
    //Создание объекта типа Запрос
    Запрос = СоздатьОбъект("Запрос");
    ТекстЗапроса =
    "//{{ЗАПРОС(Сформировать)
    |ОбрабатыватьДокументы все;
    |ТекущийДокумент = Регистр.ПартииНаличие.ТекущийДокумент;
    |Номенклатура = Регистр.ПартииНаличие.Номенклатура;
    |Количество = Регистр.ПартииНаличие.Количество;
    |СуммаРуб = Регистр.ПартииНаличие.СуммаРуб;
    |Поставщик = Регистр.ПартииНаличие.Партия.Поставщик;
    |Функция КоличествоРасход = Расход(Количество);
    |Функция СуммаРубНачОст = Расход(СуммаРуб);
    |Группировка Номенклатура без групп;
    |Группировка Поставщик;
    |Условие(ТекущийДокумент = ВыбСписаниеТМЦ);
    |"//}}ЗАПРОС
    ;
    // Если ошибка в запросе, то выход из процедуры
    Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
    Возврат;
    КонецЕсли;

    // Подготовка к заполнению выходных форм данными запроса
    Таб = СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("Сформировать");
    // Заполнение полей "Заголовок"
    Таб.ВывестиСекцию("Заголовок");
    Состояние("Заполнение выходной таблицы...");
    Таб.Опции(0, 0, Таб.ВысотаТаблицы(), 0);
    Пока Запрос.Группировка(1) = 1 Цикл
    // Заполнение полей Номенклатура
    Таб.ВывестиСекцию("Номенклатура");
    Пока Запрос.Группировка(2) = 1 Цикл
    // Заполнение полей Поставщик
    Таб.ВывестиСекцию("Поставщик");
    КонецЦикла;
    КонецЦикла;
    // Заполнение полей "Итого"
    Таб.ВывестиСекцию("Итого");
    // Вывод заполненной формы
    Таб.ТолькоПросмотр(1);
    Таб.Показать("Сформировать", "");
    КонецПроцедуры
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    22.508
    Симпатии:
    533
    Баллы:
    204
    Условие(ТекущийДокумент = ВыбСписаниеТМЦ);

    ВыбСписаниеТМЦ имеет какой тип? Подозреваю, что в условии у вас документ сравнивается с номенклатурой....
  3. TopicStarter Overlay
    Seva
    Offline

    Seva Опытный в 1С

    Регистрация:
    5 дек 2007
    Сообщения:
    65
    Симпатии:
    0
    Баллы:
    26
    ВыбСписаниеТМЦ это документ "СписаниеТМЦ"

    |ТекущийДокумент = Регистр.ПартииНаличие.ТекущийДокумент;
    |Условие(ТекущийДокумент = ВыбСписаниеТМЦ);

    А как поменять сравнение на документ списания?
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    22.508
    Симпатии:
    533
    Баллы:
    204
    Понял в чем причина... Для регистров выбор периода запроса - обязательное условие.
    Seva нравится это.
  5. TopicStarter Overlay
    Seva
    Offline

    Seva Опытный в 1С

    Регистрация:
    5 дек 2007
    Сообщения:
    65
    Симпатии:
    0
    Баллы:
    26
    Огромное Вам СПАСИБО!!! Все получилось! УРА!!!
  6. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    22.508
    Симпатии:
    533
    Баллы:
    204
    Не за что... Обращайтесь

Поделиться этой страницей