7.7 ТИС печать чека из Реализация

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем kisol, 12 фев 2016.

  1. TopicStarter Overlay
    kisol
    Offline

    kisol Профессионал в 1С

    Регистрация:
    25 июл 2012
    Сообщения:
    395
    Симпатии:
    41
    Баллы:
    54
    Здравствуйте.
    ТИС 7.7 хочу из Документа Реализация, пробивать чекккм на принтере чеков (енвд), отдельной кнопкой.

    Проблема в том что принтера пока нет и пробую в теории, нашел в модуле Чекккм функцию

    Код:
    //******************************************************************************
    Функция ПробитьЧекНаККМ()
        Перем НомерЧека;
       
        СписокТоваров = СоздатьОбъект("ТаблицаЗначений");
        СписокТоваров.НоваяКолонка("ТовНаим"   , "Строка");
        СписокТоваров.НоваяКолонка("Цена"      , "Число");
        СписокТоваров.НоваяКолонка("Количество", "Число");
       
        ВыбратьСтроки();
        Пока ПолучитьСтроку() = 1 Цикл
            СписокТоваров.НоваяСтрока();
            СписокТоваров.ТовНаим    = Номенклатура.Наименование;
            СписокТоваров.Цена       = Цена;
            СписокТоваров.Количество = Количество;
        КонецЦикла;
       
        ПризнВозврата = ?(ВидОперации = Перечисление.ВидыОперацийЧекККМ.Чек, 0, 1);
        ЧекПробитККМ  = глФРПечататьЧек(СписокТоваров, Итог("Сумма"), ?(Получено=0,Итог("Сумма"),Получено), Скидка.Процент, ПризнВозврата, Склад.НомерСекции, НомерЧека);
    
        Если ЧекПробитККМ = 1 Тогда
            ПриЗаписиПерепроводить(0);
            НомерЧекаККМ = НомерЧека;
            Записать();
            ПриЗаписиПерепроводить(1);
           
            // Откроем денежный ящик, если он подключен
            глДПОткрытьДенежныйЯщик();
        КонецЕсли;
       
        Возврат ЧекПробитККМ;
       
    КонецФункции // ПробитьЧекНаККМ()
    Код:
    Если Проведен()=1 Тогда
           
             // пробьем чек на ККМ
             Если Касса.РежимККМ = Перечисление.РежимыККМ.ФР Тогда
                 Если глФРВкл = 1 Тогда
                     Если ЧекПробитККМ = 0 Тогда
                         Если ПробитьЧекНаККМ() = 0 Тогда
                            
                             // по каким-то причинам Чек не пробит
                            Сообщить("Чек ККМ не пробит!");
                             Возврат;
                           
                        КонецЕсли;
                     КонецЕсли;
                 КонецЕсли;
             КонецЕсли;
    
        КонецЕсли;
    Я создаю кнопку на форме "Пробить чек", вставляю этот код и у меня пробивается чек.
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Во втором куске кода нужно еще вызвать метод Провести()
    Код выдран из модуля ЧекККМ... В чем проблема-то?
    Там все штатно работает! Пробивается чек, закрывается документ и создается новый (если вы под интефейсом продавца зашли)
  3. TopicStarter Overlay
    kisol
    Offline

    kisol Профессионал в 1С

    Регистрация:
    25 июл 2012
    Сообщения:
    395
    Симпатии:
    41
    Баллы:
    54
    -Sorry- проблемы нет, потому что еще нет принтера чеков, заранее готовлюсь -Banghead-
    Хочу немного допилить ТИС, пока готовимся к переходу на другую конфигурацию.

    данные для чека буду брать из документа Реализация, но я не хочу чтобы создавались чекккм, просто печатались по кнопке.
    Последнее редактирование: 12 фев 2016
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Зря... Зачем изобретать велосипед?
    Реализация это ОПТ. А чек как раз розничная продажа... В конце дня создается ОтчетККМ который штатно работает с кассой и закрывает кассовую смену и оприходует чеки.
    Зачем огород городить?
  5. TopicStarter Overlay
    kisol
    Offline

    kisol Профессионал в 1С

    Регистрация:
    25 июл 2012
    Сообщения:
    395
    Симпатии:
    41
    Баллы:
    54
    Мутная схема.

    По больше части оказываются услуги и продается товар через Реализацию, к акт выполненных работ и торг 12, хотят приложить чеккм от принтера чеков, просто для успокоения покупателей. В новой конфигурации все это сделано.

    Вот немного тис попинать и допилить нужно, чтобы дотянуть до перехода.
  6. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Тогда измени схему. Добавь в реквизит шапки реализации реквизит
    ЧекПробитККМ
  7. TopicStarter Overlay
    kisol
    Offline

    kisol Профессионал в 1С

    Регистрация:
    25 июл 2012
    Сообщения:
    395
    Симпатии:
    41
    Баллы:
    54
    Т. е это дело пишу и чеккм выбирается на принтере чеков?
    А открытие смены, закрытие?:
  8. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    1) Выбивается
    2) Есть обработка закрытия смены... Но она для создания ОтчетККМ. Выдерни код
    kisol нравится это.
Похожие темы
  1. Chapl
    Ответов:
    4
    Просмотров:
    1.661
  2. 2man
    Ответов:
    4
    Просмотров:
    2.101
  3. Dmitrij
    Ответов:
    1
    Просмотров:
    701
  4. Elenachka
    Ответов:
    1
    Просмотров:
    3.727
Загрузка...

Поделиться этой страницей