7.7 ТиС 7.7 как получить город Контрагента

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Lionzi, 15 дек 2009.

  1. TopicStarter Overlay
    Lionzi
    Offline

    Lionzi

    Регистрация:
    23 сен 2009
    Сообщения:
    6
    Симпатии:
    0
    Баллы:
    1
    Подскажте пожалуйста.

    Каким образом можно получить значение города из фактического адреса контрагента?
    чтой-то я запутался в структуре...

    Заранее благодарен.
  2. Хряк
    Offline

    Хряк Профессионал в 1С

    Регистрация:
    26 сен 2007
    Сообщения:
    1.447
    Симпатии:
    37
    Баллы:
    54
    смотри
    Функция глАдресСоответствуетТребованиямМНС(Адрес) Экспорт

    АдресСписком = глРазложить(Адрес);
    ...
    ИначеЕсли СтрДлина(АдресСписком.ПолучитьЗначение(5)) > 35 Тогда // наим.города не > 35 символов
    Возврат 0;
  3. TopicStarter Overlay
    Lionzi
    Offline

    Lionzi

    Регистрация:
    23 сен 2009
    Сообщения:
    6
    Симпатии:
    0
    Баллы:
    1
    Спасибо опробиоую :)

    Пока ждал ответа, эксперементировал, пока сделал циклом:

    Код:
    Функция ПолучитьГород(Адрес)	
    
    Адрес = сокрлп(Адрес);
    НомерЗапятой = 0;
    
    Для Сч = 1 По СтрДлина(Адрес) Цикл
    ТекСимвол = Сред(Адрес,Сч,1);
    Если Тексимвол = "," Тогда          
    Если НомерЗапятой < 3 Тогда
    НомерЗапятой = НомерЗапятой + 1;
    Иначе
    Адрес1 = Сред(Адрес,Сч+1);
    Прервать;
    КонецЕсли; 
    КонецЕсли;
    КонецЦикла;                 
    
    Для Ст = 1 По СтрДлина(Адрес1) Цикл
    ТекСимвол = Сред(Адрес1,Ст,1);
    Если Тексимвол = "," Тогда          
    Город = Лев(Адрес1,Ст-1);
    Если сокрлп(Город) = "" Тогда
    Адрес2 = Сред(Адрес1,Ст+1);
    сообщить(Адрес2);
    Для Ск = 1 По СтрДлина(Адрес2) Цикл
    ТекСимвол = Сред(Адрес2,Ск,1);
    Если Тексимвол = "," Тогда          
    Город = Лев(Адрес2,Ск-1);
    Прервать;
    КонецЕсли;
    КонецЦикла;	
    КонецЕсли;			
    Прервать;
    КонецЕсли;
    КонецЦикла;                      
    
    Возврат Город;
    КонецФункции
    

Поделиться этой страницей