7.7 ТипТовараПользователя=Перечисление.ТипыТоваров.Собственный; {H:\1CBASE\PROIZVOD\EXTFORMS\Z_LOADINGDO

Тема в разделе "Типовые решения "1С:Предприятие 7.7"", создана пользователем cviridova, 11 окт 2011.

  1. TopicStarter Overlay
    cviridova
    Offline

    cviridova

    Регистрация:
    11 окт 2011
    Сообщения:
    1
    Симпатии:
    0
    Баллы:
    1
    Скачала выгрузку-загрузку
    при загрузке в производстве выдает ошибку


    ТипТовараПользователя=Перечисление.ТипыТоваров.Собственный;
    {H:\1CBASE\PROIZVOD\EXTFORMS\Z_LOADINGDOCUMENT.ERT(1901)}: Поле агрегатного объекта не обнаружено (Собственный)


    В конфигураторе
    Код:
    ТипРеквизита_="";
    ВидРеквизита_="";
    Если zЕстьРеквизитСправочника("ТипТовара","Номенклатура",   ТипРеквизита_,ВидРеквизита_)=1 Тогда
    Если СокрЛП(ТипРеквизита_)="Перечисление" Тогда
    Если СокрЛП(ВидРеквизита_)="ТипыТоваров.Собственный" Тогда
    Если Вопрос("Изменять тип товара  (собственный, на комиссии и т.д.)  при загрузке номенклатуры
    |из файла   '"+СокрЛП(ФайлДляЧтения)+"'  ? ","Да+Нет")="Да" Тогда
    ТипТовараПользователя=Перечисление.ТипыТоваров;
    Если ВвестиПеречисление(ТипТовараПользователя,"Выберите новый тип товара")=0 Тогда
    ТипТовараПользователя="";
    КонецЕсли;
    КонецЕсли;
    КонецЕсли;
    КонецЕсли;
    КонецЕсли; 
    КонецЕсли;
    
    
    Подскажите пожалуйста как настпроить
  2. ЕкатеринаНик
    Offline

    ЕкатеринаНик Опытный в 1С

    Регистрация:
    8 ноя 2010
    Сообщения:
    698
    Симпатии:
    1
    Баллы:
    29
    заслэште, 5 "если - конецесли", и смотрите как исполняется!
  3. kavak
    Offline

    kavak Опытный в 1С

    Регистрация:
    13 май 2010
    Сообщения:
    703
    Симпатии:
    0
    Баллы:
    26
    И не стоит все таки в тему вставлять такое количество символов,для этого есть само сообщение.
  4. ЕкатеринаНик
    Offline

    ЕкатеринаНик Опытный в 1С

    Регистрация:
    8 ноя 2010
    Сообщения:
    698
    Симпатии:
    1
    Баллы:
    29
    а еще можно попробовать так:
    Если СокрЛП(ВидРеквизита_)="Перечисления.ТипыТоваров.Собственный" Тогда
    Код:
       Если zЕстьРеквизитСправочника("ТипТовара","Номенклатура", ТипРеквизита_,ВидРеквизита_)=1 Тогда
    Если СокрЛП(ТипРеквизита_)="Перечисление" Тогда
    Если СокрЛП(ВидРеквизита_)="[b]Перечисления[/b].ТипыТоваров.Собственный" Тогда
    Если Вопрос("Изменять тип товара (собственный, на комиссии и т.д.) при загрузке номенклатуры
    |из файла '"+СокрЛП(ФайлДляЧтения)+"' ? ","Да+Нет")="Да" Тогда
    ТипТовараПользователя=Перечисление.ТипыТоваров;
    Если ВвестиПеречисление(ТипТовараПользователя,"Выберите новый тип товара")=0 Тогда
    ТипТовараПользователя="";
    КонецЕсли;
    КонецЕсли;
    КонецЕсли;
    КонецЕсли;
    КонецЕсли; 
    
    
  5. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    В данном куске кода не может возникать ошибки.. Т.к. идет тупое сравнение строк

Поделиться этой страницей