7.7 Тип счет-фактуры

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Partos, 30 апр 2015.

  1. TopicStarter Overlay
    Partos
    Offline

    Partos

    Регистрация:
    30 апр 2015
    Сообщения:
    12
    Симпатии:
    0
    Баллы:
    1
    День добрый, прошу помочь разобрать, сам начинаю потихоньку вникать в конфигуратор и есть ряд проблем.

    Есть переменная на печать: ПечТип он выводится в таблице.

    Необходимо при выводе счета фактур у них выводилось разделение:

    1. На что основание Строка выписки банка или же по Счет-фактуре на предоплату;
    2. На основании Реализации (купля-продажа) или просто Счет-фактура;
    3. Может как то по подчиненности;

    как я вижу код и не понимаю что нужно вставить вместо вопросительных знаков.

    Если (СФ.Вид() = "СчетФактураВыданный")

    Тогда
    Если ( (?????) = “Счет-фактура на предоплату” )
    Тогда ПечТип = “Приход1”;
    КонецЕсли;

    Если ( (?????) = “Реализация (купля-продажа” )
    Тогда ПечТип = “Приход2”;
    КонецЕсли;

    КонецЕсли;
  2. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.781
    Симпатии:
    509
    Баллы:
    204
    Может купите для начала версию для обучения программирования ?
  3. Хряк
    Offline

    Хряк Профессионал в 1С

    Регистрация:
    26 сен 2007
    Сообщения:
    1.447
    Симпатии:
    37
    Баллы:
    54
    обычно этот реквизит называется ДокументОснование
    Partos нравится это.
  4. TopicStarter Overlay
    Partos
    Offline

    Partos

    Регистрация:
    30 апр 2015
    Сообщения:
    12
    Симпатии:
    0
    Баллы:
    1
    спасибо направили в нужное русло)

Поделиться этой страницей