8.х Тип не определен (ДиалогВыбораФайла) Как убрать ошибку?

Тема в разделе "Общие вопросы "1С:Предприятие 8"", создана пользователем Илья_777_7, 11 июн 2019.

  1. TopicStarter Overlay
    Илья_777_7
    Offline

    Илья_777_7

    Регистрация:
    11 июн 2019
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    1
    Код:
    Процедура ПутьНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
    Режим = РежимДиалогаВыбораФайла.Открытие;
    Диалог = Новый ДиалогВыбораФайла(Режим);
    Диалог.Фильтр = "Формат xls (*.xls;*.xlsx)|*.xls;*.xlsx|";
    Если Диалог.Выбрать() Тогда
    Путь = Диалог.ПолноеИмяФайла;
    Иначе
    Предупреждение(" Файл не выбран");
    Возврат;

    КонецЕсли;

    // Вставить содержимое обработчика.
    КонецПроцедуры




    Вылетает следующая ошибка :
    {Обработка.ЗагрузкаСметы.Форма.Форма1.Форма(3,17)}: Тип не определен (ДиалогВыбораФайла)
    Диалог = Новый <<?>>ДиалогВыбораФайла(Режим); (Проверка: Сервер)

    По всему интернету искал как её решить, точного решения не нашёл вся надежда на вас ) Помогите !!!
  2. TopicStarter Overlay
    Илья_777_7
    Offline

    Илья_777_7

    Регистрация:
    11 июн 2019
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    1
  3. nomad_irk
    Online

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    9.702
    Симпатии:
    1.012
    Баллы:
    204
    Вам русским по белому написано:

    Диалог = Новый <<?>>ДиалогВыбораФайла(Режим); (Проверка: Сервер)

    На сервере нет никаких диалогов.
  4. TopicStarter Overlay
    Илья_777_7
    Offline

    Илья_777_7

    Регистрация:
    11 июн 2019
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    1
    Я частично от этой ошибки избавился сделав-
    Сервис - параметры - Модули - в нем выбрать вкладку "Проверка" и убрать галочки с Мобильного приложения (как клиент, так и сервер)


    Но теперь у меня она вылетает в Пользовательском режиме
    Я без понятия как это исправить
    --- Объединение сообщений, 11 июн 2019 ---
    Как избавиться от этой ошибки
    {Обработка.Обработка1.Форма.Форма.Форма(76)}: Поле объекта не обнаружено (СписокПодрядчиков)
    НоваяСтрока.СписокПодрядчиков = СЗ;
    Вот код
    Процедура ПереборСтрокВЭксель()
    Эксель = Новый COMОбъект("Excel.Application");
    Эксель.Workbooks.Open(Путь);
    Эксель.Sheets(1).select();
    Для Стр = 1 по 92 Цикл
    СЗ = Новый СписокЗначений;

    НоваяСтрока = ТЗ.Добавить();
    НоваяСтрока.Дата = СокрЛП (Эксель.Cells(Стр,1).Value);
    НоваяСтрока.Заказчик = СокрЛП (Эксель.Cells(Стр,2).Value);
    НоваяСтрока.Объект = СокрЛП (Эксель.Cells(Стр,3).Value);
    НоваяСтрока.Работа = СокрЛП (Эксель.Cells(Стр,4).Value);
    НоваяСтрока.ЦенаПоСмете = СокрЛП (Эксель.Cells(Стр,5).Value);
    НоваяСтрока.Расходы = СокрЛП (Эксель.Cells(Стр,6).Value);
    НоваяСтрока.Оплата = СокрЛП (Эксель.Cells(Стр,7).Value);
    НоваяСтрока.Подрядчик = СокрЛП (Эксель.Cells(Стр,8).Value);

    ПозицияСимвола = ПоискПодстроки(СокрЛП (Эксель.Cells(Стр,8).Value));
    НоваяСтрока.СписокПодрядчиков = СЗ;

    КонецЦикла;
    Эксель.ActiveWorkbook.Close();
    Эксель.Application.Quit();


    КонецПроцедуры
    Последнее редактирование: 11 июн 2019