8.х ТекстПостроителя Отчета

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем xandruxa, 24 апр 2009.

  1. TopicStarter Overlay
    xandruxa
    Offline

    xandruxa

    Регистрация:
    25 фев 2009
    Сообщения:
    39
    Симпатии:
    0
    Баллы:
    1
    Подскажите что не так пишу. Ошибок не пишет, но и в отчете не выводит поле количество.

    Код:
    Если ОтображатьКоличество Тогда
    Если ТекстПостроителя = ТекстПостроителя + Символы.ПС + 
    " франПодпискаСрезПоследних.СрокПодписки = Год" Тогда 
    Количество = 12;
    ТекстПостроителя = ТекстПостроителя + Символы.ПС + 
    " &Количество КАК Количество,";
    КонецЕсли;	
    Если ТекстПостроителя = ТекстПостроителя + Символы.ПС + 
    " франПодпискаСрезПоследних.СрокПодписки = Полугодие" Тогда 
    Количество = 6;
    ТекстПостроителя = ТекстПостроителя + Символы.ПС + 
    " &Количество КАК Количество,";
    КонецЕсли;
    КонецЕсли;
    
  2. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    И что тут должны смотреть?
  3. TopicStarter Overlay
    xandruxa
    Offline

    xandruxa

    Регистрация:
    25 фев 2009
    Сообщения:
    39
    Симпатии:
    0
    Баллы:
    1
    поле количество не выводиться при построении отчета.
  4. ASh
    Offline

    ASh Опытный в 1С

    Регистрация:
    10 сен 2008
    Сообщения:
    568
    Симпатии:
    0
    Баллы:
    26
    Код:
    Если ТекстПостроителя = ТекстПостроителя + Символы.ПС + ...
    
    Это что? Такое условие никогда не выполнится, все равно что:
    Код:
    Если А = А+1 Тогда ...
    

Поделиться этой страницей