8.х Табличный Документ

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Panchos, 16 мар 2007.

  1. TopicStarter Overlay
    Panchos
    Offline

    Panchos Опытный в 1С

    Регистрация:
    27 окт 2006
    Сообщения:
    101
    Симпатии:
    0
    Баллы:
    26
    Написал процедуру, доходит до цикла и выдает ошибку. Скажите, что в цикле не так

    Код:
    Для Каждого Заказчик Из ЗадВыборка.Заказчик  Цикл
    
    ОбластьМак.Параметры.Заполнить(ЗадВыборка.Ссылка.ПолучитьОбъект());
    
    ТаблДок.Вывести(ОбластьМак);
    
    КонецЦикла;
    
    Ошибка:
    {Форма.Расписка(19)}: Итератор для значения не определен
    Для Каждого Заказчик Из ЗадВыборка.Заказчик Цикл
  2. TopicStarter Overlay
    Panchos
    Offline

    Panchos Опытный в 1С

    Регистрация:
    27 окт 2006
    Сообщения:
    101
    Симпатии:
    0
    Баллы:
    26
    Ещё один вопрос. Что надо писать

    Область.Параметры.<ИмяПараметра> = ?????

    Спасибо.
  3. Багира
    Offline

    Багира

    Регистрация:
    5 мар 2007
    Сообщения:
    7
    Симпатии:
    0
    Баллы:
    1
    Пока ЗадВыборка.Следующий() Цикл


    ОбластьМак.Параметры.Заполнить(ЗадВыборка);

    ТаблДок.Вывести(ОбластьМак);

    КонецЦикла;


    Область.Параметры.<ИмяПараметра> = ?????
    ???? - это то что хочешь присвоить, например

    Пока ЗадВыборка.Следующий() Цикл
    ОбластьЗаказ.Параметры.Заказчик = ЗадВыборка.Заказчик
    ...
    КонецЦикла;
  4. TopicStarter Overlay
    Panchos
    Offline

    Panchos Опытный в 1С

    Регистрация:
    27 окт 2006
    Сообщения:
    101
    Симпатии:
    0
    Баллы:
    26
    Как в таблином документе передаются параметры.
  5. 1010011010
    Offline

    1010011010 [1cworld]

    Регистрация:
    1 авг 2006
    Сообщения:
    582
    Симпатии:
    0
    Баллы:
    26
    либо -
    ОбластьМак.Параметры.Заполнить(ЗадВыборка);

    либо-

    ОбластьМак.Параметры.ИмяПараметра = "усталось ветра";
  6. Deosfen
    Offline

    Deosfen Опытный в 1С

    Регистрация:
    6 фев 2007
    Сообщения:
    67
    Симпатии:
    0
    Баллы:
    26
    если ошибка Итератор для значения не определен, то ЗадВыборка.Заказчик не объектного типа.
  7. TopicStarter Overlay
    Panchos
    Offline

    Panchos Опытный в 1С

    Регистрация:
    27 окт 2006
    Сообщения:
    101
    Симпатии:
    0
    Баллы:
    26
    Спасибо. Все работает.

Поделиться этой страницей