8.х Табличные части

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем mhl, 17 окт 2007.

Статус темы:
Закрыта.
  1. TopicStarter Overlay
    mhl
    Offline

    mhl Опытный в 1С

    Регистрация:
    23 июн 2007
    Сообщения:
    418
    Симпатии:
    0
    Баллы:
    26
    Добрый день
    Имеются два документа, в каждом есть табличная часть. Как можно данные из табличной части одного документа перебросить в табличную часть другого. При этом чтобы существующая ТЧ не замещалась на новую, а просто добавлялись новые строки.
    Заранее спасибо.
  2. bvg
    Offline

    bvg

    Регистрация:
    3 окт 2007
    Сообщения:
    36
    Симпатии:
    0
    Баллы:
    1
    А как часто надо перебрасывать или это только разовая переброска? и тебе нужен сам код как это делать?
  3. TopicStarter Overlay
    mhl
    Offline

    mhl Опытный в 1С

    Регистрация:
    23 июн 2007
    Сообщения:
    418
    Симпатии:
    0
    Баллы:
    26
    происходить это будет каждый раз при событии табличной части ПриИзменении. Хотелось бы получить код как это сделать.
  4. TopicStarter Overlay
    mhl
    Offline

    mhl Опытный в 1С

    Регистрация:
    23 июн 2007
    Сообщения:
    418
    Симпатии:
    0
    Баллы:
    26
    Как перебросить данные разобрался. А как установить курсор на конкретной строке табличной части?
  5. bvg
    Offline

    bvg

    Регистрация:
    3 окт 2007
    Сообщения:
    36
    Симпатии:
    0
    Баллы:
    1
    а по какому условию должен курсор ставится на конкретной строке? ... может просто по коду искать строку?
  6. TopicStarter Overlay
    mhl
    Offline

    mhl Опытный в 1С

    Регистрация:
    23 июн 2007
    Сообщения:
    418
    Симпатии:
    0
    Баллы:
    26
    При событии табличной части ПриИзменении будет добавляться новая строка. Как только она добавилась, курсор должен переходить на неё.
  7. bvg
    Offline

    bvg

    Регистрация:
    3 окт 2007
    Сообщения:
    36
    Симпатии:
    0
    Баллы:
    1
    Ясненько, интресный вопрос, если получится выложи код или концепцию саму, тоже хочу такое применить, но еще не дошел до этого момента
  8. TopicStarter Overlay
    mhl
    Offline

    mhl Опытный в 1С

    Регистрация:
    23 июн 2007
    Сообщения:
    418
    Симпатии:
    0
    Баллы:
    26
    Код:
    Процедура ТаблЧастьНоменклатураПриИзменении(Элемент)
    Докум = Документы.НормыПроизводства.Выбрать();
    Пока Докум.Следующий() Цикл        
    ТабРасх = Докум.РасходныеМатериалы;
    Для Каждого Стр Из ТабРасх Цикл
    НоваяСтрока = ТаблЧасть.Добавить();
    НоваяСтрока.НормаЦена = Стр.Цена;
    КонецЦикла;
    КонецЦикла;
    КонецПроцедуры
    
Статус темы:
Закрыта.

Поделиться этой страницей