7.7 Табличная часть при изменении - помогите тупому :(

Тема в разделе "Типовые решения "1С:Предприятие 7.7"", создана пользователем dmitry1-irk38, 5 дек 2012.

  1. TopicStarter Overlay
    dmitry1-irk38
    Offline

    dmitry1-irk38 Опытный в 1С

    Регистрация:
    10 окт 2012
    Сообщения:
    102
    Симпатии:
    0
    Баллы:
    26
    При изменении значение в столбце ОСАГО из документа ОСАГО должен быть извлечено и установлено значение в столбец Договор, в какую часть кода нужно это помещать (предопределенная процедура)...
    Сейчас при выборе в столбце Договор вызывается, какая-то процедура и заполняются значения. Так вот я хочу поставить значения столбце Догоовор и вызвать эту процеду! Спасибо за внимание!
    Делаю так
    Код:
    Договор=ПолисОСАГО.ДоговорСтрахования;
    
    Куды это пихать? :vis:

    Вложения:

  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    в формулу столбца ОСАГО. А договор, кстати, это не подчиненный справочник? Сталкивался тут с одной конфой по страхованию.... Тогда еще и реквизиты нужно связывать
  3. TopicStarter Overlay
    dmitry1-irk38
    Offline

    dmitry1-irk38 Опытный в 1С

    Регистрация:
    10 окт 2012
    Сообщения:
    102
    Симпатии:
    0
    Баллы:
    26
    Вот так выглядит этот документ.
    Все сделал по работе, осталось только тут подделать автоматизацию. Писал этот документ чел почти с нуля, ранее. Чем отличался жуткой бардачностью во всем :(

    А как она выглядит?
    Код:
    Процедура ПриИзмененииСтобцаОСАГО
    :)

    Вложения:

    • 1C_2.png
      1C_2.png
      Размер файла:
      283,4 КБ
      Просмотров:
      23
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    покажите не форму документа, а справочник договор
  5. TopicStarter Overlay
    dmitry1-irk38
    Offline

    dmitry1-irk38 Опытный в 1С

    Регистрация:
    10 окт 2012
    Сообщения:
    102
    Симпатии:
    0
    Баллы:
    26
    Вот форма

    Нашел в коде процедуры, первая ПриВыбореПолиса() кажется то что нужно, но она не работает, в модули нигде нет ссылок на нее.
    Вторая процедура работает. На нее есть ссылка в другой процедуре, которая нигде в коде не вызывается :(

    Код:
    Процедура ПриВыбореПолиса()
    Договор=ПолисОСАГО.ДоговорСтрахования;
    Страхователь=ПолисОСАГО.ДоговорСтрахования.Страхователь;
    
    
    Если (Число(Договор.ВидСтрахования.Код)=53) или
    (Число(Договор.ВидСтрахования.Код)=54) или
    (Число(Договор.ВидСтрахования.Код)=55) Тогда  
    Страхователь=ПолисОСАГО.ДоговорСтрахования.Выгодоприобретатель;
    КонецЕсли;
    
    
    НомерОСАГО=СокрЛП(ПолисОСАГО.Серия)+" "+ПолисОСАГО.Номер;
    валюта=рубль;
    курс=1;
    ВалСумма=ПолисОСАГО.ПремияПолис;
    Сумма=ПолисОСАГО.ПремияПолис;
    СумРазница=0;  
    Если БезКомиссии=1 Тогда //сумма в документе указана с учетом выплаченной комиссии
    Комиссия=ПолисОСАГО.Комиссия;
    КонецЕсли;
    КонецПроцедуры
    //------------------------------------------------------------------------------------  
    Процедура ПриВыбореДоговора()  
    
    Валюта=Договор.Валюта;
    Курс=Валюта.Кратность.Получить(ДатаДок);
    Курс=?(Курс=0,1,Курс);
    Курс=Валюта.Курс.Получить(ДатаДок)/Курс;
    ВалСумма=Договор.СтраховаяПремия;
    Сумма=Договор.СтраховаяПремия*Курс;  
    Если (Договор.ПризнакВалюты=0) и (Валюта<>рубль) Тогда
    КурсНачисления=Договор.КурсВалюты.Получить(ДатаДок);
    КурсНачисления=?(КурсНачисления=0,Курс,КурсНачисления);
    СумРазница=(Курс-КурсНачисления)*ВалСумма;
    Иначе
    СумРазница=0;

    Вложения:

  6. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    так трудно судить. Или выкладывайте МДшник, или вызывайте спеца на месте
  7. TopicStarter Overlay
    dmitry1-irk38
    Offline

    dmitry1-irk38 Опытный в 1С

    Регистрация:
    10 окт 2012
    Сообщения:
    102
    Симпатии:
    0
    Баллы:
    26
    Я вам выкладывал в личку из предыдущей темы :) Изменения применил без этой штуки, т.к она не работала ранее, но через месяц где-то может потребоваться.
  8. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    на конфе пароль кстати был.... Ну это разумеется не проблема. Но поскольку вы не откликнулись более чем 2 дня я конфу вашу снес....
    За не востребованностью

Поделиться этой страницей