7.7 ТаблицаЗначений

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Prosecutor, 11 май 2008.

  1. TopicStarter Overlay
    Prosecutor
    Offline

    Prosecutor

    Регистрация:
    24 апр 2008
    Сообщения:
    16
    Симпатии:
    0
    Баллы:
    1
    Здравствуйте!

    Описание ситуации:
    Есть ТаблицаЗначений - "ТЗ", количество колонок в которой - не постоянное.
    кол1, кол2, кол3, кол..., колN.

    Полуить значения из ТЗ можно следующим образом:
    Код:
    Пока ТЗ.ПолучитьСтроку() = 1  Цикл
    а = ТЗ.кол1;
    б = ТЗ.кол2;
    . . .;
    я = ТЗ.колN.
    КонецЦикла;
    
    
    
    
    Но это всё правильно, когда количество колонок - постоянное.

    Вопрос:
    Существует ли в 1С возможность составить агрегатное поле из "текста", то есть, агрегатное поле "кол1" составить из текста "кол"+"1":
    Код:
    Пока ТЗ.ПолучитьСтроку() = 1  Цикл
    Для а = 1 По ТЗ.Колонок() Цикл
    х = "кол"+Строка(а);
    ТЗ.х;
    КонецЦикла:
    КонецЦикла;
    
    
    
    
    PS
    Второй пример конечно не работает, но очень хотелось бы... :unsure:
  2. MaxxaM
    Offline

    MaxxaM Опытный в 1С

    Регистрация:
    16 окт 2007
    Сообщения:
    288
    Симпатии:
    2
    Баллы:
    29
    Дык, ты уже почти сам себе ответил только пару нюансов:

    ТЗ.Кол+х конечено не сработает, но можно ж:

    Код:
    для  ии=1 по Тз.КоличествоСтолбцов() Цикл
    нстолб="Кол"+строка(ии);
    а=Тз.ПолучитьЗначение(нстр,нстолб)
    Конеццикла
    
    
    :unsure:

Поделиться этой страницей