7.7 таблица значений

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем skmetall, 29 ноя 2006.

  1. TopicStarter Overlay
    skmetall
    Offline

    skmetall

    Регистрация:
    29 ноя 2006
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    ТЗ.ВыбратьСтроки();
    Пока ТЗ.ПолучитьСтроку() = 1 Цикл
    Сообщить(наименование);
    КонецЦикла;

    сообщает несколько раз (столько, сколько строк) значение последней строки,
    а надо вывести все наименования из таблице значений
  2. TopicStarter Overlay
    skmetall
    Offline

    skmetall

    Регистрация:
    29 ноя 2006
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    Sorry
    разобрался.



    ТЗ.ВыбратьСтроки();
    Пока ТЗ.ПолучитьСтроку() = 1 Цикл
    Сообщить(ТЗ.наименование);
    КонецЦикла;
  3. alexnoviy
    Offline

    alexnoviy

    Регистрация:
    3 окт 2006
    Сообщения:
    18
    Симпатии:
    0
    Баллы:
    1
    Попробуй так:
    ТЗ.ВыбратьСтроки();
    Пока ТЗ.ПолучитьСтроку() = 1 Цикл
    Сообщить(ТЗ.ПолучитьЗначение(НомерСтроки, "наименование");
    КонецЦикла;
    где "наименование" - это название столбца таблицы

Поделиться этой страницей