7.7 Таблица значений: Значение не представляет агрегатный объект

Тема в разделе "Отчеты и обработки для "1С:Предприятие 7.7"", создана пользователем Glodiator007, 14 апр 2017.

  1. TopicStarter Overlay
    Glodiator007
    Offline

    Glodiator007

    Регистрация:
    14 апр 2017
    Сообщения:
    6
    Симпатии:
    0
    Баллы:
    1
    Сижу не могу разобраться.
    Ошибка записи данных файла :
    Нс.Объект = ЖР.Объект;
    Значение не представляет агрегатный объект (Объект)

    Код:
    Процедура ПриОткрытии()
       
        //Убрать!!  
       
        КонДата = Дата(2016,12,31);   
        Конецпроцедуры             
    Процедура Сформировать()
       
        // начальная проверка
       
        Если ПустоеЗначение(КонДата)=1 Тогда
            Предупреждение("Не выбрана кон. дата"); 
            возврат;            
        КонецЕсли;
       
        //---
       
        // блок подготовки конструкций
       
        ТекГод_КонДата = КонМесяца(КонДата); //пример 31.12.2016 
       
       
       
        ТекГод_КонДата_МинусТриМесяца_НачМесяца = ДобавитьМесяц(НачМесяца(ТекГод_КонДата),-2); //01.10.2016         
        ТекГод_НачалоГода =  НачГода(КонДата); //01.01.2016         
       
        ПрошлыйГод_НачалоГода=ДобавитьМесяц( ТекГод_НачалоГода, -12); //01.01.2015 
       
        ПозапрошлыйГод_НачалоГода=ДобавитьМесяц(ПрошлыйГод_НачалоГода,-12);    // 01.01.2014
       
        ТЗ = СоздатьОбъект("ТаблицаЗначений");
        ТЗ.НоваяКолонка("Объект","Справочник.Объекты");
        ТЗ.НоваяКолонка("ТекЗадолж","Число",15,3);
        ТЗ.НоваяКолонка("Начисление_Посл_3месяца","Число",15,3);
        ТЗ.НоваяКолонка("Начисление_ТекГод","Число",15,3);
        ТЗ.НоваяКолонка("Начисление_ПрошлыйГод","Число",15,3);
        ТЗ.НоваяКолонка("Начисление_ПозапрошлыйГод","Число",15,3);
        ТЗ.НоваяКолонка("Оплата_Посл_3месяца","Число",15,3);
       
       
       
        // получение данных
        ЖР=СоздатьОбъект("ЖурналРасчетов.Платежи");
        ЖР.ВыбратьЗаписи(ПозапрошлыйГод_НачалоГода,КонДата);   
        Сумма=0;
        КоличествоЗаписей=0;   
        Сообщить ("Цикл начат в:"+ТекущееВремя());   
        Пока ЖР.ПолучитьЗапись()=1 Цикл      
           
            Если КоличествоЗаписей>=1000 тогда
                прервать;   
            конецЕсли;
                                
            Если ЖР.ВидРасч.ВходитВГруппу(ГруппаРасчетов.ВсеНачисления)=1 Тогда      
                нс = ТЗ.НоваяСтрока();
                нс.Объект = ЖР.Объект;
                нс.Начисление_Посл_3месяца = ЖР.Результат;
                нс.ТекЗадолж = ЖР.Результат;
                нс.Начисление_ТекГод = ЖР.Результат;
                нс.Начисление_ПрошлыйГод = ЖР.Результат;
                нс.Начисление_ПозапрошлыйГод = ЖР.Результат;
                нс.Оплата_Посл_3месяца = ЖР.Результат;
               
                                                               
               
               
            ИначеЕсли ЖР.ВидРасч.ВходитВГруппу(ГруппаРасчетов.ВсеОплаты)=1 Тогда
       
        КонецЕсли;           
           
           
           
            КоличествоЗаписей=КоличествоЗаписей+1;
            //Сумма=Сумма+ЖР.Результат;
        КонецЦикла;
        Сообщить ("Цикл закончен в:"+ТекущееВремя());
        Сообщить ("КоличествоЗаписей"+КоличествоЗаписей);
        Сообщить ("Итоговая сумма"+Сумма);
    
          
    КонецПроцедуры
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    22.482
    Симпатии:
    526
    Баллы:
    204
    в 7.7
    нс = ТЗ.НоваяСтрока();
    так не работает.

    ТЗ.НоваяСтрока();
    ТЗ.Объект = ЖР.Объект;
    ....
    Glodiator007 нравится это.
  3. TopicStarter Overlay
    Glodiator007
    Offline

    Glodiator007

    Регистрация:
    14 апр 2017
    Сообщения:
    6
    Симпатии:
    0
    Баллы:
    1
    Спасибо все работает
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    22.482
    Симпатии:
    526
    Баллы:
    204
Похожие темы
  1. Mister Palevo
    Ответов:
    6
    Просмотров:
    5.938
  2. tmpnikl
    Ответов:
    7
    Просмотров:
    2.266
  3. MyNameNoName
    Ответов:
    9
    Просмотров:
    11.703
  4. Аслан95
    Ответов:
    1
    Просмотров:
    1.170
  5. Александр2501
    Ответов:
    6
    Просмотров:
    883
Загрузка...

Поделиться этой страницей