7.7 Таблица значений: Значение не представляет агрегатный объект

Тема в разделе "Отчеты и обработки для "1С:Предприятие 7.7"", создана пользователем MyNameNoName, 6 мар 2014.

  1. TopicStarter Overlay
    MyNameNoName
    Offline

    MyNameNoName Опытный в 1С

    Регистрация:
    17 май 2013
    Сообщения:
    931
    Симпатии:
    0
    Баллы:
    26
    Сижу не могу разобраться.
    Ошибка записи данных файла :
    Значение не представляет агрегатный объект (Код)
    Код:
    ТЗНоменклатура=СоздатьОбъект("ТаблицаЗначений");
         ТЗНоменклатура.НоваяКолонка("Код"); 
         Объект = СоздатьОбъект("Документ.ПоступлениеТМЦ");
         Объект.ВыбратьДокументы();    
         НомерСтроки = 1;
         Пока Объект.ПолучитьДокумент() = 1 Цикл
           Если Объект.Проведен()=1 Тогда
             Объект.ВыбратьСтроки();
             Пока Объект.ПолучитьСтроку()=1 Цикл
               Стр=ТЗНоменклатура.НоваяСтрока();
               Стр.Код=Объект.Номенклатура.Код;
             КонецЦикла;  
           КонецЕсли;   
         КонецЦикла;
    
    В чем проблема? Еще раз спасибо.
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Если ПустоеЗначение(Объект.Номенклатура)=0 Тогда
    ТЗНоменклатура.НоваяСтрока();
    ТЗНоменклатура.Код=Объект.Номенклатура.Код;
    КонецЕслИ;
    MyNameNoName нравится это.
  3. TopicStarter Overlay
    MyNameNoName
    Offline

    MyNameNoName Опытный в 1С

    Регистрация:
    17 май 2013
    Сообщения:
    931
    Симпатии:
    0
    Баллы:
    26
    Та же ошибка:
    Ошибка записи данных файла :
    Значение не представляет агрегатный объект (Наименование)
    Код:
    ТЗНоменклатура=СоздатьОбъект("ТаблицаЗначений");
         ТЗНоменклатура.НоваяКолонка("Наименование");
         Объект = СоздатьОбъект("Документ.ПоступлениеТМЦ");
         Объект.ВыбратьДокументы();
         Пока Объект.ПолучитьДокумент() = 1 Цикл
           Если Объект.Проведен()=1 Тогда
             Объект.ВыбратьСтроки();
             Пока Объект.ПолучитьСтроку()=1 Цикл  
               Если ПустоеЗначение(Объект.Номенклатура)=0 Тогда
                 Стр=ТЗНоменклатура.НоваяСтрока();
                 Стр.Наименование=Объект.Номенклатура.Наименование;
             КонецЕсли;
             КонецЦикла;  
           КонецЕсли;   
         КонецЦикла;
    
    В чем то видимо другом ошибка.
  4. TopicStarter Overlay
    MyNameNoName
    Offline

    MyNameNoName Опытный в 1С

    Регистрация:
    17 май 2013
    Сообщения:
    931
    Симпатии:
    0
    Баллы:
    26
    Видимо ошибка вот тут:
    Код:
    ТЗНоменклатура.НоваяКолонка("Наименование");
    
    Хотя в справке написано можно не указывать тип.
  5. TopicStarter Overlay
    MyNameNoName
    Offline

    MyNameNoName Опытный в 1С

    Регистрация:
    17 май 2013
    Сообщения:
    931
    Симпатии:
    0
    Баллы:
    26
    Не в этом...
    Буду разбираться но очень не понятно, ведь если по этому коду напрямую в excel вывожу все работает.
  6. TopicStarter Overlay
    MyNameNoName
    Offline

    MyNameNoName Опытный в 1С

    Регистрация:
    17 май 2013
    Сообщения:
    931
    Симпатии:
    0
    Баллы:
    26
    Даже этот код не работает:
    Код:
       ТЗНоменклатура=СоздатьОбъект("ТаблицаЗначений");
         ТЗНоменклатура.НоваяКолонка("Наименование","Число",10,0);     
         Для Сч=1 По 25 Цикл
           Стр=ТЗНоменклатура.НоваяСтрока();
           Стр.Наименование=Сч;
         КонецЦикла;
    
    Что тут не так???
  7. Хряк
    Offline

    Хряк Профессионал в 1С

    Регистрация:
    26 сен 2007
    Сообщения:
    1.447
    Симпатии:
    37
    Баллы:
    54
    мммда, студент
    тз.новаяСтрока()
    тз.наименование=сч;

    блин, открой любую типовую, просто почитай код
    MyNameNoName нравится это.
  8. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    вы пропустили пост №2?????
    Для Сч=1 По 25 Цикл
    ТЗНоменклатура.НоваяСтрока();
    ТЗНоменклатура.Наименование=Сч;
    КонецЦикла;
    MyNameNoName нравится это.
  9. TopicStarter Overlay
    MyNameNoName
    Offline

    MyNameNoName Опытный в 1С

    Регистрация:
    17 май 2013
    Сообщения:
    931
    Симпатии:
    0
    Баллы:
    26
    Спасибо, что-то я... Не заметил очевидное. Спасибо.
  10. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Не за что... Обращайтесь.
    MyNameNoName нравится это.

Поделиться этой страницей