7.7 Таблица Значений не отображает данные

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем M a x i m, 27 янв 2009.

  1. TopicStarter Overlay
    M a x i m
    Offline

    M a x i m Опытный в 1С

    Регистрация:
    6 окт 2008
    Сообщения:
    212
    Симпатии:
    0
    Баллы:
    26
    Добрый день
    Делаю отбор по докам и заношу в Таблицу Значений так:
    Код:
    Процедура Сформировать()           
    //СОЗДАДИМ ВИРТУАЛЬНУЮ ТАБЛИЦУ ЗНАЧЕНИЙ
    ТЗ=СоздатьОбъект("ТаблицаЗначений");
    ТЗ.НоваяКолонка("Наименование"); //Формируем структуру ТЗ
    ТЗ.НоваяКолонка("ЕдИзм");
    ТЗ.НоваяКолонка("НачОст");
    ТЗ.НоваяКолонка("Выпуск");
    ТЗ.НоваяКолонка("Возврат");
    ТЗ.НоваяКолонка("ВсегоПриход");  
    ТЗ.НоваяКолонка("Сухарь");
    ТЗ.НоваяКолонка("Мочка");
    ТЗ.НоваяКолонка("Раздача");
    ТЗ.НоваяКолонка("ВсегоРасход");
    ТЗ.НоваяКолонка("Остаток");
    ТЗ.НоваяКолонка("ПередачаСмены");
    
    //НАЧИНАЕМ ПЕРЕБОР ЦИКЛОМ ДОКУМЕНТОВ  
    Док=СоздатьОбъект("Документ.ВыпускПродукцииПоНормам");
    Док.ВыбратьДокументы(НачДата,КонДата); 
    Пока Док.ПолучитьДокумент()=1 Цикл 
    Док.ВыбратьСтроки();
    Пока Док.ПолучитьСтроку()=1 Цикл
    ТЗ.НоваяСтрока();
    ТЗ.Наименование=Док.Продукция;
    ТЗ.ЕдИзм=Док.ЕдиницаИзмерения;
    ТЗ.НачОст=0;
    ТЗ.Выпуск=Док.Количество;
    ТЗ.Возврат=0;
    ТЗ.ВсегоПриход=0;
    КонецЦикла;                    
    КонецЦикла;
    
    ТЗ.ВыбратьСтроку();
    ТЗ.ВыбратьСтроки();
    
    КонецПроцедуры
    
    
    
    
    На прошедшей неделе нас так учили на курсах по базовым объектам. На курсах это работало, а на работе нет. Период ставлю один день. Всплывают следующие баги:
    - Выводит только записи первого документа
    - И выводит только предопределнные нули, но пусто в ячейках Наименования, ЕдИзм, Выпуск
    В документе проверял реквизиты табличной части - все сходится. При формировании ни о каких ошибках не сообщается.
    Помогите, пожалуйста.

    ! ! ! УЖЕ ИСПРАВИЛ ! ! !

Поделиться этой страницей