8.х Свойства объекта номенклатуры

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем atm779, 19 янв 2010.

  1. TopicStarter Overlay
    atm779
    Offline

    atm779 Опытный в 1С

    Регистрация:
    19 авг 2009
    Сообщения:
    133
    Симпатии:
    0
    Баллы:
    26
    Как програмно получить список свойств обеъкта номенклатуры ?

    Код:
    	Для Каждого ст Из Товары Цикл 
    товар = ст.Номенклатура;	
    //тут хочется написать чтото вроде 
    //свойства = товар.ПолучитьСписокСовйств();
    
    КонецЦикла;
    
    Перерыл доступную инфу, но не нашел похожих методов. Подскажите, как можно реализовать это ?
  2. Itsys
    Offline

    Itsys Опытный в 1С

    Регистрация:
    3 янв 2010
    Сообщения:
    1.394
    Симпатии:
    0
    Баллы:
    26
    Через Метаданные
  3. nomad_irk
    Offline

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.581
    Симпатии:
    717
    Баллы:
    204
    все гораздо проще

    Код:
    Для Каждого ст Из Товары Цикл         
    товар = ст.Номенклатура;
    Свойства = Справочники.ЗначениеСвойствОбъекта(,Товар);
    Характеристики = Справочники.ХарактеристикиНоменклатуры.Выбрать(,Товар);
    КонецЦикла;
    
    
  4. TopicStarter Overlay
    atm779
    Offline

    atm779 Опытный в 1С

    Регистрация:
    19 авг 2009
    Сообщения:
    133
    Симпатии:
    0
    Баллы:
    26
    Как именно через метаданные ? не могли бы написать пример ?


    получаю ошибку
    Код:
    {Форма.Форма(15)}: Метод объекта не обнаружен (ЗначениеСвойствОбъекта)
    
    
  5. TopicStarter Overlay
    atm779
    Offline

    atm779 Опытный в 1С

    Регистрация:
    19 авг 2009
    Сообщения:
    133
    Симпатии:
    0
    Баллы:
    26
    Каким образом впиницие привязывается свойство к объекту? Как к свойству привязвается его значение ? Как можно выдернуть из базы свойство и знаечене объекта ?
  6. ASh
    Offline

    ASh Опытный в 1С

    Регистрация:
    10 сен 2008
    Сообщения:
    568
    Симпатии:
    0
    Баллы:
    26
    Конфигурацию свою укажите. Посмотрите регистр сведений "ЗначенияСвойствОбъектов"
  7. TopicStarter Overlay
    atm779
    Offline

    atm779 Опытный в 1С

    Регистрация:
    19 авг 2009
    Сообщения:
    133
    Симпатии:
    0
    Баллы:
    26
    "Управление торговлей", редакция 10.3 (10.3.8.9)
  8. ASh
    Offline

    ASh Опытный в 1С

    Регистрация:
    10 сен 2008
    Сообщения:
    568
    Симпатии:
    0
    Баллы:
    26
    Код:
    Номенклатура = Справочники.Номенклатура;
    ВыборкаНоменклатуры = Номенклатура.Выбрать();
    Пока ВыборкаНоменклатуры.Следующий() Цикл
    Свойства = РегистрыСведений.ЗначенияСвойствОбъектов;
    Отбор = Новый Структура("Объект", ВыборкаНоменклатуры.Ссылка);
    ВыборкаСвойств = Свойства.Выбрать(Отбор);
    Пока ВыборкаСвойств.Следующий() Цикл
    Сообщить(ВыборкаСвойств.Объект.Наименование+" "+ВыборкаСвойств.Свойство.Наименование+" "+ВыборкаСвойств.Значение.Наименование);
    КонецЦикла;
    КонецЦикла;
    
    

Поделиться этой страницей