7.7 Свойства формы

Тема в разделе "Отчеты и обработки для "1С:Предприятие 7.7"", создана пользователем ANDRE, 24 ноя 2009.

  1. TopicStarter Overlay
    ANDRE
    Offline

    ANDRE Опытный в 1С

    Регистрация:
    12 мар 2008
    Сообщения:
    456
    Симпатии:
    0
    Баллы:
    26
    Добрый день!

    Диалог "Форма" служит для настройки совместной работы диалога и табличного документа формы отчета или обработки.

    Я вызвал диалог этот (пункт "Свойства формы" из меню "Действия" главного меню Конфигуратора), установил параметр группы "Использовать таблицу": Пустую (В форму отчета или обработки будет включен табличный документ, а его формирование будет выполняться средствами встроенного языка системы)

    Как обратиться и заполнить этот табличный документ?

    ЗЫ: При формировании отчета в объект "таблица" все данные выводиться в отдельное окно, а во включенный в обработку табличный документ - нет.
    Вот код
    Код:
    Док = СоздатьОбъект("Документ.Задача");
    Док.ВыбратьДокументы(НачДата, КонДата);
    Таб = СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("Таблица");
    
    Пока Док.ПолучитьДокумент() = 1 Цикл
    Если СокрЛП(вУчастник1) <> "" Тогда
    Если Док.ФИО1 <> вУчастник1  Тогда
    Продолжить;
    КонецЕсли;
    КонецЕсли;
    Докум = Док.ТекущийДокумент();
    
    Таб.ВывестиСекцию("Секция_1");
    КонецЦикла;
    
    Таб.Показать();
    
  2. WaRDeR
    Offline

    WaRDeR Модераторы Команда форума Модератор

    Регистрация:
    23 ноя 2006
    Сообщения:
    3.263
    Симпатии:
    14
    Баллы:
    29
    В вашей форме уже будет реквизит Таблица.
    Больше ничего создавать не надо:
    Код:
    Док = СоздатьОбъект("Документ.Задача");
    Док.ВыбратьДокументы(НачДата, КонДата);
    Пока Док.ПолучитьДокумент() = 1 Цикл
    Если СокрЛП(вУчастник1) <> "" Тогда
    Если Док.ФИО1 <> вУчастник1  Тогда
    Продолжить;
    КонецЕсли;
    КонецЕсли;
    Докум = Док.ТекущийДокумент();
    
    Таблица.ВывестиСекцию("Секция_1");
    КонецЦикла;
    

Поделиться этой страницей