7.7 Свои процедуры

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем destroyed brain, 7 апр 2008.

  1. TopicStarter Overlay
    destroyed brain
    Offline

    destroyed brain

    Регистрация:
    7 апр 2008
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    1
    2 дня назад решил потехоньку осваивать 1С программирование и практически сразу столкнулся с такой проблемой: как я понял в 1С есть 2 типа процедур: предопределенные или простым языком говоря - события и пользовательские. и если с предопределенными все более менее ясно, то с пользовательскими совсем ничего не ясно B)
    вопрос 1: как создать свою процедуру, в модуле документ предположим?как я понял она ограничеваеться ключевыми словами Процедура...КонецПроцедуры. правильно ли я все понял и не надоли где еще ее обьявлять?
    вопрос 2: возможно ли вызвать процедуру из процедуры? поскольку я знаком с языком VB и поскольку синтаксис 1С оч похож на синтаксис VB я было предположил что в 1С процедуры вызываються так же по имени. Но ошибка "Процедура не обнаружена" меня в этом разубедила :unsure: так как же мне всетаки вызвать свою процедуру из любой другой
  2. ZEMA
    Offline

    ZEMA Опытный в 1С

    Регистрация:
    5 окт 2007
    Сообщения:
    231
    Симпатии:
    0
    Баллы:
    26
    ДА процедура объявляется Процедура...КонецПроцедуры.Если это твоя процедура. например установитьфильтр,то ты эту процедуру описываешь в модуле док.,а потом вызываешь ,например, в элементе диалога(это может быть таблицазначений,флажок и т.д.).В этом элементе в закладке дополнительно ->в формуле вписываешь название своей процедуры. и при использовании элемента диалога,если ты посмотришь через отладчит,произойдет обращение к твоей процедурке.
  3. Savant
    Offline

    Savant Опытный в 1С

    Регистрация:
    19 ноя 2007
    Сообщения:
    252
    Симпатии:
    4
    Баллы:
    29
    Прежде чем обращаться к процедуре - её необходимо предварительно описать. Также можно не описывать процедуры, но в таком случае они должны быть реализованы ранее, чем места, в которых они вызываются.
  4. TopicStarter Overlay
    destroyed brain
    Offline

    destroyed brain

    Регистрация:
    7 апр 2008
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    1
    а про вызов процедуры из процедуры?(и примерчик желательно)
  5. Хряк
    Online

    Хряк Профессионал в 1С

    Регистрация:
    26 сен 2007
    Сообщения:
    1.447
    Симпатии:
    37
    Баллы:
    54
    Открой любую конфу, там этих процедур как грязи
  6. Prospero
    Offline

    Prospero Опытный в 1С

    Регистрация:
    13 сен 2006
    Сообщения:
    111
    Симпатии:
    0
    Баллы:
    26
    Вроде так:
    Код:
    Процедура ТвояПроцедура()
    ... // тут пишешь чо процедура делать будет...
    КонецПроцедуры
    
    Процедура ПриОткрытии()
    ТвояПроцедура();
    КонецПроцедуры
    
    
    Если вызываешь ДО своей процедуры, сначала объяви ее:
    Код:
    Процедура ТвояПроцедура() Далее // обрати внимание на слово ДАЛЕЕ - оно обязательно
    
    Процедура ПриОткрытии()
    ТвояПроцедура();
    КонецПроцедуры
    
    Процедура ТвояПроцедура()
    ... // тут пишешь чо процедура делать будет...
    КонецПроцедуры
    
    
    И правильно Хряк написал - в любой конфе можно посмотреть примеры... Там даже ФУНКЦИИ есть :)
  7. TopicStarter Overlay
    destroyed brain
    Offline

    destroyed brain

    Регистрация:
    7 апр 2008
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    1

Поделиться этой страницей