8.х Связанные документы

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем igorekkrav, 20 май 2011.

  1. TopicStarter Overlay
    igorekkrav
    Offline

    igorekkrav Опытный в 1С

    Регистрация:
    29 апр 2010
    Сообщения:
    223
    Симпатии:
    0
    Баллы:
    26
    Добрый день всем!!! Делаю отчет (структура подчиненности- заказы поставщику). Цель нужно видеть стрктуру по всем документам заказы поставщику , а именно поступление товаров и услуг и расходник.
    Вроде все данные получилось получить этим запросом


    Код:
    	
    ДатаНач = НачПериода;
    ДатаКон = КонецДня(КонПериода);
    
    
    
    Запрос = Новый Запрос;
    
    Запрос.УстановитьПараметр("ДатаНач", ДатаНач);
    Запрос.УстановитьПараметр("ДатаКон", ДатаКон);
    Запрос.Текст=
    "ВЫБРАТЬ
    |	ЗаказПоставщику.Ссылка,
    |	ЗаказПоставщику.Дата,
    |	ЗаказПоставщику.Контрагент
    |ИЗ
    |	Документ.ЗаказПоставщику КАК ЗаказПоставщику
    |ГДЕ
    |	ЗаказПоставщику.Дата МЕЖДУ &ДатаНач И &ДатаКон
    |
    |СГРУППИРОВАТЬ ПО
    |	ЗаказПоставщику.Ссылка,
    |	ЗаказПоставщику.Дата,
    |	ЗаказПоставщику.Контрагент";
    ЗапросОпись = Запрос.Выполнить();
    ВыборкаСтрок = ЗапросОпись.Выбрать();
    Пока ВыборкаСтрок.Следующий() Цикл
    РКО = ВыборкаСтрок.Ссылка;	
    КритерийОтбора = "СвязанныеДокументы";
    Список = ПолныеПрава.ПолучитьСписокДокументовПоКритериюОтбора(КритерийОтбора, РКО);
    ТабДок = ЭлементыФормы.ПолеТабличногоДокументаРезультат;
    //ТабДок.Очистить();
    Макет = ПолучитьМакет("Макет");
    ОбластьШапка = Макет.ПолучитьОбласть("Шапка");
    ОбластьСтрока = Макет.ПолучитьОбласть("Строка");
    Для Каждого Строка из Список  Цикл
    ОбластьСтрока.Параметры.РКО = РКО;
    ОбластьСтрока.Параметры.ПТ = Строка.Ссылка;
    ТабДок.Вывести(ОбластьСтрока);
    КонецЦикла;	
    КонецЦикла;
    ТабДок.ТолькоПросмотр = Истина;
    ТабДок.Показать();
    
    КонецПроцедуры 
    
    Выводит следующим образом (screenshot1) . А хочу сделать (screenshot2). Не пойму как мне разделить Строка.Ссылка( отдельно расходник , отдельно поступление вынуть )И как написать условия что-бы он мне не выводил по 10 раз один и тот же документ

    Вложения:

    • screenshot1.jpg
      screenshot1.jpg
      Размер файла:
      589,6 КБ
      Просмотров:
      216
    • screenshot2.jpg
      screenshot2.jpg
      Размер файла:
      74,4 КБ
      Просмотров:
      193
  2. Lugano
    Offline

    Lugano

    Регистрация:
    4 мар 2011
    Сообщения:
    27
    Симпатии:
    0
    Баллы:
    1
    Используй итоги
  3. Lugano
    Offline

    Lugano

    Регистрация:
    4 мар 2011
    Сообщения:
    27
    Симпатии:
    0
    Баллы:
    1
    Дочитал до конца... Понял что бред написал))) :angry:

Поделиться этой страницей