7.7 Связь "Отгрузка"-"Счет фактура"

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Hartge, 2 июн 2009.

  1. TopicStarter Overlay
    Hartge
    Offline

    Hartge

    Регистрация:
    25 окт 2008
    Сообщения:
    22
    Симпатии:
    0
    Баллы:
    1
    В базу вносятся документы "Отгрузка товаров", на их основании формируютсч счета фактуры выданные. В проведенные документы "Отгрузка товаров" вносятся изменения, а счета фактуры не меняются. Можно ли сделать так так, чтобы они автоматически менялись или необходимо дописывать конфу? Если да, то какие процедуры использовать для поиска подчиненных счетов фактур?
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Автоматически менять не получится (если у них заполнена табличная часть)
    Для поиска подчиненных документов используй функцию
    Код:
    Процедура ПолучитьСФ()            
    Если Выбран()=0 Тогда //документ даже не записан еще...
    Возврат "";
    КонецЕсли;
    Док=СоздатьОбъект("Документ");
    Док.ВыбратьПодчиненныеДокументы(,,ТекущийДокумент());
    Пока Док.ПолучитьДокумент()=1 Цикл
    Если Док.Вид()="СчетФактура" Тогда
    Возврат Док.ТекущийДокумент();
    КонецЕсли;
    КонецЦикла;
    Возврат "";
    КонецПроцедуры
    
    
    
  3. TopicStarter Overlay
    Hartge
    Offline

    Hartge

    Регистрация:
    25 окт 2008
    Сообщения:
    22
    Симпатии:
    0
    Баллы:
    1
    А почему не получится? Если при сохранении Документа"Отгрузка" делать проверку на наличае подчиненного счета-фактуры, перезаполнять его ТЧ в соответствии с ТЧ документа"Отгрузка" и перепроводить.
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Молодец... 5! Догадался. Я имел ввиду что стандартного механизма автообновления нет. Но его можно создать)))))))

Поделиться этой страницей