8.х СведенияОВнешнейОбработке

Тема в разделе "Отчеты и обработки для "1С:Предприятие 8"", создана пользователем OXED, 15 май 2014.

  1. TopicStarter Overlay
    OXED
    Offline

    OXED Опытный в 1С

    Регистрация:
    10 апр 2012
    Сообщения:
    256
    Симпатии:
    0
    Баллы:
    26
    Добрый день. При попытке записать внешнюю обработку в дополнительные отчеты и обработки выдает ошибку. Гугл пишет,что необходимо в модуле объекта обработки создать функцию "СведенияОВнешнейОбработке" экспортную. Поиском по форуму нашел пример:
    Код:
    Функция СведенияОВнешнейОбработке() Экспорт
    
        ПараметрыРегистрации = Новый Структура;
        ПараметрыРегистрации.Вставить("Вид", "ДополнительнаяОбработка");
        ПараметрыРегистрации.Вставить("Наименование", НСтр("ru = 'Путеводитель по демонстрационной базе'"));
        ПараметрыРегистрации.Вставить("Версия", "1.0");
        ПараметрыРегистрации.Вставить("БезопасныйРежим", Истина);
        ПараметрыРегистрации.Вставить("Информация", НСтр("ru = 'Путеводитель содержит описание хозяйственных операций, отраженных в демонстрационной базе, и является удобным средством навигации по документам, регистрирующим эти хозяйственные операции.'"));
    //    ПараметрыРегистрации.Вставить("ВерсияБСП", "1.2.1.4");
    
        ТаблицаКоманд = ПолучитьТаблицуКоманд();
    
        ДобавитьКоманду(ТаблицаКоманд,
            НСтр("ru = 'Путеводитель по демо-базе'"),
            "ПутиводительПоДемоБазе",
            "ОткрытиеФормы",
            Истина,
            "");
      
        ПараметрыРегистрации.Вставить("Команды", ТаблицаКоманд);
    
        Возврат ПараметрыРегистрации;
    
    КонецФункции // СведенияОВнешнейОбработке()
    
    Функция ПолучитьТаблицуКоманд()
      Команды = Новый ТаблицаЗначений;
      Команды.Колонки.Добавить("Представление", Новый ОписаниеТипов("Строка"));
      Команды.Колонки.Добавить("Идентификатор", Новый ОписаниеТипов("Строка"));
      Команды.Колонки.Добавить("Использование", Новый ОписаниеТипов("Строка"));
      Команды.Колонки.Добавить("ПоказыватьОповещение", Новый ОписаниеТипов("Булево"));
      Команды.Колонки.Добавить("Модификатор", Новый ОписаниеТипов("Строка"));
      Возврат Команды;
    КонецФункции
    
    Процедура ДобавитьКоманду(ТаблицаКоманд, Представление, Идентификатор, Использование, ПоказыватьОповещение = Ложь, Модификатор = "")
      НоваяКоманда = ТаблицаКоманд.Добавить();
      НоваяКоманда.Представление = Представление;
      НоваяКоманда.Идентификатор = Идентификатор;
      НоваяКоманда.Использование = Использование;
      НоваяКоманда.ПоказыватьОповещение = ПоказыватьОповещение;
      НоваяКоманда.Модификатор = Модификатор;
    КонецПроцедуры
    Но нигде не пишется и не объясняется что конкретно писать в случае с внешним отчетом,в случае с обработкой и т.д. Может есть у кого нибудь мануал или пояснения какие нибудь? Мне нужно понять самому откуда берется таблица команд, параметры регистрации и прочие переменные в этой функции, как их заполнять, зачем заполнять и т.д.
  2. rshakiro
    Offline

    rshakiro Профессионал в 1С Команда форума

    Регистрация:
    17 мар 2011
    Сообщения:
    2.236
    Симпатии:
    144
    Баллы:
    104
    OXED нравится это.
  3. TopicStarter Overlay
    OXED
    Offline

    OXED Опытный в 1С

    Регистрация:
    10 апр 2012
    Сообщения:
    256
    Симпатии:
    0
    Баллы:
    26
    Спасибо большое. То что нужно

Поделиться этой страницей