7.7 Сумма значнией

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем igorekkrav, 14 апр 2011.

  1. TopicStarter Overlay
    igorekkrav
    Offline

    igorekkrav Опытный в 1С

    Регистрация:
    29 апр 2010
    Сообщения:
    223
    Симпатии:
    0
    Баллы:
    26
    Подскажите как можно получить сумму всех полученных значений ИРПТС


    Код:
    Пока докСчет.ПолучитьСтроку() = 1 Цикл        
    КолТовРез = РегРез.СводныйОстаток(докСчет.Товар,ТекущийДокумент(),"Количество");
    Если КолТовРез > 0 Тогда
    ИРПТС = КолТовРез * докСчет.ЦенаСС;  
    Сообщить("Сумма товаров в резерве "+ИРПТС+"");
    КонецЕсли; 
    КонецЦикла; 
    
    
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Элементарно
    Код:
    Итог=0;
    Пока докСчет.ПолучитьСтроку() = 1 Цикл        
    КолТовРез = РегРез.СводныйОстаток(докСчет.Товар,ТекущийДокумент(),"Количество");
    Если КолТовРез > 0 Тогда
    ИРПТС = КолТовРез * докСчет.ЦенаСС;  
    Итог=Итог+ИРПТС;
    Сообщить("Сумма товаров в резерве "+ИРПТС+"");
    КонецЕсли; 
    КонецЦикла; 
    Сообщить("Общий итог "+Итог);
    
    
  3. TopicStarter Overlay
    igorekkrav
    Offline

    igorekkrav Опытный в 1С

    Регистрация:
    29 апр 2010
    Сообщения:
    223
    Симпатии:
    0
    Баллы:
    26
    Спасибо!! Я почему то на этом всегда застреваю:) Теперь все запомнил:))
  4. Flamepayne
    Offline

    Flamepayne Опытный в 1С

    Регистрация:
    16 мар 2011
    Сообщения:
    113
    Симпатии:
    0
    Баллы:
    26
    Для спасибо существует элементарная кнопка :) Человек все таки откликнулся на Вашу проблему и помог решить :)
  5. TopicStarter Overlay
    igorekkrav
    Offline

    igorekkrav Опытный в 1С

    Регистрация:
    29 апр 2010
    Сообщения:
    223
    Симпатии:
    0
    Баллы:
    26
    Честно всегда нажимаю:))
  6. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Прикольно....Игорь Крав, на ники у сообщений-то смотрим?)))
  7. Flamepayne
    Offline

    Flamepayne Опытный в 1С

    Регистрация:
    16 мар 2011
    Сообщения:
    113
    Симпатии:
    0
    Баллы:
    26
    Мне то за что спс? =) я не могу :angry:

Поделиться этой страницей