7.7 Сумма прописью с другой валютой

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем mass, 3 ноя 2014.

  1. TopicStarter Overlay
    mass
    Offline

    mass

    Регистрация:
    4 сен 2014
    Сообщения:
    20
    Симпатии:
    0
    Баллы:
    1
    В платежных документах сумма прописью пишется в рублях. Как мне изменить на другую валюту (нужно в евро). Те веду учет в евро, а он пишет сумму прописью 97 семь рублей (а нужно евро).
    <ПечСНДСПропись> в процедуре:
    Код:
    ПечСНДСПропись=глСуммаПрописью(глПересчет(Итог("СуммаСНДС"),Валюта,Курс,ВП,ДатаДок),ВП);
    Код:
    Функция глСуммаПрописью(Сумма,Валюта) Экспорт
        Если Константа.ФормыНаУкраинском = Да тогда
            Если ФС.СуществуетФайл(КаталогИБ()+Валюта.ИмяФайлаПрописиУкр)=1 Тогда
                Пропись(Валюта.ИмяФайлаПрописиУкр);
            КонецЕсли; 
        Иначе
            Если ФС.СуществуетФайл(КаталогИБ()+Валюта.ИмяФайлаПрописиРус)=1 Тогда
                Пропись(Валюта.ИмяФайлаПрописиРус);
            КонецЕсли; 
        КонецЕсли;
        СтрокаСуммы=Формат(Сумма,"ЧПДС");
        Пропись("");
        Возврат СтрокаСуммы;
    КонецФункции
    
    это нужно файл *.spl редактировать?

    Вложения:

  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    В параметрах метода Пропись указать имя файла прописи евро
  3. MaxxaM
    Offline

    MaxxaM Опытный в 1С

    Регистрация:
    16 окт 2007
    Сообщения:
    288
    Симпатии:
    2
    Баллы:
    29
    {"Speller",
    {"Money",
    {"Евро","Евро","Евро","цент","цента","центов","M"}},
    {"Numbers",
    {"Один","Два","Три","Четыре","Пять","Шесть","Семь","Восемь","Девять","Одна","Две",
    "Десять","Одиннадцать","Двенадцать","Тринадцать","Четырнадцать","Пятнадцать","Шестнадцать","Семнадцать","Восемнадцать","Девятнадцать",
    "Двадцать","Тридцать","Сорок","Пятьдесят","Шестьдесят","Семьдесят","Восемьдесят","Девяносто",
    "Сто","Двести","Триста","Четыреста","Пятьсот","Шестьсот","Семьсот","Восемьсот","Девятьсот",
    "Тысяча","Тысячи","Тысяч",
    "Миллион","Миллиона","Миллионов",
    "Миллиард","Миллиарда","Миллиардов",
    "Триллион","Триллиона","Триллионов",
    "Ноль"}},
    {"Date",
    {"Январь","Февраль","Март","Апрель","Май","Июнь","Июль","Август","Сентябрь","Октябрь","Ноябрь","Декабрь",
    "Января","Февраля","Марта","Апреля","Мая","Июня","Июля","Августа","Сентября","Октября","Ноября","Декабря",
    "г.","Квартал"}},
    {"DateRange",
    {"Полугодие","Месяцев"}},
    {"WeekDay",
    {"Понедельник","Вторник","Среда","Четверг","Пятница","Суббота","Воскресенье"}}
    }
    сохрани с расширением spl и подтягивай по валюте евро (в базовой конфе пропиши путь к файлу в справочнике валюты)
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    MaxxaM, вы бы первый пост прочитали и процедуру грянули...

Поделиться этой страницей