8.х Структура конфигурации несовместима с текущей версией программы

Тема в разделе "Общие вопросы "1С:Предприятие 8"", создана пользователем chiburato, 30 сен 2009.

  1. TopicStarter Overlay
    chiburato
    Offline

    chiburato

    Регистрация:
    10 июн 2009
    Сообщения:
    6
    Симпатии:
    0
    Баллы:
    1
    Доброе время суток!

    Возникла такая ситуация, на работе установлена Бухгалтерия предприятия (базовая), редакция 1.5 (1.5.10.3) пытаюсь обновить последовательно до версии по настоящий момент, но даже при обновлении на 1.5.12.1 выдает ошибку "Структура конфигурации несовместима с текущей версией программы". Платформа установлена - 8.1.14.72. Как такое получилось не могу добиться у бывшего сисадмина. Помогите пожалуйста исправить данную ситуацию, может у кого был подобный случай. В 1С я новичок, так что буду рад любой помощи. Всем ответившим заранее спасибо.
  2. x_under
    Offline

    x_under Модераторы Команда форума Модератор

    Регистрация:
    25 апр 2007
    Сообщения:
    2.576
    Симпатии:
    13
    Баллы:
    29
    Какая-то из конфигураций для 8.0 обновляха скорее всего.
    У вас изначально была бухгалтерия 1.5 на какой платформе 8.0 или 8.1?
  3. TopicStarter Overlay
    chiburato
    Offline

    chiburato

    Регистрация:
    10 июн 2009
    Сообщения:
    6
    Симпатии:
    0
    Баллы:
    1
    В том то и дело, что я не могу ничего путного от бывшего сисадмина добиться. Что стояло, как и на что обновлялось не знаю :unsure:
  4. x_under
    Offline

    x_under Модераторы Команда форума Модератор

    Регистрация:
    25 апр 2007
    Сообщения:
    2.576
    Симпатии:
    13
    Баллы:
    29
    Так. Вот ты изначально когда начинал обновлять какие версии были???
  5. TopicStarter Overlay
    chiburato
    Offline

    chiburato

    Регистрация:
    10 июн 2009
    Сообщения:
    6
    Симпатии:
    0
    Баллы:
    1
    Изначально я и написал. Бухгалтерия предприятия (базовая), редакция 1.5 (1.5.10.3), платформа установлена - 8.1.14.72
  6. x-a-d
    Offline

    x-a-d Опытный в 1С

    Регистрация:
    3 сен 2009
    Сообщения:
    184
    Симпатии:
    0
    Баллы:
    26
    Нельзя взять последний продукт, и с помощью него произвести обновление.
    Обычно существует цепочка релизов, которые надо ставить поочереди чтобы была возможность поставить последнее(актуальное) обновление.
    Если вы являетесь подписчиком на ИТС, то на ресурсе http://users.v8.1c.ru/ Вы можете скачать все нужные Вам обновления. "Код пользователя" и "пароль" Вам выдадут в фирме, где Вы оформляли подписку на ИТС.
  7. TopicStarter Overlay
    chiburato
    Offline

    chiburato

    Регистрация:
    10 июн 2009
    Сообщения:
    6
    Симпатии:
    0
    Баллы:
    1
    Все релизы уже скачаны. Пытаюсь обновить последовательно. Т.е. 1.5.10.3 на 1.5.12.1, именно при этом и возникает ошибка "Структура конфигурации несовместима с текущей версией программы"
  8. x-a-d
    Offline

    x-a-d Опытный в 1С

    Регистрация:
    3 сен 2009
    Сообщения:
    184
    Симпатии:
    0
    Баллы:
    26
    иногда при выходе новой платформы необходимо проводить конвертацию базы данных в связи с изменениями в платформе.
    у Вас написано
    Следовательно Ваша база уже конвертировалась и возможно не один раз для работы на новой платформе. Как сделать обновление, для которой нужна "старая" платформа, даже не подскажу.
    вот например обсуждение этой же проблемы: http://devtrainingforum.v8.1c.ru/forum/thr...mp;threadtype=0

    Если бы Ваша база не была бы конвертирована...
    А так у меня только одна идея:
    1. установить платформу, для релиза 1.5.10.3
    2. установить чистую базу на основе релиза 1.5.10.3 (назовем "база Х")
    3. выгрузить данные из текущей базы и загрузить их в "база Х"
    4. начать поэтапное обновление релизов для "база Х" и платформы до актуальных
  9. x_under
    Offline

    x_under Модераторы Команда форума Модератор

    Регистрация:
    25 апр 2007
    Сообщения:
    2.576
    Симпатии:
    13
    Баллы:
    29
    Не пугайте так человека. Дело в следующем: релизы БП под 8.1 начиналдись кажется с 1.5.14, а ваш 1.5.12 еще под 8.0.
    Значит заморочки будут, но не страшные. Вам надо конвертировать эту базу под 8.1 и создать свой файл поставки-обновления.
    Иначе никак.
    И так пока не дойдешь для релизов под 8.1
  10. TopicStarter Overlay
    chiburato
    Offline

    chiburato

    Регистрация:
    10 июн 2009
    Сообщения:
    6
    Симпатии:
    0
    Баллы:
    1
    Подскажите пожалуйста как это сделать. Просто я в 1с-ке человек новый
  11. x_under
    Offline

    x_under Модераторы Команда форума Модератор

    Регистрация:
    25 апр 2007
    Сообщения:
    2.576
    Симпатии:
    13
    Баллы:
    29
    Создаешь пустую базу на версии 8.0 с релизом 1.5.12.
    Открываешь ее конфигуратором 8.1.
    В конфигураторе: конфигурация - поставка конфигурации - создать файлы поставки и обновления. Указываешь конфу которую обновляешь.

    Получится файл для обновления 1.5.10 на 1.5.12 но на платформ 8.1
  12. TopicStarter Overlay
    chiburato
    Offline

    chiburato

    Регистрация:
    10 июн 2009
    Сообщения:
    6
    Симпатии:
    0
    Баллы:
    1
    Спасибо большое. Буду пробовать
  13. Vdeg
    Offline

    Vdeg

    Регистрация:
    13 окт 2010
    Сообщения:
    37
    Симпатии:
    0
    Баллы:
    1
    У меня выдаётся аналогичное сообщение при попытке обновить Конфигурацию Зарплата и Управление Персоналом, редакция 2.5.30.4 через поддержку на версию 2.5.31.4.

    [​IMG]

    База данных была сконвертирована на 1С 8.2, запущена платформой 1С 8.2.13.202.

    :angry:
  14. PopOff
    Offline

    PopOff

    Регистрация:
    13 апр 2010
    Сообщения:
    9
    Симпатии:
    0
    Баллы:
    1
    В конфигураторе : Свойства "ЗарплатаИУправлениеПерсоналом", Режим совместимости=Не использовать.
  15. Vdeg
    Offline

    Vdeg

    Регистрация:
    13 окт 2010
    Сообщения:
    37
    Симпатии:
    0
    Баллы:
    1
    Но для этого мне нужно включать возможность изменений?
  16. Vdeg
    Offline

    Vdeg

    Регистрация:
    13 окт 2010
    Сообщения:
    37
    Симпатии:
    0
    Баллы:
    1
    К сожалению, не помогло!

    [​IMG]

    [​IMG]

    [​IMG]

    :angry:

Поделиться этой страницей