7.7 СтрДлина

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем igorekkrav, 27 авг 2010.

  1. TopicStarter Overlay
    igorekkrav
    Offline

    igorekkrav Опытный в 1С

    Регистрация:
    29 апр 2010
    Сообщения:
    223
    Симпатии:
    0
    Баллы:
    26
    Подскажите пожалуйста есть функция СтрДлина . Есть код

    Код:
    Если СтрДлина(стрПозиция) > 10 Тогда 
    Предупреждение 	(""+стрПозиция+"")
    КонецЕсли;
    
    Как из не го сделать смысл следующий : Если строка больше 10 Тогда сказать что это за строка :) :unsure:
  2. shurikvz
    Offline

    shurikvz Модераторы Команда форума Модератор

    Регистрация:
    1 окт 2009
    Сообщения:
    8.409
    Симпатии:
    316
    Баллы:
    104
    А чем вами же приведенный код не устраивает?
  3. TopicStarter Overlay
    igorekkrav
    Offline

    igorekkrav Опытный в 1С

    Регистрация:
    29 апр 2010
    Сообщения:
    223
    Симпатии:
    0
    Баллы:
    26
    Он просто говорит строки . А вот как сделать чтобы он говорил о тех строках которые больше 10 не понятно как реализовать
  4. shurikvz
    Offline

    shurikvz Модераторы Команда форума Модератор

    Регистрация:
    1 окт 2009
    Сообщения:
    8.409
    Симпатии:
    316
    Баллы:
    104
    Непонимаю.
    Которые длиной больше 10 символов? "стрПозиция" - это что такое?
  5. TopicStarter Overlay
    igorekkrav
    Offline

    igorekkrav Опытный в 1С

    Регистрация:
    29 апр 2010
    Сообщения:
    223
    Симпатии:
    0
    Баллы:
    26
    Да которые больше 10 .
    Код:
    стрПозиция
    
    
    это массив в котором (ИНН несколько штук) . Вот я хочу из него получить только то что больше 10 символов.
  6. shurikvz
    Offline

    shurikvz Модераторы Команда форума Модератор

    Регистрация:
    1 окт 2009
    Сообщения:
    8.409
    Симпатии:
    316
    Баллы:
    104
    Точно массив? Не список значений или таблица значений?
  7. TopicStarter Overlay
    igorekkrav
    Offline

    igorekkrav Опытный в 1С

    Регистрация:
    29 апр 2010
    Сообщения:
    223
    Симпатии:
    0
    Баллы:
    26
    тьфу ошибся :unsure: . Да список значений
  8. shurikvz
    Offline

    shurikvz Модераторы Команда форума Модератор

    Регистрация:
    1 окт 2009
    Сообщения:
    8.409
    Симпатии:
    316
    Баллы:
    104
    Как-то так:
    Код:
    Значение = "";
    Для НомерСтрокиСписка = 1 По стрПозиция.РазмерСписка() Цикл
    Значение = стрПозиция.ПолучитьЗначение(НомерСтрокиСписка);
    Если СтрДлина(СокрЛП(Значение)) > 10 Тогда
    //Предупреждение(Значение);
    Сообщить(Значение);
    КонецЕсли;
    КонецЦикла;
    
    
  9. TopicStarter Overlay
    igorekkrav
    Offline

    igorekkrav Опытный в 1С

    Регистрация:
    29 апр 2010
    Сообщения:
    223
    Симпатии:
    0
    Баллы:
    26
    Спасибо я сейчас попробую!!!
  10. TopicStarter Overlay
    igorekkrav
    Offline

    igorekkrav Опытный в 1С

    Регистрация:
    29 апр 2010
    Сообщения:
    223
    Симпатии:
    0
    Баллы:
    26
    А с таблицей значений так же можно?
  11. shurikvz
    Offline

    shurikvz Модераторы Команда форума Модератор

    Регистрация:
    1 окт 2009
    Сообщения:
    8.409
    Симпатии:
    316
    Баллы:
    104
    Естественно.
    Код:
    Значение = "";
    стрПозиция.ВыбратьСтроки();
    Пока стрПозиция.ПолучитьСтроку() = 1 Цикл
    Значение = стрПозиция.НазваниеКолонкиСоЗначением;
    Если СтрДлина(СокрЛП(Значение)) > 10 Тогда
    //Предупреждение(Значение);
    Сообщить(Значение);
    КонецЕсли;
    КонецЦикла;
    
    
  12. TopicStarter Overlay
    igorekkrav
    Offline

    igorekkrav Опытный в 1С

    Регистрация:
    29 апр 2010
    Сообщения:
    223
    Симпатии:
    0
    Баллы:
    26
    Всё шикарно получилось . Спасибо :unsure: А есть возможность удалить из данных ТЗ , 3 символа?
  13. TopicStarter Overlay
    igorekkrav
    Offline

    igorekkrav Опытный в 1С

    Регистрация:
    29 апр 2010
    Сообщения:
    223
    Симпатии:
    0
    Баллы:
    26
    Всё я решил!Спасибо за помощь!

Поделиться этой страницей