8.х Странности при обходе выборки из запроса

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем НеАнгел, 7 фев 2008.

  1. TopicStarter Overlay
    НеАнгел
    Offline

    НеАнгел

    Регистрация:
    20 ноя 2007
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    1
    В ОбработкеПроведения ПКО добавлен следующий код. При обходе выборки, вывожу в табло, что она содержит 5 значений. Он записывает только 2, и то не по порядку, а сначала 2, потом 4. Движения делаются в том же регистре, что и выборка из запроса. В чем может быть дело?

    Код:
    Если ВидОперации = Перечисления.ВидыОперацийПКО.ОплатаПокупателя Тогда 
    
    Для Каждого ТекСтрока Из РасшифровкаПлатежа Цикл
    Запрос = Новый Запрос();
    Запрос.Текст =
    "ВЫБРАТЬ
    |    осиПланПоступленийОстатки.Договор,
    |    осиПланПоступленийОстатки.СуммаОстаток,
    |    осиПланПоступленийОстатки.НомерВыпуска
    |ИЗ
    |    РегистрНакопления.осиПланПоступлений.Остатки(&НачДата, ) КАК осиПланПоступленийОстатки
    |ГДЕ
    |    осиПланПоступленийОстатки.Договор = &Договор";
    
    Запрос.УстановитьПараметр("НачДата", Дата);
    Запрос.УстановитьПараметр("Договор", ДоговорКонтрагента);
    Выборка = Запрос.Выполнить().Выбрать();      
    СуммаП=ТекСтрока.СуммаПлатежа;
    Выборка.Сбросить();
    Пока Выборка.Следующий() Цикл                      
    // регистр осиПланПоступлений Расход
    
    
    Движение = Движения.осиПланПоступлений.Добавить();
    Движение.ВидДвижения = ВидДвиженияНакопления.Расход;
    Движение.Организация = Организация;
    Движение.Период = Дата;
    Движение.НоменклатурнаяГруппа = ТекСтрока.ДоговорКонтрагента.осиНоменклатурнаяГруппа;
    Движение.Контрагент = Контрагент;
    Движение.Договор = ТекСтрока.ДоговорКонтрагента;
    Движение.НомерВыпуска=Выборка.НомерВыпуска;
    Зачесть=Мин(СуммаП,Выборка.СуммаОстаток);            
    Движение.Сумма = зачесть;
    Если зачесть=СуммаП тогда
    Прервать;    
    КонецЕсли;
    СуммаП=СуммаП-зачесть;
    КонецЦикла;            
    КонецЦикла;
    
    
    Используйте тэг
    Код:
    
    

Поделиться этой страницей