8.х Странная ошибка

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем serzh44, 25 мар 2008.

  1. TopicStarter Overlay
    serzh44
    Offline

    serzh44

    Регистрация:
    19 мар 2008
    Сообщения:
    11
    Симпатии:
    0
    Баллы:
    1
    Моя задача - вывести все элементы управления на всех формах.

    Код:
    Процедура КнопкаВыполнитьНажатие(Кнопка)
    // Вставить содержимое обработчика.
    Перем ф;
    
    НачальныеУстановки();
    
    Таблица1=Новый ТаблицаЗначений;
    Таблица1.Колонки.Добавить("Форма");
    Таблица1.Колонки.Добавить("Имя");
    Таблица1.Колонки.Добавить("Тип");
    Таблица1.Колонки.Добавить("Подсказка");
    Таблица1.Колонки.Добавить("Данные");
    
    
    Для каждого Объект из Метаданные.ОбщиеФормы Цикл
    Форма=ПолучитьОбщуюФорму(Объект);
    Проверить(Объект,Форма);
    КонецЦикла;
    
    Для каждого Объект из Метаданные.Справочники Цикл
    Для каждого Форма из Объект.Формы Цикл
    Выполнить("ф=Справочники."+Объект.Имя+".ПолучитьФорму("""+Форма.Имя+""");");
    Проверить(Форма,ф);
    КонецЦикла;
    КонецЦикла;
    
    
    
    
    
    ЭлементыФормы.ТабПоле1.Значение=Таблица1;	
    ЭлементыФормы.ТабПоле1.СоздатьКолонки();
    
    
    
    ЭтаФорма.ОбщЧисло=Строка(ЧислоЭлементов);
    ЭтаФорма.КолОшибок=Строка(КоличествоОшибок);
    КонецПроцедуры
    
    Процедура Проверить(Объект, Форма)
    Для каждого Элемент Из Форма.ЭлементыФормы Цикл
    ЧислоЭлементов=ЧислоЭлементов+1;        
    Строка=Таблица1.Добавить();
    Строка.Форма=Объект.ПолноеИмя();
    Строка.Имя=Элемент.Имя;
    Строка.Тип=Тип(Элемент);
    Попытка
    Строка.Подсказка=Элемент.Подсказка;	
    Исключение
    Строка.Подсказка="Неопределено";	
    КонецПопытки;
    
    Попытка
    Строка.Данные=Элемент.Данные	
    Исключение
    Строка.Данные="Неопределено";	
    КонецПопытки;
    
    КонецЦикла;
    КонецПроцедуры
    
    Этот код должен обойти общие формы и формы справочников. Он работает, но на некотрых формах вылезает ошибка (похожие есть и на других формах):

    {Справочник.Номенклатура.Форма.ФормаПоискаПоНоменклатуреКонтрагента(103)}: Значение не является значением объектного типа (ЭлементыФормы)
    ЦветРамкиПоиска = ФормаОтбора.ЭлементыФормы.фСтрокаПоиска.ЦветРамки;

    Т.е.ошибка в модуле формы, хотя в режиме предприятия эта форма нормально открывается! Я не понимаю как связан мой код и эта ошибка? И почему она вобще может возникать?
  2. TopicStarter Overlay
    serzh44
    Offline

    serzh44

    Регистрация:
    19 мар 2008
    Сообщения:
    11
    Симпатии:
    0
    Баллы:
    1
    На верно я не в тот раздел написал....но всё равно помогите плиз! от чего это может быть?
  3. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    Дык отладчиком посмотри, что у тебя там...

Поделиться этой страницей