7.7 Стоп фактор при проведении документов

Тема в разделе "Типовые решения "1С:Предприятие 7.7"", создана пользователем admin, 15 апр 2009.

  1. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    у вас какая валюта стоит управленческого учета? рубли?
  2. Ivan-Vasilich
    Offline

    Ivan-Vasilich

    Регистрация:
    24 сен 2015
    Сообщения:
    8
    Симпатии:
    0
    Баллы:
    1
    Доллары, делал обманным путем замену валюты упр. учета с долл. на рубли, надо перепроводить все документы. Сделали немного иначе. В документ ОтчетККМ добавил код
    ВыбратьСтроки();
    Пока ПолучитьСтроку()=1 Цикл
    Если НазваниеНабораПрав()<>"Администратор" Тогда
    ЗакупЦена=0;ЗакупЕдЦены=Единица;ЗакупВалЦены=Валюта;
    Если глВернутьЦену(Номенклатура, Константа.ЗакупочныйТипЦен, ДатаДок, ЗакупЦена, ЗакупЕдЦены, ЗакупВалЦены)=1 Тогда
    ЗакупЦена=глОкруглить(ЗакупЦена*(100+Константа.МинПроцентНаценки)/100,Константа.ЗакупочныйТипЦен.ПорядокОкругления);
    Если ЗакупЦена>Цена Тогда
    Сообщить("Рассчитанная цена "+Цена+" на товар "+Номенклатура+" меньше минимальной наценки. Необходима переоценка до рекомендуемой цены "+ЗакупЦена,"!");
    Цена=ЗакупЦена;
    КонецЕсли;
    КонецЕсли;
    КонецЕсли;
    КонецЦикла;

    Его же добавляем в Процедура глПересчитатьЦенуВДокументе
    Добавим еще константы МинПроцентНаценки и ЗакупочныйТипЦен.

    Но только вот замучали продавцы на рознице, цена меняется на минимальный процент наценки. Пришлось убирать дописки.
  3. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Доллары... Вот поэтому и не работает
  4. Ivan-Vasilich
    Offline

    Ivan-Vasilich

    Регистрация:
    24 сен 2015
    Сообщения:
    8
    Симпатии:
    0
    Баллы:
    1
    Да, но перепроводить все не решились, т.к длинные обмены будут на периферийных базах. Будем искать другие пути
  5. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    применяйте ваш код, только с уточнентем... Добавьте еще дельту порога срабатывания

Поделиться этой страницей