7.7 Ссылки на печятной форме

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем geba, 9 июн 2010.

  1. TopicStarter Overlay
    geba
    Offline

    geba

    Регистрация:
    27 авг 2009
    Сообщения:
    41
    Симпатии:
    0
    Баллы:
    1
    Код:
    Процедура ОбработкаЯчейкиТаблицы(Расшифровка, СтандартнаяОбработка, Таблица) Экспорт
    Перем Отчет, Конт;
    
    Если ТипЗначенияСтр(Расшифровка) <> "СписокЗначений" Тогда
    СтандартнаяОбработка = 1;
    Возврат;
    КонецЕсли;
    
    // расшифровка для расчетных отчетов
    Меню = СоздатьОбъект("СписокЗначений");
    
    Объект = Расшифровка.Получить("Объект");
    Если (ТипЗначенияСтр(Объект) = "Документ") И (ПустоеЗначение(Объект) = 0) Тогда
    // на документ
    Меню.ДобавитьЗначение("Документ");
    Меню.ДобавитьЗначение("Журнал");
    Если Меню.ВыбратьЗначение(Отчет, "",,, 1) = 1 Тогда
    Если Отчет = "Документ" Тогда
    Стр = Расшифровка.Получить("СтрокаДокумента");
    
    ОткрытьФорму(Объект, Конт);
    Конт.АктивизироватьСтроку(Стр);
    Иначе    
    ОткрытьФорму("Журнал.ПолныйЖурнал", Конт);
    Конт.АктивизироватьОбъект(Объект);
    КонецЕсли;;
    КонецЕсли;
    ИначеЕсли (ТипЗначенияСтр(Объект) = "Справочник") И (ПустоеЗначение(Объект) = 0) Тогда
    // на справочник
    ОткрытьФорму(Объект, Конт);
    ИначеЕсли (ТипЗначенияСтр(Объект) = "СписокЗначений") И (ПустоеЗначение(Объект) = 0) Тогда
    // список - показать
    Объект.ВыбратьЗначение("", "",,, 0);
    ИначеЕсли (ТипЗначенияСтр(Объект) = "Строка") И (ПустоеЗначение(Объект) = 0) Тогда
    // на отчет
    Если Расшифровка.Получить("Меню") = 1 Тогда
    Меню = СоздатьОбъект("СписокЗначений");
    Если Меню.ВыбратьЗначение(Отчет, "",,, 1) = 0 Тогда
    Возврат;
    КонецЕсли;
    Иначе
    Отчет = Объект;
    КонецЕсли;
    глРасшифровка = Расшифровка;
    глФлагРасшифровки = 1;
    глОбновить = Число(Расшифровка.Получить("Обновить"));
    Если глОбновить <> 0 Тогда
    глТаблица = Таблица;
    КонецЕсли;
    Если Найти(Отчет, ".ert") > 0 Тогда
    ОткрытьФорму("Отчет#", , Отчет);
    Иначе
    ОткрытьФорму("Отчет."+Отчет+"#");
    КонецЕсли;
    глФлагРасшифровки = 0;
    глРасшифровка = 0;
    глОбновить = 0;
    Возврат;
    КонецЕсли;
    Меню = 0;
    
    // расшифровка для бухгалтерских отчетов
    Док = Расшифровка.Получить("Документ");
    Если ТипЗначения(Док) <> 0 Тогда
    ОткрытьФорму("Операция",, Док, Расшифровка.Получить("НомерПроводки"),
    Расшифровка.Получить("НомерКорреспонденции"),-1);
    Иначе
    // если в списке Расшифровка присутствует значение "ДокументЖурнала", и оно непусто
    // то запускаем полный журнал документа с позиционированием на "ДокументЖурнала"
    ДокументЖурнала=Расшифровка.Получить("ДокументЖурнала");
    Если ПустоеЗначение(ДокументЖурнала)=0 Тогда
    КонтЖурн=ДокументЖурнала;
    Если ОткрытьФорму("Журнал.ПолныйЖурнал.ФормаСписка",КонтЖурн)=0 Тогда
    Возврат;
    КонецЕсли;
    СтандартнаяОбработка = 0;
    Возврат;
    ИначеЕсли Расшифровка.Получить("Меню") = 1 Тогда
    Меню = СоздатьОбъект("СписокЗначений");
    Меню.ДобавитьЗначение("КарточкаСчета", "Карточка счета");
    Если Расшифровка.Получить("Счет").КоличествоСубконто() > 0 Тогда
    Меню.ДобавитьЗначение("ОборотноСальдоваяВедомостьПоСчету", "Ведомость по счету");
    КонецЕсли;
    Меню.ДобавитьЗначение("АнализСчета", "Анализ счета");
    Меню.ДобавитьЗначение("ОтчетПоПроводкам", "Отчет по проводкам");
    Меню.ДобавитьЗначение("ГлавнаяКнига", "Обороты счета (Гл. книга)");
    Меню.ДобавитьЗначение("ЖурналОрдерПоСубконто", "Журнал-ордер по субконто");
    Если Меню.ВыбратьЗначение(Отчет, "",,, 1) = 0 Тогда
    Возврат;
    КонецЕсли;
    Иначе
    Отчет = Расшифровка.Получить("Отчет");
    КонецЕсли;
    
    глРасшифровка = Расшифровка;
    глФлагРасшифровки = 1;
    глОбновить = Число(Расшифровка.Получить("Обновить"));
    Если глОбновить <> 0 Тогда
    глТаблица = Таблица;
    КонецЕсли;
    
    Если Отчет = "ОборотноСальдоваяВедомостьПоСчету" Тогда
    Счет = Расшифровка.Получить("Счет");
    Если Счет.КоличествоСубконто() = 0 Тогда
    Расшифровка.Установить("ДанныеПоСубсчетам", Счет.ЭтоГруппа());
    КонецЕсли;
    КонецЕсли;                                                  
    
    Если ПустаяСтрока(Отчет) = 0 Тогда
    Если Найти(Отчет, ".ert") > 0 Тогда
    ОткрытьФорму("Отчет#", , Отчет);
    Иначе
    ОткрытьФорму("Отчет."+Отчет+"#");
    КонецЕсли;
    КонецЕсли;
    глФлагРасшифровки = 0;
    глРасшифровка = 0;
    глОбновить = 0;
    КонецЕсли;
    КонецПроцедуры //ОбработкаЯчейкиТаблицы
    
    MD
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Код:
    Процедура ОбработкаЯчейкиТаблицы(Расшифровка,СтандартнаяОбработка, Таблица) Экспорт
    Перем Отчет, Конт;    
    Если ТипЗначенияСтр(Расшифровка) <> "СписокЗначений" Тогда
    СтандартнаяОбработка = 1;        
    Возврат;    
    КонецЕсли;
    ....
    
    
    
    У вас расшифровка Документ а не СписокЗначений. Так что процедура тут не виновата.Копайте в процедуре открытия документа
  3. TopicStarter Overlay
    geba
    Offline

    geba

    Регистрация:
    27 авг 2009
    Сообщения:
    41
    Симпатии:
    0
    Баллы:
    1
    Короче, на сервере все роботает супер, на локальном компе выскакивают ошибки.

    Всем спасибо за помощь!!! :unsure:

Поделиться этой страницей