8.х Срок

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Эмиль0690, 19 май 2015.

  1. XXL
    Offline

    XXL Опытный в 1С Команда форума

    Регистрация:
    22 янв 2007
    Сообщения:
    1.159
    Симпатии:
    19
    Баллы:
    29
    -Banghead-
    --- Объединение сообщений, 20 май 2015 ---
    Не параметр, реквизит.

    Что значит "скриншоты не работают"???
  2. TopicStarter Overlay
    Эмиль0690
    Offline

    Эмиль0690 Опытный в 1С

    Регистрация:
    3 фев 2014
    Сообщения:
    290
    Симпатии:
    2
    Баллы:
    29
    вот этот скриншот не работает тоже самое что у меня есть код результаты одинаковы т.е срок пункт2 пусто
    Код:
    &НаКлиенте
    Процедура ОбновитьСроки()
      Объект.Срок = (НачалоДня(Объект.ДатаЗаезда) - НачалоДня(Объект.ДатаВыезда)) / 86400;
      Объект.Срок2 = (НачалоДня(Объект.ДатаЗаездаПункт2) - НачалоДня(Объект.ДатаВыездаПункт2)) / 86400;
    КонецПроцедуры
    
    &НаКлиенте
    Процедура ДатаВыездаПриИзменении(Элемент)
      ОбновитьСроки();
    КонецПроцедуры
    
    &НаКлиенте
    Процедура ДатаВыездаПункт2ПриИзменении(Элемент)
      ОбновитьСроки();
    КонецПроцедуры
    upload_2015-5-21_13-33-5.png
  3. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.782
    Симпатии:
    509
    Баллы:
    204
    Все реквизиты объекта заполняйте на сервере, на клиенте делайте только обновление данных.
  4. TopicStarter Overlay
    Эмиль0690
    Offline

    Эмиль0690 Опытный в 1С

    Регистрация:
    3 фев 2014
    Сообщения:
    290
    Симпатии:
    2
    Баллы:
    29
    все варианты пере пробовал все равно Срок2 не хочет работать
    здесь что-то не то
    Код:
    &НаСервере
    Процедура ОбновитьСрокиСервер();
      Объект.Срок = (НачалоДня(Объект.ДатаЗаезда) - НачалоДня(Объект.ДатаВыезда)) / 86400;
      //Объект.Срок2 = (НачалоДня(Объект.ДатаЗаездаПункт2) - НачалоДня(Объект.ДатаВыездаПункт2)) / 86400;
    КонецПроцедуры
    
    &НаСервере
    Процедура ОбновитьСрокиСерверСрок2();
      //Объект.Срок = (НачалоДня(Объект.ДатаЗаезда) - НачалоДня(Объект.ДатаВыезда)) / 86400;
      Объект.Срок2 = (НачалоДня(Объект.ДатаЗаездаПункт2) - НачалоДня(Объект.ДатаВыездаПункт2)) / 86400;
    КонецПроцедуры
    
    
    &НаКлиенте
    Процедура ДатаВыездаПриИзменении(Элемент)
    ОбновитьСрокиСервер();
    КонецПроцедуры
    
    &НаКлиенте
    Процедура ДатаВыездаПункт2ПриИзменении(Элемент)
      ОбновитьСрокиСерверСрок2();
    КонецПроцедуры
    
  5. TopicStarter Overlay
    Эмиль0690
    Offline

    Эмиль0690 Опытный в 1С

    Регистрация:
    3 фев 2014
    Сообщения:
    290
    Симпатии:
    2
    Баллы:
    29
    Добрый день!
    посмотрите код пожалуйста где неправильно??
  6. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.782
    Симпатии:
    509
    Баллы:
    204
    Отладчик вам в помощь.
    Еще добавьте:
    Код:
    &НаКлиенте
    Процедура ДатаВыездаПриИзменении(Элемент)
    ОбновитьСрокиСервер();
    ОбновитьОтображениеДанных();
    КонецПроцедуры
  7. Yuriy_Alexandrovich
    Offline

    Yuriy_Alexandrovich Профессионал в 1С Команда форума

    Регистрация:
    15 сен 2011
    Сообщения:
    1.275
    Симпатии:
    76
    Баллы:
    54
    Доброго дня, такое впечатление что тип у "Объект.ДатаЗаездаПункт2" - Дата, а не ДатаВремя
    --- Объединение сообщений, 22 май 2015 ---
    проверьте типы данных
  8. TopicStarter Overlay
    Эмиль0690
    Offline

    Эмиль0690 Опытный в 1С

    Регистрация:
    3 фев 2014
    Сообщения:
    290
    Симпатии:
    2
    Баллы:
    29
    все одинаковы я думая проблема в коде
    upload_2015-5-22_15-40-57.png

    upload_2015-5-22_15-41-23.png
    upload_2015-5-22_15-44-49.png
    upload_2015-5-22_15-45-15.png
    --- Объединение сообщений, 22 май 2015 ---
    вот этот код работает но срок2 работает когда хочет т.е можно получить срок при первом изменение а если второй раз при изменение не работает
    upload_2015-5-22_15-51-25.png

    Код:
    &НаСервере
    Процедура ОбновитьСрокиСервер();
      Объект.Срок = (НачалоДня(Объект.ДатаЗаезда) - НачалоДня(Объект.ДатаВыезда)) / 86400;
      //Объект.Срок2 = (НачалоДня(Объект.ДатаЗаездаПункт2) - НачалоДня(Объект.ДатаВыездаПункт2)) / 86400;
    КонецПроцедуры
    
    &НаКлиенте
    Процедура ДатаВыездаПриИзменении(Элемент)
    ОбновитьСрокиСервер();
    ОбновитьОтображениеДанных();
    КонецПроцедуры
    
    
    &НаСервере
    Процедура ОбновитьСрокиСерверСрок2();
      //Объект.Срок = (НачалоДня(Объект.ДатаЗаезда) - НачалоДня(Объект.ДатаВыезда)) / 86400;
      Объект.Срок2 = (НачалоДня(Объект.ДатаЗаездаПункт2) - НачалоДня(Объект.ДатаВыездаПункт2)) / 86400;
    КонецПроцедуры
    
    
    
    &НаКлиенте
    Процедура ДатаВыездаПункт2ПриИзменении(Элемент)
      ОбновитьСрокиСерверСрок2();
      ОбновитьОтображениеДанных();
    КонецПроцедуры
    
    Последнее редактирование: 22 май 2015
  9. Yuriy_Alexandrovich
    Offline

    Yuriy_Alexandrovich Профессионал в 1С Команда форума

    Регистрация:
    15 сен 2011
    Сообщения:
    1.275
    Симпатии:
    76
    Баллы:
    54
    Зря поставил галки "Неотрицательное"
  10. XXL
    Offline

    XXL Опытный в 1С Команда форума

    Регистрация:
    22 янв 2007
    Сообщения:
    1.159
    Симпатии:
    19
    Баллы:
    29
    Проверяйте отладчиком код именно при изменении выезд пункт2
  11. TopicStarter Overlay
    Эмиль0690
    Offline

    Эмиль0690 Опытный в 1С

    Регистрация:
    3 фев 2014
    Сообщения:
    290
    Симпатии:
    2
    Баллы:
    29
    почему зря? для чего он мне понадобиться?
  12. Yuriy_Alexandrovich
    Offline

    Yuriy_Alexandrovich Профессионал в 1С Команда форума

    Регистрация:
    15 сен 2011
    Сообщения:
    1.275
    Симпатии:
    76
    Баллы:
    54
    повторил в внешней обработке, все работает, ну конечно в приведенном коде нет обработчиков отрабатывающих при изменении дат заезда.
    --- Объединение сообщений, 22 май 2015 ---
    upload_2015-5-22_15-31-18.png
    --- Объединение сообщений, 22 май 2015 ---
    у вас нет проверок правильности ввода дат, в некоторых случаях разница будет отрицательной и будет 0
  13. TopicStarter Overlay
    Эмиль0690
    Offline

    Эмиль0690 Опытный в 1С

    Регистрация:
    3 фев 2014
    Сообщения:
    290
    Симпатии:
    2
    Баллы:
    29
    Благодарю!
    Все работает!
    ошибка в отрицательном
    Код:
    &НаСервере
    Процедура ОбновитьСрокиСервер();
      Объект.Срок = (НачалоДня(Объект.ДатаЗаезда) - НачалоДня(Объект.ДатаВыезда)) / 86400;
      //Объект.Срок2 = (НачалоДня(Объект.ДатаЗаездаПункт2) - НачалоДня(Объект.ДатаВыездаПункт2)) / 86400;
    КонецПроцедуры
    
    &НаКлиенте
    Процедура ДатаВыездаПриИзменении(Элемент)
    ОбновитьСрокиСервер();
    ОбновитьОтображениеДанных();
    КонецПроцедуры
    
    
    &НаСервере
    Процедура ОбновитьСрокиСерверСрок2();
      //Объект.Срок = (НачалоДня(Объект.ДатаЗаезда) - НачалоДня(Объект.ДатаВыезда)) / 86400;
      //Объект.Срок2 = (НачалоДня(Объект.ДатаЗаездаПункт2) - НачалоДня(Объект.ДатаВыездаПункт2)) / 86400;
      Объект.Срок2 = (НачалоДня(Объект.ДатаВыездаПункт2) - НачалоДня(Объект.ДатаЗаездаПункт2)) / 86400;
    
    КонецПроцедуры
    
    
    
    &НаКлиенте
    Процедура ДатаВыездаПункт2ПриИзменении(Элемент)
      ОбновитьСрокиСерверСрок2();
      ОбновитьОтображениеДанных();
    КонецПроцедуры
    
  14. Yuriy_Alexandrovich
    Offline

    Yuriy_Alexandrovich Профессионал в 1С Команда форума

    Регистрация:
    15 сен 2011
    Сообщения:
    1.275
    Симпатии:
    76
    Баллы:
    54
    Гыыы. :)

    Молодец.
  15. TopicStarter Overlay
    Эмиль0690
    Offline

    Эмиль0690 Опытный в 1С

    Регистрация:
    3 фев 2014
    Сообщения:
    290
    Симпатии:
    2
    Баллы:
    29
    Всем Спасибо!
    особенно моему деду alexburn ;)
    --- Объединение сообщений, 22 май 2015 ---
    а почему в отрицательном не работал?
    alexburn нравится это.
  16. Yuriy_Alexandrovich
    Offline

    Yuriy_Alexandrovich Профессионал в 1С Команда форума

    Регистрация:
    15 сен 2011
    Сообщения:
    1.275
    Симпатии:
    76
    Баллы:
    54
    потомуштааа ограничения типа значений, сами же поставили галку "неотрицательное"

Поделиться этой страницей